DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 8th July 2009
Mantazz Mantazz is offline
Shell Scout
 
Join Date: Oct 2008
Posts: 90
Thanked 0 Times in 0 Posts
Default Xorg starts with numlock on

I finally have XOrg and KDE running on my laptop, running 7.2-release. However I have one significant problem now, XOrg starts with numlock on, and I cannot seem to disable it. Being as this is a laptop keyboard, this turns several important keys into numbers.

What do I need to do to correct this? I set KDE to turn the num lock off when it starts but that doesn't seem to work. I see that when X is first loading, before KDE actually starts up, the num lock is turned on at that point.
Reply With Quote
  #2   (View Single Post)  
Old 9th July 2009
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,062
Thanked 198 Times in 156 Posts
Default

I use numlockx in ~/.xinitrc:
http://www.freshports.org/x11/numlockx/

Ifm you're using KDM/GDM you will probably need to add to a different startup script (Which I do not know).
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
  #3   (View Single Post)  
Old 9th July 2009
Mantazz Mantazz is offline
Shell Scout
 
Join Date: Oct 2008
Posts: 90
Thanked 0 Times in 0 Posts
Default

I don't have any documentation for numlockx; it seems designed to turn numlock on - I need to turn it off. Is there an option to do that?
Reply With Quote
  #4   (View Single Post)  
Old 9th July 2009
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

I use Xorg under OpenBSD, without a DE.. numlock is off.

It's more likely that KDE is controlling it as Carpetsmoker has suggested.

I found this guide.. via Google:
http://linux.about.com/od/kubuntu_doc/a/kubudg35t07.htm
Reply With Quote
  #5   (View Single Post)  
Old 10th July 2009
Mantazz Mantazz is offline
Shell Scout
 
Join Date: Oct 2008
Posts: 90
Thanked 0 Times in 0 Posts
Default

Quote:
It's more likely that KDE is controlling it as Carpetsmoker has suggested.
I would have expected the same, but that is not the case. If I run xinit without an .xinit.rc file (so that no desktop environment starts) I have the same problem with num lock turning itself on.

Any other ideas? I have set KDE to turn it off when it starts, but it doesn't work. I would be more than happy to just disable num lock entirely as this is a laptop keyboard, but I can't find a way to do that.
Reply With Quote
  #6   (View Single Post)  
Old 10th July 2009
Mantazz Mantazz is offline
Shell Scout
 
Join Date: Oct 2008
Posts: 90
Thanked 0 Times in 0 Posts
Default

After some more experimentation I found that indeed
Code:
numlockx off
does turn off numlock. Granted this wasn't a trivial feat to accomplish without being able to use the letter "o" on my keyboard (as it becomes the number 6 with numlock on).

I eventually wrote a shell script for my ~/bin directory, which I called "wwww" (since the letter w is not effected by the status of numlock) that essentially just invoked the command above.

Then, once I could boot into KDE and use all my keys, I went to
system settings -> advanced -> autostart -> where I could enter the same command to be started on starting KDE.
Reply With Quote
  #7   (View Single Post)  
Old 10th July 2009
BSDKaffee's Avatar
BSDKaffee BSDKaffee is offline
Real Name: Jason Hale
Coffee Addict
 
Join Date: May 2008
Location: Wintersville, Ohio
Posts: 212
Thanked 36 Times in 34 Posts
Default

Quote:
Originally Posted by Mantazz View Post
I don't have any documentation for numlockx; it seems designed to turn numlock on - I need to turn it off. Is there an option to do that?
Yes:
numlockx on - Turn numlock on
numlockx off - Turn numlock off
numlockx toggle - If numlock is on, turn it off; if numlock is off, turn it on

You could put that into a KDE autostart script. Perhaps even putting it in .xinitrc would work.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg taking the fun out of BSD Carpetsmoker General software and network 122 6th December 2010 01:21 PM
Xorg freeze? xfel OpenBSD Installation and Upgrading 2 6th November 2008 09:37 PM
executing commands for all users when X starts with KDM caesius FreeBSD General 2 20th October 2008 09:03 AM
Is xorg necessary....... rex FreeBSD General 10 19th October 2008 03:05 PM
xorg bug? enterhaken FreeBSD Ports and Packages 9 17th July 2008 02:38 PM


All times are GMT. The time now is 04:00 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick