DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 18th May 2008
nihonto nihonto is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 65
Thanked 1 Time in 1 Post
Default Cups + USB-Printer

Hi there,

since OpenBSD 4.3 the Gutenprint drivers are available and yesterday I have tried to install Cups with Gutenprint on my Epson C42UX inkjet printer (an older, cheap model that runs with Cups and Gutenprint perfectly under Debian).

I've installed cups and ghostscript, exchanged ghostscript and installed ghostscript-cups (via "pkg_add -r") and then, as last step, I've installed Gutenprint and Gutenprint-Cups.

In the Browserinterface (localhost:631) I could choose the driver for my printer and everything looked perfect.

But when I try to print a testpage nothing happens at the printer. A look into /var/log/cups/error-log shows:

Quote:
I [18/May/2008:12:19:58 +0200] Started "/usr/local/libexec/cups/cgi-bin/printers
.cgi" (pid=8809)
I [18/May/2008:12:19:58 +0200] Adding start banner page "none" to job 10.
I [18/May/2008:12:19:58 +0200] Adding end banner page "none" to job 10.
I [18/May/2008:12:19:58 +0200] Job 10 queued on "C42UX" by "root".
I [18/May/2008:12:19:58 +0200] Started filter /usr/local/libexec/cups/filter/pst
ops (PID 24141) for job 10.
I [18/May/2008:12:19:58 +0200] Started filter /usr/local/libexec/cups/filter/pst
oraster (PID 16550) for job 10.
I [18/May/2008:12:19:58 +0200] Started filter /usr/local/libexec/cups/filter/ras
tertogutenprint.5.0 (PID 23904) for job 10.
I [18/May/2008:12:19:58 +0200] Started backend /usr/local/libexec/cups/backend/u
sb (PID 10678) for job 10.
E [18/May/2008:12:19:58 +0200] PID 10678 (/usr/local/libexec/cups/backend/usb) s
topped with status 1!
I [18/May/2008:12:19:58 +0200] Hint: Try setting the LogLevel to "debug" to find
out more.
E [18/May/2008:12:19:58 +0200] [Job 10] Unable to open USB device "usb:/dev/ulpt
0": Permission denied
When I look for "ls -l /dev/ulpt0" it shows:

Quote:
# ls -l /dev/ulpt0
crw-rw---- 1 root wheel 64, 0 Apr 17 23:53 /dev/ulpt0
My user is member of the group "wheel"

And when I try out "chmod 666 /dev/ulpt0" the printer starts printing nonsense (a clutter of letters and symbols).

So, what have I done wrong or which step is missing?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
darn cUPS da1 FreeBSD General 0 18th February 2009 07:15 PM
Cups + Netbsd = pstoraster failed TMD3 NetBSD Package System (pkgsrc) 2 12th February 2009 11:20 PM
Printer setup question JMJ_coder NetBSD General 12 6th November 2008 12:04 AM
IP Printer Setup kjemison FreeBSD General 4 2nd June 2008 02:35 PM
FreeBSD+CUPS+Samba faustcoder FreeBSD General 6 20th May 2008 12:20 AM


All times are GMT. The time now is 06:02 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick