DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 31st August 2009
guitarscn guitarscn is offline
Package Pilot
 
Join Date: Oct 2008
Posts: 166
Thanked 1 Time in 1 Post
Default Cannot connect to IRC (network issues within OBSD?)

For some reason whenever I try to connect with ircII or irssi, it will not let me connect to ANY IRC server, not even my friend's private one.

But if I switch to say Linux or Windows partition on this computer, I can get on IRC fine with irssi and HydraIRC.

But on OpenBSD with irssi I get like "Connection refused" or with ircII I get a similar message like:
Code:
*** Connecting to port 6667 of server irc.freenode.net
*** Connection closed from irc.freenode.net: Connection reset by peer
*** Unable to connect to server irc.freenode.net
Maybe some setting I need to tweak in OpenBSD? I have a fresh install of 4.5-Release and I only installed programs via pkg_add, and very few packages at that. (Like Xorg, ircII, irssi, portsentry, Firefox, and Bitlbee)

Update: BUT if I use a web service like mibbit.com to connect to IRC on OpenBSD, I can connect fine! I need to get my clients working, though because Firefox takes up a lot of memory more than irssi or ircII
(I just tried xchat too but still same error that I can't connect).

Last edited by guitarscn; 31st August 2009 at 10:56 PM.
Reply With Quote
  #2   (View Single Post)  
Old 31st August 2009
Oko's Avatar
Oko Oko is offline
Fsck Surgeon
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 845
Thanked 36 Times in 32 Posts
Default

Looks like a firewall issue to me on the first glance. Could you post your pf.conf.
Reply With Quote
  #3   (View Single Post)  
Old 31st August 2009
guitarscn guitarscn is offline
Package Pilot
 
Join Date: Oct 2008
Posts: 166
Thanked 1 Time in 1 Post
Default

Code:
#       $OpenBSD: pf.conf,v 1.38 2009/02/23 01:18:36 deraadt Exp $
#
# See pf.conf(5) for syntax and examples; this sample ruleset uses
# require-order to permit mixing of NAT/RDR and filter rules.
# Remember to set net.inet.ip.forwarding=1 and/or net.inet6.ip6.forwarding=1
# in /etc/sysctl.conf if packets are to be forwarded between interfaces.

set require-order no
set skip on lo
scrub in

# NAT/filter rules and anchors for ftp-proxy(8)
#nat-anchor "ftp-proxy/*"
#rdr-anchor "ftp-proxy/*"
#rdr pass on ! egress proto tcp to port ftp -> 127.0.0.1 port 8021
#anchor "ftp-proxy/*"
#pass out proto tcp from $proxy to any port ftp

# NAT/filter rules and anchors for relayd(8)
#rdr-anchor "relayd/*"
#anchor "relayd/*"

# NAT rules and anchors for spamd(8)
#table <spamd-white> persist
#table <nospamd> persist file "/etc/mail/nospamd"
#no rdr on egress proto tcp from <nospamd> to any port smtp
#no rdr on egress proto tcp from <spamd-white> to any port smtp
#rdr pass on egress proto tcp from any to any port smtp -> 127.0.0.1 port spamd

pass in         # to establish keep-state

#block in quick from urpf-failed to any # use with care

# By default, do not permit remote connections to X11
block in on ! lo0 proto tcp from any to any port 6000
Reply With Quote
  #4   (View Single Post)  
Old 1st September 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,889
Thanked 214 Times in 189 Posts
Default

That is the default PF included with 4.5-release. In 4.5, pf is not enabled by default, anyway. While we don't know if you enabled it, it is likely you did not. And therefore, it is likely this is not your problem.

So, what changed in your network since March, when you first asked your questions about your IRC client? Under the assumption it was working then, it is likely a change to your network topology, or to network configuration, has rendered it inoperative. I would think it was your external router/firewall that is blocking IRC traffic -- but you've stated that when you boot another OS from the same platform, you don't have a problem.

When you run another OS, are you using the same IP address?

If *nothing* has changed, and you are using the same IP address, then post network configuration info:

$ ifconfig -A
$ route -n show -inet

And post the name and contents of all your /etc/hostname.* files, and, if you are still using static IP addressing, the contents of your /etc/mygate file.

Last edited by jggimi; 1st September 2009 at 12:16 AM.
Reply With Quote
  #5   (View Single Post)  
Old 1st September 2009
guitarscn guitarscn is offline
Package Pilot
 
Join Date: Oct 2008
Posts: 166
Thanked 1 Time in 1 Post
Default

Yes, same IP address

I remember in March I couldn't load scripts but I got it working. But at that time, I had similar issues to this one I have now, but I never pursued it which is why there is somewhat of a gap between times I have been posting, because when I am not posting questions, it usually means I am using another OS because I run into a lot of hassles on OpenBSD each time I use it. Anyway, it WAS working before, but then it suddenly stopped working I think when I installed something, or changed settings for something? Maybe Tor/Privoxy or Bitlbee because I had to change some inetd settings as well as some xinetd thing, and for Privoxy I put something into rc.local for it to work

Here I am using rl0 which is my ethernet.

Code:
# ifconfig -A
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 33204
        priority: 0
        groups: lo
        inet 127.0.0.1 netmask 0xff000000
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:03:0d:15:18:6f
        priority: 0
        groups: egress
        media: Ethernet autoselect (100baseTX full-duplex)
        status: active
        inet6 fe80::203:dff:fe15:186f%rl0 prefixlen 64 scopeid 0x1
        inet 172.17.4.72 netmask 0xffffff00 broadcast 172.17.4.255
enc0: flags=0<> mtu 1536
        priority: 0
ath0: flags=8822<BROADCAST,NOTRAILERS,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:14:bf:7b:2f:34
        priority: 0
        groups: wlan
        media: IEEE802.11 autoselect
        status: no network
        ieee80211: nwid ""
Code:
# route -n show -inet
Routing tables

Internet:
Destination        Gateway            Flags   Refs      Use   Mtu  Prio Iface
default            172.17.4.1         UGS        9    36469     -     8 rl0
127/8              127.0.0.1          UGRS       0        0 33204     8 lo0
127.0.0.1          127.0.0.1          UH         4      597 33204     4 lo0
172.17.4/24        link#1             UC         1        0     -     4 rl0
172.17.4.1         00:1f:45:47:89:1b  UHLc       1        0     -     4 rl0
172.17.4.72        127.0.0.1          UGHS       0        0 33204     8 lo0
224/4              127.0.0.1          URS        0        0 33204     8 lo0
I have no /etc/hostname files. Just:
Code:
# vi /etc/host                                                                                                                                                        
hostapd.conf   hosts          hosts.equiv    hosts.lpd
(when I press Tab to complete)
And I also have no /etc/mygate

Last edited by guitarscn; 1st September 2009 at 12:47 AM.
Reply With Quote
  #6   (View Single Post)  
Old 1st September 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,889
Thanked 214 Times in 189 Posts
Default

Back in February, ocicat recommended FAQ 6:

http://www.daemonforums.org/showthre...2878#post21488
http://www.daemonforums.org/showthre...2878#post21492

In that thread where FAQ 6 was discussed, you wrote you had an /etc/hostname.rl0 file. Since you no longer have it ... something has changed since the last time you mentioned your network configuration, back in February.

I'll ask again: did IRC ever work for you in the past? You asked about IRC script files in March.

Apparently, you are no longer using a static IP address, and it looks to me like you are using DHCP, and are manually using dhclient(8) once again, rather than a hostname file. A re-reading of FAQ 6 is recommended, since you are not automating your network configuration.

As currently configured, your network appears as follows:
IP Address: 172.17.4.72
Subnet mask: 255.255.255.0
CIDR description: 172.17.4.72/24
Default route: 172.17.4.1
I see nothing unusual in your configuration, other than a lack of correct configuration files. Your default route (network gateway) appears to be routing properly, according to your routing table.

This give me the opportunity to ask you a second time: when you boot another OS on the same computer, can you please confirm the other OSes use the same IP address of 172.17.4.72?

I'm asking this (again), because the problem, as I understand it, is that IRC is the only network application you have tried that is not working. Is that assumption correct? If so, then the most likely reason is a firewall setting. Your firewall is external to OpenBSD, and resides in your gateway router at 172.17.4.1. If your Linux and Windows systems use a different IP address, than that would explain why they work and this OS does not.
Reply With Quote
  #7   (View Single Post)  
Old 1st September 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,889
Thanked 214 Times in 189 Posts
Default

I just went back and noted you are running Tor. It will get in the way of many normal TCP/IP applications, in particular, IRC. If you disable Tor, your IRC function will probably return to normal.

Tor's brief description (highlight mine):
Quote:
Tor is a connection-based low-latency anonymous communication system that protects TCP streams: web browsing, instant messaging, irc, ssh, etc.
Reply With Quote
  #8   (View Single Post)  
Old 1st September 2009
guitarscn guitarscn is offline
Package Pilot
 
Join Date: Oct 2008
Posts: 166
Thanked 1 Time in 1 Post
Default

What I think I will try is, save all my configurations and stuff since I don't have much installed, and re-install a fresh copy of 4.5 and only install ircII and see if that works first and maybe that will tell me if another program is affecting IRC or not
Reply With Quote
  #9   (View Single Post)  
Old 1st September 2009
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,249
Thanked 182 Times in 149 Posts
Default

Some IRC networks don't allow Tor connections, see https://wiki.torproject.org/noreply/...er/BlockingIrc
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
Old 4th September 2009
guitarscn guitarscn is offline
Package Pilot
 
Join Date: Oct 2008
Posts: 166
Thanked 1 Time in 1 Post
Default

I never use Tor with IRC, I just have it installed and running for Firefox
Reply With Quote
Old 4th September 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,889
Thanked 214 Times in 189 Posts
Default

Sigh. Did you do either of these, and try your IRC connection again?
A. Reinstall

B. # pkg_delete tor ; reboot
B is simple, quick, and easier than A, if you haven't done either, yet.

Last edited by jggimi; 4th September 2009 at 02:25 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Restore OBSD Over SSH revzalot OpenBSD Installation and Upgrading 16 2nd September 2009 06:45 PM
Vista network issues behind PF Firewall cerulean Other OS 3 10th November 2008 10:36 PM
obsd 4.3 chrooted sftp permissions? luismi OpenBSD General 4 12th July 2008 11:39 PM
Cacti performance OBSD vs. CentOS ai-danno General software and network 8 3rd July 2008 08:51 PM
obsd 4.3 secure ssh use milo974 OpenBSD Security 9 3rd July 2008 11:23 AM


All times are GMT. The time now is 10:22 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick