DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Installation and Upgrading

FreeBSD Installation and Upgrading Installing and upgrading FreeBSD.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 6th September 2009
mururoa mururoa is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 46
Thanked 0 Times in 0 Posts
Default pidgin (py25-gtk) wont upgrade

Hi there,

I'm using 7.2 release with system and port tree up to date.
I get security warning using portaudit :

Code:
mururoa2# portaudit -Fda
auditfile.tbz                                 100% of   57 kB   52 kBps
New database installed.
Database created: Sun Sep  6 09:10:03 CEST 2009
Affected package: pidgin-2.5.7
Type of problem: pidgin -- MSN overflow parsing SLP messages.
Reference: <http://www.FreeBSD.org/ports/portaudit/59e7af2d-8db7-11de-883b-001e3300a30d.html>

Affected package: libpurple-2.5.7
Type of problem: pidgin -- MSN overflow parsing SLP messages.
Reference: <http://www.FreeBSD.org/ports/portaudit/59e7af2d-8db7-11de-883b-001e3300a30d.html>

Affected package: linux-pango-1.10.2_2
Type of problem: pango -- integer overflow.
Reference: <http://www.FreeBSD.org/ports/portaudit/4b172278-3f46-11de-becb-001cc0377035.html>

3 problem(s) in your installed packages found.

You are advised to update or deinstall the affected package(s) immediately.
But I cant upgrade anything of that.
I cant upgrade linux-pango but I guess it's normal since there is no new version without security problem.
But when I try to upgrade libpurple or pidgin (pidgin depends of libpurple) I get this :

Code:
# portupgrade -R pidgin
.
.
.
py25-cairo-1.8.8 needs Python 2.6 at least. But you specified 2.5.
.
.
.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! multimedia/gstreamer-plugins-dvd (gstreamer-plugins-dvd-0.10.12,3)    (unknown build error)
        * multimedia/gstreamer-plugins-core (gstreamer-plugins-core-0.10_10)
        ! net-im/libpurple (libpurple-2.5.7)    (unknown build error)
        * net-im/pidgin (pidgin-2.5.7)
So I try to upgrade py-gtk2 only and get the same error :

Code:
mururoa2# cd /usr/ports/x11-toolkits/py-gtk2
mururoa2# make reinstall
===>   py25-gtk-2.14.1_1 depends on file: /usr/local/lib/python2.5/site-packages/cairo/__init__.py - not found
===>    Verifying reinstall for /usr/local/lib/python2.5/site-packages/cairo/__init__.py in /usr/ports/graphics/py-cairo
===>  py25-cairo-1.8.8 needs Python 2.6 at least. But you specified 2.5.
*** Error code 1

Stop in /usr/ports/graphics/py-cairo.
*** Error code 1

Stop in /usr/ports/x11-toolkits/py-gtk2.
*** Error code 1

Stop in /usr/ports/x11-toolkits/py-gtk2.
I googled and searched but nothing found.
I'm lost there, what is the problem ?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pidgin MSN connection issues, invalid SSL Certificate chain TerryP Guides 5 8th December 2010 01:06 AM
pidgin amsn kopete gosha General software and network 2 2nd June 2009 10:08 PM
Yahoo! related Pidgin problems... BSDfan666 General software and network 10 28th September 2008 02:39 AM
KDE wont start up dctr FreeBSD General 9 11th June 2008 05:59 AM
Why wont this compile? Johnny2Bad FreeBSD General 10 19th May 2008 11:30 PM


All times are GMT. The time now is 04:59 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick