DaemonForums  

Go Back   DaemonForums > Miscellaneous > General software and network

General software and network General OS-independent software and network questions, X11, MTA, routing, etc.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 18th May 2008
WeakSauceIII WeakSauceIII is offline
Port Guard
 
Join Date: May 2008
Posts: 30
Thanked 0 Times in 3 Posts
Default OpenBSD 4.3, XDM + FluxBox

I believe I have a basic user environment problem. I have been using fluxbox for some time now. I start fluxbox via console login then startx command. The next step is that my .xinitrc file is run by X. I also have an .xsession but it is just a link to .xinitrc. .xinitrc file has 1 line;

exec /usr/local/bin/startfluxbox

This startfluxbox script runs this file

~/.fluxbox/startup

... or a default if its not there.

~/.fluxbox/startup holds my configuration such as background setup, gkrellm and so on. this all works fine with startx. I want to use XDM now to start fluxbox. XDM gets to

exec /usr/local/bin/startfluxbox

Then it loads the default fluxbox with no background ect... The .xsession-errors file contains

/root/.fluxbox/startup[8]: fbsetbg: not found
/root/.fluxbox/startup[44]: gkrellm: not found
BScreen::BScreen: managing screen 0 using visual 0x23, depth 24
Fluxbox: There is no background option specified in this style.


these are the three things I do in my ~/.fluxbox/startup

I use root for everything. I know its bad but I'm still learning the setup. I thought it was the case that XDM was running as another user with a different home directory so ~/.fluxbox/startup couldn't be found and the default startup was used. The .xsession errors tell me different because those lines are in my ~/.fluxbox/startup file so it ran the file but couldn't find those programs. Any ideas as to why those programs could not be found in this context?
Reply With Quote
  #2   (View Single Post)  
Old 19th May 2008
nihonto nihonto is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 65
Thanked 1 Time in 1 Post
Default

... you could try this in your .xinitrc:

Quote:
feh --bg-tile ~/wallpaper/bg.jpg &
gkrellm &
exec startfluxbox
... and please do yourself a favor and use a normal user, not root for this.
Reply With Quote
  #3   (View Single Post)  
Old 19th May 2008
WeakSauceIII WeakSauceIII is offline
Port Guard
 
Join Date: May 2008
Posts: 30
Thanked 0 Times in 3 Posts
Default

Thanks for the reply. I am aware of different ways to work around the problem but my goal is to understand the problem, not get it working another way. I am still in the learn until I break / reinstall phase of BSD and nothing of any value is on my machine. Once I get to a point where I'm comfortable that i will not be reinstalling soon, I will create and use non root user. Thanks again.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluxbox don't start Artur FreeBSD General 4 3rd September 2009 01:04 PM
fluxbox crash? HELP bsdnewbie999 OpenBSD General 9 2nd April 2009 04:35 AM
HOWTO: Fluxbox from GIT vermaden Guides 6 3rd November 2008 12:13 PM
Fluxbox fbsetbg problem rex FreeBSD General 6 12th September 2008 05:18 PM
gtk themes for fluxbox rex FreeBSD General 0 18th May 2008 03:24 AM


All times are GMT. The time now is 07:53 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick