DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Installation and Upgrading

FreeBSD Installation and Upgrading Installing and upgrading FreeBSD.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 15th October 2009
RJPugh RJPugh is offline
Port Guard
 
Join Date: Jun 2008
Location: Culpeper, VA
Posts: 42
Thanked 0 Times in 0 Posts
Default Dell Dimension 4550 sound card problem

Greetings! I’m a refugee from the world of Linux, and I’ve been using PC-BSD for over a year now. I know that PC-BSD has some bad points, but on the whole I’m happy with it. I recently acquired a newer computer, a Dell Dimension 4550 series desktop. It may be an older model, but it’s newer and in better condition than the one it replaced. PC-BSD installed on this beast without any problem… except for the sound card. The system claims it’s unable to use it, though according to the diagnostics, it knows the card is in there.

The card is a Creative Labs Sound Blaster Live, PCI model. Windows XP can use the card without a problem, so I’m pretty sure the card’s hardware is stable. I’ve also read that the SB-Live series is supported by BSD, so I should be able to get the thing working, perhaps after some kicking and screaming. I plan to try the following, in order:

1. Go through the process of manually configuring a sound card, according to the FreeBSD handbook.

2. Find out what driver set PC-BSD is using and try to override it.

3. Look into an OSS port (I really hope it doesn’t come to this…)

4. Acquire a different sound card that I know to be supported. I really hope it doesn’t come to this! But for all I know the current sound card may have a proprietary chip that prevents it from working in anything other than Windows (Winmodem syndrome).

PC-BSD uses KDE. I tried to play a sound file from a different window manager and it still didn’t work. So at the very least I can rule out KDE as the problem. That would have been too easy.



Another possibility is a PCI add-on card I put in there. It’s a USB/Firewire bridge card, which I put into an empty PCI slot. The system handled it without a problem, though I’m now wondering if it has created a memory problem on the PCI bridge. If this card is the problem, it won’t be for long, as I’ve determined that it’s not going to be necessary after all. It’s going to be pulled the next time I open the case.

Can anyone think of anything else I should try? For that matter, has anyone in here ever tried to use BSD on this model of computer? PC-BSD seems happy with it… it just can’t talk yet. I hope to eventually resolve this, because the sound issue is now the only thing stopping me from making BSD my primary operating system. (I need Windows XP for gaming, but nothing else.)

Thanks in advance,


Richard
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Recording sound with external sound card backrow OpenBSD General 5 21st August 2009 08:17 PM
Sound Problem. MetalHead OpenBSD General 3 16th November 2008 09:27 PM
Sound problem renej FreeBSD General 18 12th September 2008 07:30 PM
Problem with no sound in games troberts FreeBSD General 9 21st July 2008 08:53 PM
problem with Virtual Sound Channels in FreeBSD 7 casper007 FreeBSD Installation and Upgrading 3 16th July 2008 04:22 PM


All times are GMT. The time now is 07:54 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick