DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 31st October 2009
valorisa valorisa is offline
Port Guard
 
Join Date: May 2009
Posts: 16
Thanked 0 Times in 0 Posts
Default OpenBSD 4.6 -current and Opera 10....

Hello,

When I want to run Opera 10 with OpenBSD 4.6 -current (and KDE 3.5.10 installed) I get the message :

$ opera
/usr/local/libexec/opera: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory

The installation of Opera seems correct. My pkg_info shows :

$ pkg_info
opera-10.00 fast and customizable WWW browser
opera-flashplugin-7.0r68p0 flash support for opera

Where is the problem ?

Opera 9.64 or other will give me a better result ?

Thanks for your help.

valorisa
Reply With Quote
  #2   (View Single Post)  
Old 31st October 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,435
Thanked 214 Times in 189 Posts
Default

Opera runs under Linux emulation on OpenBSD/i386. You are apparently missing a Linux version of the qt-mt library.

I do not believe that your pkg_info output -only- shows opera 10 and the older Flash 7 plugin. There are build and run dependencies that would be required to be installed, such as bzip, fedora_base, glib2.

If you want to solve this, start by reading the compat_linux(8) man page, and then perhaps obtain the appropriate Linux library.
Reply With Quote
  #3   (View Single Post)  
Old 31st October 2009
valorisa valorisa is offline
Port Guard
 
Join Date: May 2009
Posts: 16
Thanked 0 Times in 0 Posts
Default

Hello,

Thanks Jggimi,

Here is my complete pkg_info :
Code:
$ pkg_info
OpenEXR-1.6.1p0     high dynamic range image format
akode-2.0.2p6       decoding library for KDE Multimedia
apr-1.2.11p2        Apache Portable Runtime
apr-util-1.2.10p3   companion library to APR
arts-1.5.10p0       K Desktop Environment, aRTs
aspell-0.60.6p3     spell checker designed to eventually replace Ispell
atk-1.24.0          accessibility toolkit used by gtk+
avahi-0.6.25p1      framework for Multicast DNS Service Discovery
bzip2-1.0.5         block-sorting file compressor, unencumbered
cabextract-1.2p0    extracts files from Microsoft CAB archives
cairo-1.8.6p1       vector graphics library
cdparanoia-3.a9.8p0 CDDA reading utility with extra data verification features
cups-1.3.10p7       Common Unix Printing System
curl-7.19.5         get files from FTP, Gopher, HTTP or HTTPS servers
cyrus-sasl-2.1.23   RFC 2222 SASL (Simple Authentication and Security Layer)
db-4.6.21p0         Berkeley DB package, revision 4
dbus-1.2.14p0       message bus system
desktop-file-utils-0.15 utilities for 'desktop' entries
faac-1.26           MPEG-2 and MPEG-4 AAC encoder
faad-2.6.1          MPEG-2 and MPEG-4 AAC decoder
fam-2.7.0p7         File Alteration Monitor
fedora_base-4.0p4   Linux compatibility package based on Fedora Core 4
fedora_motif-2.1.30p0 Motif toolkit Linux libraries
ffmpeg-20080620p8   audio/video converter and streamer with bktr(4) support
flac-1.2.1p0        free lossless audio codec
fribidi-0.10.4p0    library implementing the Unicode Bidirectional Algorithm
gdbm-1.8.3p0        GNU dbm
gettext-0.17p0      GNU gettext
ghostscript-8.63p6  GNU PostScript interpreter
ghostscript-fonts-8.11p0 35 standard PostScript fonts with Adobe name aliases
glib-1.2.10p3       useful routines for C programming
glib2-2.18.4p3      general-purpose utility library
glitz-0.5.6p1       OpenGL image compositing library
gmp-4.2.4           library for arbitrary precision arithmetic
gnokii-0.6.14p9     tools to talk to GSM cellular phones
gnupg-1.4.9         GNU privacy guard - a free PGP replacement
gnutls-2.6.6        GNU Transport Layer Security library
gpgme-1.1.5p0       GnuPG Made Easy
gstreamer-0.10.19p3 streaming media framework - core
gtk+-1.2.10p7       General Toolkit for X11 GUI
gtk+2-2.14.7p0      multi-platform graphical toolkit
hicolor-icon-theme-0.10p4 high-color icon theme shell for GNOME and KDE
ijs-0.35            raster image transmission library
ilmbase-1.0.1p2     ILM base libraries
imlib-1.9.14p7      image manipulation library for X11
imlib2-1.4.2        image manipulation library
jack-0.116.1p2      low latency sound server
jasper-1.900.1p0    reference implementation of JPEG-2000
jpeg-6bp4           IJG's JPEG compression utilities
kde-i18n-fr-3.5.10  fr translations for KDE
kdeaccessibility-3.5.10p1 X11 toolkit, accessibility aids
kdeaddons-3.5.10p1  K Desktop Environment, addons
kdeadmin-3.5.10     K Desktop Environment, admin tools
kdeartwork-3.5.10p2 K Desktop Environment, additional artwork
kdebase-3.5.10p1    K Desktop Environment, basic applications
kdebindings-3.5.10p1 K Desktop Environment, extra language support
kdecups-3.5.10      K Desktop Environment, cups support
kdeedu-3.5.10p0     K Desktop Environment, edutainment
kdegames-3.5.10p0   K Desktop Environment, games
kdegraphics-3.5.10  K Desktop Environment, graphic applications
kdelibs-3.5.10p0    K Desktop Environment, libraries
kdemultimedia-3.5.10p1 K Desktop Environment, multimedia applications
kdenetwork-3.5.10p0 K Desktop Environment, network applications
kdepim-3.5.10p0     KDE personal information applications
kdesamba-3.5.10     K Desktop Environment, samba support
kdesdk-3.5.10p0     K Desktop Environment, developer extensions
kdesvn-3.5.10p1     K Desktop Environment, svn extensions
kdetoys-3.5.10      some useless KDE applications
kdeutils-3.5.10p0   K Desktop Environment, utilities
kdewebdev-3.5.10    web development tool
lame-3.98.2         lame ain't an MP3 encoder
lcms-1.18a          color management library
liba52-0.7.4p2      AC-3 decoding library
libart-2.3.20p0     high-performance 2D graphics library
libaudiofile-0.2.6p2 SGI audiofile library clone
libdaemon-0.12      lightweight C library that eases the writing of daemons
libdvdnav-20051102p2 DVD read/navigation library
libgcrypt-1.4.4p0   crypto library based on code used in GnuPG
libgpg-error-1.5    error codes for GnuPG related software
libical-0.27        implementation of basic iCAL protocols
libiconv-1.13       character set conversion library
libid3tag-0.15.1bp2 library for reading ID3 tags
libidn-1.11         internationalized string handling
libltdl-1.5.26      GNU libtool system independent dlopen wrapper
libmad-0.15.1bp1    high-quality MPEG audio decoder
libmal-0.44         MAL convenience library
libmng-1.0.10       Multiple-image Network Graphics (MNG) reference library
libmp4v2-1.5.0.1    read and manipulate the MP4 container format
libogg-1.1.3        Ogg bitstream library
libpaper-1.1.21p0   library for handling paper characteristics
libsamplerate-0.1.7 audio sample rate conversion library
libsndfile-1.0.20p1 library to handle various audio file formats
libtasn1-1.5        Abstract Syntax Notation One structure parser library
libtheora-1.0       open video codec
libungif-4.1.4p1    tools and library routines for working with GIF images
libusb-0.1.12       USB access library
libvorbis-1.2.0p1   audio compression codec library
libxml-2.6.32p2     XML parsing library
libxslt-1.1.24p2    XSLT C Library for GNOME
lzo-1.08p1          portable speedy lossless data compression library
meanwhile-1.0.2p1   implementation of Lotus Sametime Community Client protocol
msttcorefonts-2.0   Microsoft TrueType core fonts
neon-0.28.3         HTTP and WebDAV client library, with C interface
net-snmp-5.4.2.1p1  extendable SNMP implementation
openldap-client-2.3.43 Open source LDAP software (client)
opera-10.00         fast and customizable WWW browser
opera-flashplugin-7.0r68p0 flash support for opera
pango-1.22.4p0      library for layout and rendering of text
pcre-7.9            perl-compatible regular expression library
pilot-link-0.12.3p1 tools to connect your PalmOS® compatible handheld
png-1.2.35          library for manipulating PNG images
poppler-0.10.7      PDF rendering library
poppler-qt-0.10.7   qt interface to PDF rendering library
popt-1.7p0          getopt(3)-like library with a number of enhancements
python-2.5.4p0      interpreted object-oriented programming language
qca-1.0p2           Qt Cryptographic Architecture
qca-tls-1.0p7       Qt Cryptographic Architecture, TLS plugin
qt3-mt-3.8p2        C++ X11 GUI toolkit
rpm2cpio-1.2        rpm2cpio, simple perl converter
ruby-1.8.6.368      object oriented script language with threads
samba-3.0.34p0      SMB and CIFS client and server for UNIX
sdl-1.2.13p11       cross-platform multimedia library
speex-1.2rc1        patent-free speech codec
sqlite3-3.6.13p0    embedded SQL implementation
subversion-1.6.1    subversion revision control system
taglib-1.5p0        managing meta-data of audio formats
tiff-3.8.2p3        tools and library routines for working with TIFF images
unzip-5.52p0        extract, list & test files in a ZIP archive
wavpack-4.50.1      Audio codec for lossless, lossy and hybrid compression
x264-20090204       free H264/AVC encoder
xanim-2.80.1p1      X11 animation player with support for lots of formats
xdg-utils-1.0.2p5   utilities to assist desktop integration tasks
xine-lib-1.1.16.3   multimedia decoding library
xmms-1.2.11p5       Multimedia player for the X Window System
xscreensaver-data-5.08 graphical demos (savers) for screensavers
I will read the compat_linux man page

Again thanks.

valorisa

Last edited by ocicat; 31st October 2009 at 10:05 PM. Reason: Use [code] tags to facilitate reading.
Reply With Quote
  #4   (View Single Post)  
Old 31st October 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,435
Thanked 214 Times in 189 Posts
Default

I see your problem. Your fedora_base is 4.0p4, -current has been 4.04p6 since August 3. You have moved your OS to -current, but you have not updated your package set.

Read FAQ 15.4.1, then update your packages. (Snapshot packages are available for i386, but they may not always be in sync with -current.)
Reply With Quote
  #5   (View Single Post)  
Old 1st November 2009
Oko's Avatar
Oko Oko is offline
Fsck Surgeon
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 734
Thanked 36 Times in 32 Posts
Default

Quote:
Originally Posted by jggimi View Post
I see your problem. Your fedora_base is 4.0p4, -current has been 4.04p6 since August 3. You have moved your OS to -current, but you have not updated your package set.
He can use ldd to see which dynamic libraries he is missing and get them from
the live Linux system. Opera 10 does require one or two new libraries. He can look for the Fratnisek Holop's posts on ports@openbsd to see the whole story of getting Opara 10 working on OpenBSD.
Reply With Quote
  #6   (View Single Post)  
Old 1st November 2009
valorisa valorisa is offline
Port Guard
 
Join Date: May 2009
Posts: 16
Thanked 0 Times in 0 Posts
Default

Hello,

Thanks Oko and Jggimi.

Yes, lately (2 days) I have moved my OS from Openbsd 4.5 snapshot (june 2009) to -current (october 2009). I have upgraded src, ports and xenocara, rebuilt the kernel, the userland but not rebuilt X.

Now when I do a pkg_add -u as stated previously in your advice i get this :

Code:
# pkg_add -u fedora_base
Candidates for updating fedora_base-4.0p4 -> fedora_base-4.0p6
Looking for updates: complete
Running update fedora_base-4.0p4 -> fedora_base-4.0p6
New package fedora_base-4.0p6 contains potentially unsafe oper
        @exec ln -fhs /usr/local/emul/fedora /emul/linux
        @exec /usr/local/emul/fedora/sbin/ldconfig
        @exec /usr/local/emul/fedora/usr/bin/gdk-pixbuf-query-        local/emul/fedora/etc/gtk-2.0/gdk-pixbuf.loaders
        @exec /usr/local/emul/fedora/usr/bin/gtk-query-immodul        ocal/emul/fedora/etc/gtk-2.0/gtk.immodules
        @exec /usr/local/emul/fedora/usr/bin/pango-querymodule        emul/fedora/etc/pango/i386-redhat-linux-gnu/pango.modules
Can't safely update to fedora_base-4.0p6 (use -F update to for
/usr/sbin/pkg_add: fedora_base-4.0p6:Fatal error
A pkg_add -u (without package name will help me ??)

Valorisa

Last edited by Carpetsmoker; 3rd November 2009 at 10:10 PM. Reason: Add [code] tags
Reply With Quote
  #7   (View Single Post)  
Old 1st November 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,435
Thanked 214 Times in 189 Posts
Default

No. You just need to tell pkg_add that is is OK to run the installation scripts that are outside of its control. Either use -i, and respond to the prompt when it asks, or use -F update.
Reply With Quote
  #8   (View Single Post)  
Old 1st November 2009
valorisa valorisa is offline
Port Guard
 
Join Date: May 2009
Posts: 16
Thanked 0 Times in 0 Posts
Default

Hello,

If I understand, just /usr/sbin/pkg_add -u -F fedora_base

Valorisa
Reply With Quote
  #9   (View Single Post)  
Old 1st November 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,435
Thanked 214 Times in 189 Posts
Default

No. Use:

# pkg_add -r -F update fedora_base

or

# pkg_add -ir fedora_base

or, update -all- of your packages, with either:

# pkg_add -u -F update -F updatedepends

or

# pkg_add -iu


-Read- the pkg_add(8) man page. FAQ 15 is also of value.
Reply With Quote
Old 1st November 2009
valorisa valorisa is offline
Port Guard
 
Join Date: May 2009
Posts: 16
Thanked 0 Times in 0 Posts
Default

Jggimi,

I have used this by waiting your response :

Code:
# /usr/sbin/pkg_add -u -i fedora_base
Candidates for updating fedora_base-4.0p4 -> fedora_base-4.0p6
Looking for updates: complete
Running update fedora_base-4.0p4 -> fedora_base-4.0p6
New package fedora_base-4.0p6 contains potentially unsafe operations
        @exec ln -fhs /usr/local/emul/fedora /emul/linux
        @exec /usr/local/emul/fedora/sbin/ldconfig
        @exec /usr/local/emul/fedora/usr/bin/gdk-pixbuf-query-loaders-32 > /usr/local/emul/fedora/etc/gtk-2.0/gdk-pixbuf.loaders
        @exec /usr/local/emul/fedora/usr/bin/gtk-query-immodules-2.0-32 > /usr/local/emul/fedora/etc/gtk-2.0/gtk.immodules
        @exec /usr/local/emul/fedora/usr/bin/pango-querymodules-32 > /usr/local/emul/fedora/etc/pango/i386-redhat-linux-gnu/pango.modules
proceed with update anyways? [y/N/a] y
fedora_base-4.0p6 (installing): complete
Clean shared items: complete
--- fedora_base-4.0p4 -------------------
Remember to update /emul/linux
Remember to update /usr/local/emul/fedora/etc/gtk-2.0/gdk-pixbuf.loaders
Remember to update /usr/local/emul/fedora/etc/gtk-2.0/gtk.immodules
Remember to update /usr/local/emul/fedora/etc/ld.so.cache
Remember to update /usr/local/emul/fedora/etc/pango/i386-redhat-linux-gnu/pango.modules
Remember to update /usr/local/emul/fedora/usr/lib/libstdc++-libc6.1-1.so.2
# ^D
$ opera
Conflict in /usr/local/lib/kde3/plugins/styles/scheck.so:
  Plugin uses incompatible Qt library (3.3.8)!

Opera seems to work.

I was right or wrong ?

valorisa

Last edited by Carpetsmoker; 3rd November 2009 at 10:10 PM. Reason: Added [code] tags
Reply With Quote
Old 1st November 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,435
Thanked 214 Times in 189 Posts
Default

Opera is using Linux emulation. KDE is running natively. Plugins are unlikely to work properly, unless they are installed in the Linux emulation hierarchy.

See compat_linux(8) for more information on Linux emulation.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenBSD on qemu: opera install problems Mr-Biscuit OpenBSD Packages and Ports 6 7th September 2009 03:29 AM
OpenBSD release to -current: Xenocara question IronForge OpenBSD Installation and Upgrading 4 1st September 2009 05:44 PM
Enlightenment e17 on OpenBSD (Question about current ports) uptonm OpenBSD Packages and Ports 2 17th June 2009 09:12 PM
/usr is full (OpenBSD 4.5 current) valorisa OpenBSD Packages and Ports 7 10th June 2009 01:28 PM


All times are GMT. The time now is 01:11 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick