DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 22nd November 2009
whetphish whetphish is offline
BSD Daemon
 
Join Date: Feb 2009
Location: Bath, England, UK
Posts: 7
Thanked 0 Times in 0 Posts
Unhappy Firefox 3 - Adding magnet: protocol

Hi,

I am running Firefox 3 on Gnome 2 under FreeBSD 7.2-RELEASE.

Basically I am trying to get Firefox to open Vuze when I click on a magnet: link, but at the moment I get the following message:

Code:
Firefox doesn't know how to open this address, because the protocol (magnet) isn't associated with any program.
I read a guide which suggested adding/setting the following in about:config

network.protocol-handler.app.magnet String -> /usr/local/bin/vuze
network.protocol-handler.handler.external.magnet Boolean -> true
network.protocol-handler.expose-all Boolean -> true

With these settings I get exactly the same error message clicking a link.

Another guide suggests adding the following in gconf-editor ...

/desktop/gnome/url-handlers/magnet /desktop/gnome/url-handlers/magnet/enabled Container
/desktop/gnome/url-handlers/magnet/command String -> /usr/local/bin/vuze %s
/desktop/gnome/url-handlers/magnet/enabled Boolean -> true
/desktop/gnome/url-handlers/magnet/needs_terminal Boolean -> false

This doesn't work either and has no effect on the error.

Note that I managed to create the string network.protocol-handler.app.irc in about:config in Firefox and set it to /usr/local/bin/xchat. This runs xchat fine when an irc: link is clicked.

As always any help would be greatly appreciated. I can't work out why this works for the irc: protocol and not for the magnet: one.

Thanks in advance,
whetphish.
Reply With Quote
  #2   (View Single Post)  
Old 22nd November 2009
whetphish whetphish is offline
BSD Daemon
 
Join Date: Feb 2009
Location: Bath, England, UK
Posts: 7
Thanked 0 Times in 0 Posts
Default

Just a quick update - a few threads I found on different forums seem to indicate that Firefox no longer lets you add your own protocols and instead relies on the underlying OS/environment to provide them. It appears to completely ignore the Gnome settings in /desktop/gnome/url-handlers as the man: and info: protocols configured there don't work in Firefox. I looked at this page which explains how to add MIME types in Gnome 2.8, but doesn't mention adding protocols.

Does anyone know how I can add protocols in Gnome 2.8?! I've googled but can't seem to find any information.
Reply With Quote
Reply

Tags
azureus, firefox, magnet, magnetic, vuze

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
pf & remote desktop protocol cerulean FreeBSD General 7 4th August 2011 10:14 PM
Adding a separate /home JMJ_coder NetBSD General 2 29th August 2008 10:45 AM
Upgrading firefox to firefox 3 -keeping plugins+bookmarks kasse FreeBSD Ports and Packages 11 5th July 2008 01:34 PM
Having trouble adding 7.0 to GRUB 0.97 Arenlor FreeBSD General 4 26th June 2008 01:02 AM
Adding multiple lines into file c0mrade Programming 4 7th June 2008 11:03 PM


All times are GMT. The time now is 12:49 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick