DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 27th November 2009
ddrx ddrx is offline
New User
 
Join Date: Nov 2009
Posts: 4
Thanked 0 Times in 0 Posts
Question Headphones versus built-in speakers

Hello,

The sound works well, but when I plug the headphone jack the sound still come out from the built-in speakers. Well, I can still hear the sound from the headphone, but the sound from the speakers just annoying. The speakers should be muted when I plug the headphone jack, right?

'mixerctl -av' returned
Code:
inputs.dac-0:1=150,150 
inputs.dac-2:3=150,150 
inputs.beep=85 
record.adc-0:1_source=mic2  [ mic2 mic ]
record.adc-0:1=126,126 
outputs.hp_source=dac-0:1  [ dac-0:1 dac-2:3 ]
outputs.hp_boost=off  [ off on ]
inputs.mic=126,126 
outputs.mic_dir=input-vr80  [ none input input-vr50 input-vr80 ]
outputs.spkr_source=dac-2:3  [ dac-0:1 dac-2:3 ]
outputs.spkr_eapd=on  [ off on ]
outputs.SPDIF_source=dig-dac-0:1  [ dig-dac-0:1 ]
inputs.mic2=126,126 
outputs.hp_sense=plugged  [ unplugged plugged ]
outputs.mic_sense=unplugged  [ unplugged plugged ]
outputs.master=150,150 
outputs.master.mute=off  [ off on ]
outputs.master.slaves=dac-0:1,dac-2:3  { dac-0:1 dac-2:3 beep }
record.volume=126,126 
record.volume.mute=off  [ off on ]
record.volume.slaves=adc-0:1  { adc-0:1 mic mic2 }
outputs.mode=analog  [ analog digital ]
I tried :
outputs.master.mute=off -> on
And to change slaves list...

Maybe the wrong way.

dmesg| grep Audio

Code:
azalia0 at pci1 dev 0 function 1 "ATI Radeon HD 3600 HD Audio" rev 0x00: apic 1 int 17 (irq 11)
azalia1 at pci0 dev 27 function 0 "Intel 82801I HD Audio" rev 0x03: apic 1 int 22 (irq 10)
Voilà,

Thanks.
Reply With Quote
  #2   (View Single Post)  
Old 28th November 2009
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,888
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by ddrx View Post
The speakers should be muted when I plug the headphone jack, right?
It would be great if sound configuration were this simple. Unfortunately (even when the same chipset is used...), manufacturers don't always connect all features that azalia(4) makes available. Parameter tweaking, for better or worse is frequently required.

For context, you would be advised to study what Jacob Meuser says in the misc@ archives. In particular, you may found the following useful:

http://marc.info/?t=124063258600001&r=1&w=2
Reply With Quote
  #3   (View Single Post)  
Old 28th November 2009
ddrx ddrx is offline
New User
 
Join Date: Nov 2009
Posts: 4
Thanked 0 Times in 0 Posts
Default

Thanks for your answer.

I already had a look to that topic on misc mailing list, however mixerctl hasn't such options now : outputs.dac2_mute= etc.. so when I try these commands I only get a :


Code:
mixerctl: field outputs.dac2_mute does not exist
Reply With Quote
  #4   (View Single Post)  
Old 28th November 2009
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,888
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by ddrx View Post
I already had a look to that topic on misc mailing list, however mixerctl hasn't such options now...
Per Section 13.1 of the FAQ:
Quote:
The controls of an audio device may be labeled differently. For instance, there might not be an outputs.master as above, but there is an outputs.outputs which does the same thing. Usually the controls have a meaningful label, but sometimes one must simply try different settings to see what effect each control has.
Reply With Quote
  #5   (View Single Post)  
Old 28th November 2009
ddrx ddrx is offline
New User
 
Join Date: Nov 2009
Posts: 4
Thanked 0 Times in 0 Posts
Default

I did a quick'n'dirty change in /etc/mixerctl.conf :

Code:
inputs.dac-2:3=0,0
Speakers are then muted but not headphones.
And when i unplug headphones I switch manually the volume of speakers.
Reply With Quote
  #6   (View Single Post)  
Old 28th November 2009
ddrx ddrx is offline
New User
 
Join Date: Nov 2009
Posts: 4
Thanked 0 Times in 0 Posts
Default

Well, apparently that fixe is really dirty because when I unplug/replug headphones spearkers' volume are reset.
Reply With Quote
  #7   (View Single Post)  
Old 28th November 2009
Oko's Avatar
Oko Oko is offline
Fsck Surgeon
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 774
Thanked 36 Times in 32 Posts
Default

Quote:
Originally Posted by ddrx View Post
Well, apparently that fixe is really dirty because when I unplug/replug headphones spearkers' volume are reset.
In order to make permanent changes you will have to create file

/etc/mixerctl.conf

and put the options you want to be permanent.

Cheers,
Predrag

P.S. But it seems to me that you still want to be able to switch between speakers and headphones as soon as you unplug/plug devices. That is NOT going to happen unless you can make your own hardware.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Misc. BSD/UNIX ZFS just got built-in deduplication vermaden News 3 3rd November 2009 01:03 PM
a novel idea: a sh with a `fork built-in? TerryP Programming 4 25th March 2009 07:17 PM
Audio & Headphones JMJ_coder General Hardware 3 10th November 2008 05:21 PM
Speakers not working in Dell Vostro 1400 mc_i2020 FreeBSD General 3 5th August 2008 09:00 PM
Sound in headphones buba OpenBSD General 3 11th June 2008 01:39 PM


All times are GMT. The time now is 03:40 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick