DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 4th December 2009
knasbas knasbas is offline
Port Guard
 
Join Date: May 2008
Posts: 25
Thanked 0 Times in 0 Posts
Default powersurge - missing mbr?

2 days ago we had a powersurge and no electricity for 1 hour. After the power came back i turned on my server only to notice that i needed to run manual fsck_ffs for wd4. Being very busy in rl i shut off the power.

Now i got a little time over so i started the server, entered shell and tried
disklabel -p wd4
and according to disklabel there is no partitions at all, luckily this wasnt very important data but still, i havent "lost" data like that, might have been a few blocks but this seems to be the mbr?

Is there some sort of way to possibly restore the mbr?
doing fsck wd4 i get
Cant open /dev/wd4a: device not configured
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sys.tar.gz missing from 3rd CD in 4.5? thirdm OpenBSD Installation and Upgrading 0 5th May 2009 03:25 PM
Disk space gone missing EricM FreeBSD General 0 26th February 2009 02:25 AM
The case of the missing 24GB Bruco FreeBSD General 3 20th October 2008 06:44 PM
Update from 6.3 to 7.0 (libs missing etc.) Calderon FreeBSD Installation and Upgrading 16 17th May 2008 09:03 PM


All times are GMT. The time now is 09:08 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick