DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 19th May 2008
WeakSauceIII WeakSauceIII is offline
Port Guard
 
Join Date: May 2008
Posts: 30
Thanked 0 Times in 3 Posts
Default Xorg.conf w/Matrox g550 agp

New install of openbsd on a new machine with a matrox g550. To my surprise a simple startx went right into X at a 1600x1200 resolution. I then did a 'x -configure' and ran X with the new auto-generated xorg.conf.new and it displayed that blank default background for fvwm but no clock, terminal, or anything else. Clicking the mouse wouldn't do anything either. I can kill X with ctrl-alt-backspace though. It's odd to me that X works with no configuration file but the autogenerated one does not work. All my past problems with X involved bad refresh/resolution/monitor issues but I do not believe this is the case here because I get X loaded, it, just doesn't show anything on the desktop or allow mouse clicks. The log file shows no errors. Any suggestions to troubleshoot this behavior?

Here is the file xorg.conf.new

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/share/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/OTF"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
Load "GLcore"
Load "dbe"
Load "extmod"
Load "glx"
Load "record"
Load "xtrap"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "wsmouse"
Option "Device" "/dev/wsmouse"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
#DisplaySize 320 240 # mm
Identifier "Monitor0"
VendorName "VSC"
ModelName "E75f"
### Comment all HorizSync and VertRefresh values to use DDC:
HorizSync 30.0 - 86.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "PciRetry" # [<bool>]
#Option "SyncOnGreen" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "Overlay" # [<str>]
#Option "MGASDRAM" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "UseFBDev" # [<bool>]
#Option "ColorKey" # <i>
#Option "SetMclk" # <freq>
#Option "OverclockMem" # [<bool>]
#Option "VideoKey" # <i>
#Option "Rotate" # [<str>]
#Option "TexturedVideo" # [<bool>]
#Option "Crtc2Half" # [<bool>]
#Option "Crtc2Ram" # <i>
#Option "Int10" # [<bool>]
#Option "AGPMode" # <i>
#Option "AGPSize" # <i>
#Option "DigitalScreen1" # [<bool>]
#Option "DigitalScreen2" # [<bool>]
#Option "TV" # [<bool>]
#Option "TVStandard" # [<str>]
#Option "CableType" # [<str>]
#Option "NoHal" # [<bool>]
#Option "SwappedHead" # [<bool>]
#Option "DRI" # [<bool>]
#Option "MergedFB" # [<bool>]
#Option "Monitor2HSync" # [<str>]
#Option "Monitor2VRefresh" # [<str>]
#Option "Monitor2Position" # [<str>]
#Option "MetaModes" # [<str>]
#Option "OldDmaInit" # [<bool>]
#Option "ForcePciDma" # [<bool>]
#Option "AccelMethod" # [<str>]
Identifier "Card0"
Driver "mga"
VendorName "Matrox Graphics, Inc."
BoardName "MGA G550 AGP"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768"
EndSubSection
EndSection
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg & i810 graphics / loader.conf / kldstat OgreNaut FreeBSD Installation and Upgrading 26 7th November 2008 02:27 PM
pf.conf lumiwa FreeBSD Security 11 20th September 2008 01:01 AM
difference between rc.conf and loader.conf disappearedng FreeBSD General 5 3rd September 2008 05:54 AM
wine.conf bsdnewbie999 OpenBSD General 6 15th July 2008 04:08 PM
Generate xorg.conf.new and black screen aleunix OpenBSD Packages and Ports 2 4th June 2008 10:49 AM


All times are GMT. The time now is 07:37 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick