DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 6th January 2010
FreeBee FreeBee is offline
Real Name: A name is just a word or a label, not really me!
Port Guard
 
Join Date: Jan 2010
Location: My own head.
Posts: 39
Thanked 0 Times in 0 Posts
Question Ath0: no carrier

I added

Code:
if_ath_load="YES"
wlan_ccmp_load="YES"
wlan_tkip_load="YES"
to /boot/loader.conf

I then tried to compile these drivers into the kernel:

Code:
device ath               # Atheros IEEE 802.11 wireless network driver
device ath_hal           # Atheros Hardware Access Layer
device ath_rate_sample   # John Bicket's SampleRate control algorithm.
device wlan              # 802.11 support (Required)
device wlan_wep          # WEP crypto support for 802.11 devices
device wlan_ccmp         # AES-CCMP crypto support for 802.11 devices
device wlan_tkip         # TKIP and Michael crypto support for 802.11 devices
Rebuilding the kernel failed with a compile error regarding ath_hal. See: ath_hal error (I am not yet allowed to post the URL pointing to that thread).

So I then tried to load the necessary modules by hand but I got:

Code:
can't load ... : File exists.
I added:

Code:
ifconfig_ath0="WPA DHCP
"

to /etc/rc.conf

I tried:

Code:
/etc/rc.d/netif start
Starting wpa_supplicant.
ELOOP: remaining socket: sock=5 eloop_data=0x28407140 user_data=0x2840e040 handler=0x8069f40
Starting Network: lo0 ath0.
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	options=3<RXCSUM,TXCSUM>
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3 
	inet6 ::1 prefixlen 128 
	inet 127.0.0.1 netmask 0xff000000 
ath0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 2290
	ether 00:c0:a8:a9:c6:96
	media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
	status: no carrier

wpa_supplicant[97512]: Failed to initialise driver interface
/etc/rc.d/wpa_supplicant: WARNING: failed to start wpa_supplicant
I added this to /etc/wpa_supplicant:

Code:
network={
ssid="my network name"
key_mgmt=WPA-PSK
psk=" my password"
}
I added this to /etc/rc.conf:

Code:
ifconfig_ath0="WPA DHCP"
I'm stuck. Any ideas?
Reply With Quote
  #2   (View Single Post)  
Old 6th January 2010
DutchDaemon's Avatar
DutchDaemon DutchDaemon is offline
Real Name: Ben
Spam Refugee
 
Join Date: Jul 2008
Location: Rotterdam, The Netherlands
Posts: 337
Thanked 32 Times in 30 Posts
Default

Is this on FreeBSD 7 or 8?
Reply With Quote
  #3   (View Single Post)  
Old 6th January 2010
FreeBee FreeBee is offline
Real Name: A name is just a word or a label, not really me!
Port Guard
 
Join Date: Jan 2010
Location: My own head.
Posts: 39
Thanked 0 Times in 0 Posts
Exclamation

Quote:
Originally Posted by DutchDaemon View Post
Is this on FreeBSD 7 or 8?
Code:
uname -r

8.0-RELEASE
Reply With Quote
  #4   (View Single Post)  
Old 6th January 2010
DutchDaemon's Avatar
DutchDaemon DutchDaemon is offline
Real Name: Ben
Spam Refugee
 
Join Date: Jul 2008
Location: Rotterdam, The Netherlands
Posts: 337
Thanked 32 Times in 30 Posts
Default

Wireless setup has changed significantly in FreeBSD 8.

(sorry to link to 'competing forums' )

http://forums.freebsd.org/showthread.php?t=8784
http://forums.freebsd.org/showthread.php?t=5530
Reply With Quote
  #5   (View Single Post)  
Old 6th January 2010
FreeBee FreeBee is offline
Real Name: A name is just a word or a label, not really me!
Port Guard
 
Join Date: Jan 2010
Location: My own head.
Posts: 39
Thanked 0 Times in 0 Posts
Thumbs down

Quote:
Originally Posted by DutchDaemon View Post
Wireless setup has changed significantly in FreeBSD 8.

(sorry to link to 'competing forums' )

http://forums.freebsd.org/showthread.php?t=8784
http://forums.freebsd.org/showthread.php?t=5530
I tried to implement the new stuff and now I get:

Code:
wpa_supplicant[309]: Failed to disable WPA in the driver.
Disable WPA?! That's not my idea!
Reply With Quote
  #6   (View Single Post)  
Old 9th January 2010
FreeBee FreeBee is offline
Real Name: A name is just a word or a label, not really me!
Port Guard
 
Join Date: Jan 2010
Location: My own head.
Posts: 39
Thanked 0 Times in 0 Posts
Default

Competition is irrelevant to me. Anyway, I tried all of the stuff on the "competing" forums to no avail.

Primarily I followed the instructions as written down in the official FreeBSD handbook. Isn't this information up-to-date?

I still get this error:

Quote:
ioctl[SIOCG80211, op 98, len 32]: Invalid argument
Failed to initialize driver interface
ELOOP: remaining socket: sock=4 eloop_data=0x28205140 user_data=0x2820c040 handler=0x8067b50
Reply With Quote
  #7   (View Single Post)  
Old 9th January 2010
FreeBee FreeBee is offline
Real Name: A name is just a word or a label, not really me!
Port Guard
 
Join Date: Jan 2010
Location: My own head.
Posts: 39
Thanked 0 Times in 0 Posts
Question

Quote:
Originally Posted by DutchDaemon View Post
Wireless setup has changed significantly in FreeBSD 8.

(sorry to link to 'competing forums' )

http://forums.freebsd.org/showthread.php?t=8784
http://forums.freebsd.org/showthread.php?t=5530
One of the "new" things is this:

Code:
# ifconfig wlan0 create wlandev ath0
My system completely freezes after this command.

En ik doe toch echt wel veel moeite om alles te lezen en toe te passen zoals gesuggereerd. Ik heb trouwens net een buildworld gedaan en dat liep helemaal perfect en snel!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FreeBSD 7.2@amd64 atheros problem ath0: stuck beacon; resetting (bmiss count 4) asmo FreeBSD General 0 6th June 2009 11:02 AM
Freebsd Ath0 mode monitor mateusrico FreeBSD General 3 8th April 2009 09:34 AM
Ath0 + wpa, how configure? nesca2in1 FreeBSD General 10 2nd July 2008 04:12 AM


All times are GMT. The time now is 11:22 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick