DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 10th February 2010
IronForge IronForge is offline
Fdisk Soldier
 
Join Date: Jul 2009
Location: SoCal - "have skills, will travel for projects"
Posts: 55
Thanked 0 Times in 0 Posts
Default Enabling an "All-in-One" Printer/Scanner/Fax on OBSD

Greetings:

I've been looking into getting my "All in One", a Brother MFC I bought several years ago. I had a Fedora/WinXP dual boot arrangement at the time, so I didn't need to access some of the features (e.g., Print by Fax) while on Linux.

I've been sending faxes the old fashioned way (since I needed to send signed documents); but wouldn't mind accessing some of the firmware interfaces I had on Windows.

Brother has a "Driver" section for their devices (bugged them a bit about making them avail for Linux) - w/Lpr and CUPS wrappers
http://welcome.solutions.brother.com.../en/index.html
which may work under the fedora-base pkg.

However, this is OBSD - so - I've looked around a bit; and found a few packages that might allow me to run several features (Scanning and Faxing) on OBSD. I don't have much of a hardcopy load to justify buying inkjet cartridges whenever they dry up , so I'd like to take a 2 Part (Scanner, then Fax) approach to see what I can do with this All-in-One.

Starting w/SCANNERS:
I've seen sane-backends, sane-frontends, xsane
I pkg_added them; but xsane can't seem to locate my All-in-One, though it's listed in the "Compatible Devices" Directory at the SANE site.

Scanned the Manual
http://www.sane-project.org/man/sane.7.html
Read that a bit; and understand the libusb is used (and was included in the pkg_add) to access USB based scanners. Noticed that OBSD is still referencing uscanner(4) when I ran "sane-find-scanner -v", though.

Per Readme.OpenBSD for the sane-backends package:
"Make sure your user has read/write access to the scanner device
(e.g. /dev/uscanner0) or you will not be able to scan.

* USB
With some USB backends, the OpenBSD uscanner(4) driver does not support
getting USB vendor and product ids. To make your scanner work with sane,
you'll have to disable uscanner(4) in your kernel - see config(8) -
which will allow libusb to claim your device instead. When using libusb,
you need read/write permissions to ugen(4) (/dev/ugen*.*) and the usb(4)
controller (/dev/usb*) your scanner is connected to (consider using
hotplugd(8) attach and detach scripts)."


I don't have any /dev/uscanner* device directories, only /dev/ugen*.*, so methinks sane-find-scanner -v may be inappropriate for OBSD.

From what I 've read so far, I think I need to do the following:
1) Alter the config file (seen only linux versions - need to look for the OBSD location) to include the "usb VENDOR PRODUCT" entry for my All-in-One (Listed on the SANE site) in the "backends" config file (somewhere - Linux version is explained in text; and it's getting late...)

2) My usb connection to the All-in-One doesn't come up on the dmesg. I had problems with my USB before on another thread, where I was advised to modify and recompile the kernel after disabling echi:
http://www.daemonforums.org/showthre...ighlight=drive

3) Get user acct access to ugen and usb drivers per Readme.OpenBSD and Sane Manual.

Am I on the right track?

Thanks.
Reply With Quote
  #2   (View Single Post)  
Old 10th February 2010
Oko's Avatar
Oko Oko is offline
Fsck Surgeon
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 770
Thanked 36 Times in 32 Posts
Default

Quote:
Originally Posted by IronForge View Post
Greetings:

I've been looking into getting my "All in One", a Brother MFC I bought several years ago.
If you have a good expensive model of Brother MFC the printer speaks PostScript and doesn't need any driver. Check if the sane-backends support
scanning. I would be very surprised that they do. If they do let us know and
we will try to help you. Getting all-in-one is rather tricky because of the way
the device drivers has to get attached (it also doesn't help that devices are
designed with Linux in mind which is completely different OS).

Brother has proprietary Linux drivers for printers and scanners. If your MFC is
of importance to you the best thing would be to use Ubuntu or something like that.
Reply With Quote
  #3   (View Single Post)  
Old 10th February 2010
IronForge IronForge is offline
Fdisk Soldier
 
Join Date: Jul 2009
Location: SoCal - "have skills, will travel for projects"
Posts: 55
Thanked 0 Times in 0 Posts
Default MFC is supported

Thank you, Oko:

From the SANE Support Directory, my model is supported:
http://www.sane-project.org/cgi-bin/...&bus=usb&v=&p=

with the "good" status. Figure it's worth a shot to get it working.

Per my earlier post, it's not essential now (I don't scan or print much - any documents that need printing, it's usually job related and done at the client site, or I just head down to one of several "Big Office Stores" not too far from my home office.

When I do expand my SOHO, I'll upgrade my goods. I lobbied Brother pretty hard (exchanging emails - offering to hack up a draft version) to get them port their drivers to Linux. The MFC was on sale - should have bought a Canon or an HP on hindsight (should have looked it up a bit more).

Figure we get more hardware vendors to recognize/provide for non-Windows system, the better, IMHO. From what I read Sane did state that work on custom backends is not an extremely difficult endeavor.

Here's my dmesg - appreciate the feedback to this thread (especially the 3 steps) - thank you all

$ dmesg
OpenBSD 4.7-beta (GENERIC) #518: Wed Jan 27 19:22:14 MST 2010
todd@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: AMD Sempron(tm) ("AuthenticAMD" 686-class, 256KB L2 cache) 1.01 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,P GE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem = 2113433600 (2015MB)
avail mem = 2039078912 (1944MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 08/31/04, BIOS32 rev. 0 @ 0xfb490, SMBIOS rev. 2.2 @ 0xf0000 (39 entries)
bios0: vendor Phoenix Technologies, LTD version "6.00 PG" date 08/31/2004
apm0 at bios0: Power Management spec V1.2 (slowidle)
apm0: AC on, battery charge unknown
acpi at bios0 function 0x0 not configured
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xdef4
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfde60/144 (7 entries)
pcibios0: PCI Exclusive IRQs: 3 5 9 10 11
pcibios0: PCI Interrupt Router at 000:02:0 ("SiS 85C503 System" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x8000!
cpu0 at mainbus0: (uniprocessor)
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "SiS 741 PCI" rev 0x03
sisagp0 at pchb0
agp0 at sisagp0: aperture at 0xd0000000, size 0x8000000
ppb0 at pci0 dev 1 function 0 "SiS 648FX AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "SiS 6330 VGA" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pcib0 at pci0 dev 2 function 0 "SiS 964 ISA" rev 0x36
pciide0 at pci0 dev 2 function 5 "SiS 5513 EIDE" rev 0x01: 741: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <HDS722540VLAT20>
wd0: 16-sector PIO, LBA48, 39266MB, 80418240 sectors
wd1 at pciide0 channel 0 drive 1: <Maxtor 6L100P0>
wd1: 16-sector PIO, LBA, 95611MB, 195813072 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
wd1(pciide0:0:1): using PIO mode 4, Ultra-DMA mode 6
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <SONY, DVD RW DRU-530A, 1.0d> ATAPI 5/cdrom removable
atapiscsi1 at pciide0 channel 1 drive 1
scsibus1 at atapiscsi1: 2 targets
cd1 at scsibus1 targ 0 lun 0: <HL-DT-ST, CD-RW GCE-8526B, 1.03> ATAPI 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
cd1(pciide0:1:1): using PIO mode 4, Ultra-DMA mode 2
auich0 at pci0 dev 2 function 7 "SiS 7012 AC97" rev 0xa0: irq 5, SiS7012 AC97
ac97: codec id 0x414c4760 (Avance Logic ALC655 rev 0)
audio0 at auich0
ohci0 at pci0 dev 3 function 0 "SiS 5597/5598 USB" rev 0x0f: irq 10, version 1.0, legacy support
ohci1 at pci0 dev 3 function 1 "SiS 5597/5598 USB" rev 0x0f: irq 11, version 1.0, legacy support
ohci2 at pci0 dev 3 function 2 "SiS 5597/5598 USB" rev 0x0f: irq 9, version 1.0, legacy support
ehci0 at pci0 dev 3 function 3 "SiS 7002 USB" rev 0x00: irq 3
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "SiS EHCI root hub" rev 2.00/1.00 addr 1
sis0 at pci0 dev 4 function 0 "SiS 900 10/100BaseTX" rev 0x91: irq 11, address 00:11:5b:15:b4:c5
rlphy0 at sis0 phy 1: RTL8201L 10/100 PHY, rev. 1
unknown vendor 0x2000 product 0x2800 (class communications subclass modem, rev 0x02) at pci0 dev 11 function 0 not configured
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
it0 at isa0 port 0x2e/2: IT8705F rev 3, EC port 0x290
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
usb1 at ohci0: USB revision 1.0
uhub1 at usb1 "SiS OHCI root hub" rev 1.00/1.00 addr 1
usb2 at ohci1: USB revision 1.0
uhub2 at usb2 "SiS OHCI root hub" rev 1.00/1.00 addr 1
usb3 at ohci2: USB revision 1.0
uhub3 at usb3 "SiS OHCI root hub" rev 1.00/1.00 addr 1
biomask ef4d netmask ef4d ttymask ffdf
mtrr: Pentium Pro MTRR support
umass0 at uhub0 port 4 configuration 1 interface 0 "PIONEER CORPORATION PIONEER DVD/CD Writer DVR-S606" rev 2.00/0.01 addr 2
umass0: using SCSI over Bulk-Only
scsibus2 at umass0: 2 targets, initiator 0
cd2 at scsibus2 targ 1 lun 0: <PIONEER, DVD-RW DVR-106D, 1.08> SCSI0 5/cdrom removable
vscsi0 at root
scsibus3 at vscsi0: 256 targets
softraid0 at root
root on wd0a swap on wd0b dump on wd0b
Reply With Quote
  #4   (View Single Post)  
Old 17th February 2010
Oko's Avatar
Oko Oko is offline
Fsck Surgeon
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 770
Thanked 36 Times in 32 Posts
Default

Sorry, I got busy.

1. Install CUPS
2. Read the message
3. Replace LPD with CUPS
4. Install Sand-backends
5. Boot and dissable ultp and umass driver, and possibly uscanner driver.
6. Adjust permissions properly for usb devices and ugen.
7. Go to CUPS interface and add the MFC as printer.
8. Check if printing is working.
9. Run sane-find scanner
10. Post dmesg, result of printing the test page, and result of sane-scanner

Last edited by Oko; 17th February 2010 at 04:38 AM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wpa_supplicant errors: "CTRL-EVENT-SCAN-RESULTS" jackburke FreeBSD General 0 1st February 2010 12:07 AM
A little confused. Do "snapshots" (vs dump=image) have any correlation, non-unix? jb_daefo FreeBSD General 9 21st November 2009 04:41 AM
Fixed "xinit" after _7 _8, "how" here in case anyones' "X" breaks... using "nvidia" jb_daefo Guides 0 5th October 2009 09:31 PM
"Thanks" and "Edit Tags". diw Feedback and Suggestions 2 29th March 2009 12:06 AM


All times are GMT. The time now is 02:25 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick