DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 7th March 2010
texaganian texaganian is offline
New User
 
Join Date: Mar 2010
Posts: 5
Thanked 0 Times in 0 Posts
Default problem with static v4 IPs

Please excuse the fact that I'm probably overlooking something really obvious and trivial but I'm stuck.

I have some OpenBSD background but have not worked with it for a number of years. I recently decided to use OpenBSD (4.6) and pf to build a new firewall that I need.

Initially I set both network interfaces to dhcp in their hostname.if files (hostname.fxp0 & hostname.fxp1) just to make sure all the hardware was working correctly. Everything worked perfectly.

I then changed the hostname.if files to set static IPs as follows:

hostname.fxp1
Code:
inet w.x.y.z 255.255.255.0 w.x.y.255 description internal
where w.x.y.z is the actual IP (of course).

But when I bring the interface up, I get this result:
Code:
fxp1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
         lladdr 00:02:be:28:52:33
         priority: 0
         media: Ethernet autoselect (100BaseTX full-duplex)
         status: active
         inet6 fe80::202:b3ff:fe28:5233%fxp1 prefixlen 64 scopeid 0x2
and, indeed, I don't seem to have any valid IPv4 address.

I checked all the man pages but didn't find anything that illuminated me.

Can someone tell me what I'm missing here?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
static ip's not showing up in routing table birdmansdomain OpenBSD General 4 27th November 2009 12:57 AM
snd_emu10k1 and static kly FreeBSD General 3 17th September 2009 01:28 PM
Static IP address problem rex FreeBSD General 2 25th November 2008 08:53 PM
Cannot assign static IP. bsdnewbie999 OpenBSD General 5 21st June 2008 09:50 AM
dhcpd problems... dynamic and static leases present edhunter FreeBSD General 7 16th May 2008 02:34 PM


All times are GMT. The time now is 03:15 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick