DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Installation and Upgrading

OpenBSD Installation and Upgrading Installing and upgrading OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 5th June 2010
rpindy rpindy is offline
Fdisk Soldier
 
Join Date: May 2010
Posts: 59
Thanked 1 Time in 1 Post
Default Broadcom wireless driver

I have a Linksys WMP54GS wireless card I'm trying to get working. I found this link that gives the info for the Broadcom Airforce card and similar. OpenBSD recognizes the card as bwi, but I can't get it to work. I installed the bwi firmware linked to on the page I linked to above using pkg_add and then rebooted with the installation CD and got this:

Available network interfaces are: bwi0 fxp0 vlan0.
Which one do you wish to configure? (or 'done') [bwi0]
IPv4 address for bwi0? (or 'dhcp' or 'none') [dhcp]
Issuing hostname-associated DHCP request for bwi0.
bwi0: error 2, could not read firmware bwi-airforce
bwi0: error 2, could not read firmware bwi-airforce
bwi0: no link ............. sleeping
bwi0: error 2, could not read firmware bwi-airforce
ifconfig: SIOCDIFADDR: Can't assign requested address
Issuing free-roaming DHCP request for bwi0.
bwi0: error 2, could not read firmware bwi-airforce
bwi0: no link ............. sleeping
bwi0: error 2, could not read firmware bwi-airforce
ifconfig: SIOCDIFADDR: Can't assign requested address

It obviously recognizes the card but not the firmware. My question is if there is a way to get it to read the firmware or somehow access it and ultimately get my wireless working.
Reply With Quote
  #2   (View Single Post)  
Old 5th June 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,873
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by rpindy View Post
OpenBSD recognizes the card as bwi, but I can't get it to work.
Not all Broadcom chips are supported. In fact, this very same question came up earlier today on different hardware:

http://www.daemonforums.org/showthread.php?t=4826

If there is anything further anyone can add, it will only be from seeing hard information. Please post the output of the following command:

$ dmesg | grep 'bwi'
Quote:
I installed the bwi firmware linked to on the page I linked to above using pkg_add and then rebooted with the installation CD and got this:
While this is a way to configure an interface, the "EXAMPLES" section in the bwi(4) manpage describes how this can be done at the command-line, sans install kernel -- not that I am implying that this method will allow you to configure what appears to be a non-supported chip.
Reply With Quote
  #3   (View Single Post)  
Old 5th June 2010
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,608
Thanked 214 Times in 189 Posts
Default

Quote:
Originally Posted by rpindy View Post
I installed the bwi firmware linked to on the page I linked to above using pkg_add and then rebooted with the installation CD ...
If that is true, then you booted the wrong OS. The installation CD is the so called "ramdisk kernel", bsd.rd, which keeps a completely self-contained filesystem structure in RAM. The installed firmware is in /etc/firmware on your hard drive.

(Yes, with admin skills you could mount your root partition and copy the files from the /<mountpoint>/etc into the filesystem in RAM, but such things usually cause the RAM filesystem to run out of memory.)

Boot the standard OS, where the firmware is installed, and try:

# dhclient bwi0

If that works, then all you need do is create an /etc/hostname.bwi0 file -- see FAQ 6 and the hostname.if(5) man page for instructions.
Reply With Quote
  #4   (View Single Post)  
Old 5th June 2010
rpindy rpindy is offline
Fdisk Soldier
 
Join Date: May 2010
Posts: 59
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by ocicat View Post
Please post the output of the following command:

$ dmesg | grep 'bwi'
bwi0 at pci3 dev 0 function 0 "Broadcom BCM4318" rev 0x02: apic 2 int 21 (irq 10), address 00:14:bf:74:65:8e

Quote:
Originally Posted by jggimi View Post
Boot the standard OS, where the firmware is installed, and try:

# dhclient bwi0
All I got was bwi0: no link ................. sleeping, so apparently I need to do something else. I booted into GNOME and used the terminal to do it, so let me know if that's correct. I installed the driver already using pkg_add, so it should have recognized it.
Reply With Quote
  #5   (View Single Post)  
Old 5th June 2010
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,608
Thanked 214 Times in 189 Posts
Default

It's not a driver, it is -firmware-. It contains only code run on the NIC itself.

If you did NOT receive the message:
Code:
bwi0: error 2, could not read firmware bwi-airforce
then the firmware was loaded.

The use of gnome does not matter, dhclient(8) can be run from any shell as the superuser.

Now, it is time to look at the output of "ifconfig bwi0" and see what it says about the status of your wireless networks.
Reply With Quote
  #6   (View Single Post)  
Old 5th June 2010
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,062
Thanked 198 Times in 156 Posts
Default

Just running dhclient will not work on a wireless interace, you will need to setup the proper ssid and possibly also WEP or WPA security first.
Only then can you run dhclient.

If there is no network selected or if the settings are wrong, the "no link" message is displayed.

Also note you must first bring a wireless interface up: % ifconfig bwi0 up

Take a look at ifconfig(8), in particular the section "IEEE 802.11 (WIRELESS DEVICES)".
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
  #7   (View Single Post)  
Old 6th June 2010
tetrodozombie tetrodozombie is offline
Real Name: bill slusser
Banned
 
Join Date: Dec 2009
Location: atlanta, ga
Posts: 82
Thanked 1 Time in 1 Post
Default

I have a Dell latitude with the bwi0 and you have to install the firmware after you install OpenBSD. So, that means you need another computer that gets on the net and go to the OpenBSD site, go to the man pages on the web, search for bwi and it should have a link to point you to or download the firmware update. Once you have it put it on a thumb drive, cd, whatever and keep a copy. I just use any number of usb wifi at install, so I can get net access myself and get the bwi0 firmware update. Hope this helps.
Reply With Quote
  #8   (View Single Post)  
Old 6th June 2010
rpindy rpindy is offline
Fdisk Soldier
 
Join Date: May 2010
Posts: 59
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by jggimi View Post
Now, it is time to look at the output of "ifconfig bwi0" and see what it says about the status of your wireless networks.
bwi0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 1500
lladdr 00:14:bf:74:65:8e
priority: 4
groups: wlan
media: IEEE802.11 autoselect
status: no network
ieee80211: nwid ""

Quote:
Originally Posted by tetrodozombie View Post
I have a Dell latitude with the bwi0 and you have to install the firmware after you install OpenBSD. So, that means you need another computer that gets on the net and go to the OpenBSD site, go to the man pages on the web, search for bwi and it should have a link to point you to or download the firmware update. Once you have it put it on a thumb drive, cd, whatever and keep a copy. I just use any number of usb wifi at install, so I can get net access myself and get the bwi0 firmware update. Hope this helps.
I did that already- I installed the firmware linked to in a man page above using pkg_add. There are a few other man pages I'll probably have to look at. The card I have is about 3 years old so I'm thinking (and hoping) it's not a "newer card" that's unsupported.
Reply With Quote
  #9   (View Single Post)  
Old 6th June 2010
rpindy rpindy is offline
Fdisk Soldier
 
Join Date: May 2010
Posts: 59
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Carpetsmoker View Post
Also note you must first bring a wireless interface up: % ifconfig bwi0 up
I tried that and got a slightly different output. I have the changes in bold.

Code:
bwi0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
lladdr 00:14:bf:74:65:8e
priority: 4
groups: wlan
media: IEEE802.11 autoselect (DS1 mode 11g)
status: no network
ieee80211: nwid ""
inet6 fe80::214:bfff:fe74:658e%bwi0 prefixlen 64 scopeid 0x1
Reply With Quote
Old 6th June 2010
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

Quote:
Originally Posted by rpindy View Post
The card I have is about 3 years old so I'm thinking (and hoping) it's not a "newer card" that's unsupported.
It very well could be, time doesn't magically make chip documentation appear, or code get written.

Have you tried scanning for access points? ifconfig bwi0 scan, post the output here.. you'll need to associate with an access point before you can obtain an IP address.
Reply With Quote
Old 6th June 2010
rpindy rpindy is offline
Fdisk Soldier
 
Join Date: May 2010
Posts: 59
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by BSDfan666 View Post
It very well could be, time doesn't magically make chip documentation appear, or code get written.

Have you tried scanning for access points? ifconfig bwi0 scan, post the output here.. you'll need to associate with an access point before you can obtain an IP address.
Code:
nwid ROUTER chan 9 bssid 00:19:e4:d8:9a:a1 29dB 54M privacy,short_preamble,short_slottime
"ROUTER" is the access point I want to connect to, and am using it wirelessly now on another computer.
Reply With Quote
Old 6th June 2010
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

So try the following:

$ sudo ifconfig bwi0 nwid ROUTER chan 9

Check the output of ifconfig bwi0, confirm it's operational, and then try running dhclient on the interface.

If you have a WEP key, make sure to specify that using nwkey.. this is documented in ifconfig(8) under the IEEE 802.11 (WIRELESS DEVICES) section.
Reply With Quote
Old 17th July 2010
fredo696 fredo696 is offline
New User
 
Join Date: Jul 2010
Posts: 4
Thanked 0 Times in 0 Posts
Default

Hello everybody

I've just got my bwi0 working, on my old HP Pavilion ze2000 laptop
(i'm using a WPA-PSK key)

this is a broadcom BCM4318 too.

How I dit it :


1. installed the firmware like explained in the bwi manpage

2. created (as root) the file /etc/hostname.bwi0 for the interface to be started at boot :

the file contains the following line :

Quote:
dhcp nwid <my_nwid> wpa wpapsk `wpa-psk <my_nwid> <my_wpa-psk-key>`
(for security, chmod 640 /etc/hostname.bwi0 )

reboot, and the interface should be brought up!
Reply With Quote
Old 17th July 2010
fredo696 fredo696 is offline
New User
 
Join Date: Jul 2010
Posts: 4
Thanked 0 Times in 0 Posts
Default

sorry I forgot : OpenBSD 4.7 (amd64) inside
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom BCM5906M 10/100 Ethernet Driver? revzalot Solaris 0 15th June 2009 05:47 PM
Broadcom NIC syrushcw FreeBSD General 5 4th June 2009 01:55 AM
broadcom 4312 jaideep_jdof OpenBSD General 1 18th November 2008 11:45 AM
Freebsd broadcom driver jaideep_jdof FreeBSD Ports and Packages 9 10th November 2008 06:25 PM
rum0 driver wireless fails after install jasites OpenBSD General 10 2nd June 2008 12:14 PM


All times are GMT. The time now is 11:38 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick