DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Installation and Upgrading

OpenBSD Installation and Upgrading Installing and upgrading OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 30th June 2010
Don_HH2K Don_HH2K is offline
New User
 
Join Date: Jun 2010
Posts: 2
Thanked 0 Times in 0 Posts
Default Sun XVR-600 in 24-bit mode

Hello all,

I recently acquired a Sun Blade 1500 workstation. This is an Open Firmware-based SPARC machine so it's a bit different than the x86 hardware I'm used to. Solaris 10 doesn't run well at all on this machine, and OpenBSD appears to be the only other OS with support for the XVR-600 graphics card it's got.

So far I've got Xorg configured with the wildcatfb driver, which works fine on its own. The only issue is that wildcatfb will only cooperate with the framebuffer bit depth it's running on when X is started. The XVR-600 starts in 8-bit mode by default. In Solaris the fbconfig utility is provided to get it running in 24-bit mode, but I can't find a similar utility in OpenBSD (4.7/sparc64) to achieve this.

It's possible to set the framebuffer resolution and refresh rate from within the Open Firmware prompt, but to the best of my knowledge no way to set the bit depth.

If anybody can point me in the right direction to get X running in 24-bit color on this card, I'd very much appreciate it.
Reply With Quote
  #2   (View Single Post)  
Old 30th June 2010
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,608
Thanked 214 Times in 189 Posts
Default

I don't use Sparc boxen with OpenBSD, myself, but I found this in the sparc@ mailing list archive. It may help. http://marc.info/?l=openbsd-sparc&m=107247800227645&w=2
Quote:
One problem usually with SPARC's (which I had) and X was that you need
to set the default color depth to 32 instead of 24 bit (even though the
framebuffers are 24-bit) if you want it to work. Unless, of course
you're satisfied with 8-bit
Reply With Quote
  #3   (View Single Post)  
Old 30th June 2010
Don_HH2K Don_HH2K is offline
New User
 
Join Date: Jun 2010
Posts: 2
Thanked 0 Times in 0 Posts
Default

I gave that a try but get the same behavior as setting 24 (or n != 8) bpp.

Here's an excerpt from my /var/log/Xorg.0.log file:

Code:
(II) wsfb: driver for wsdisplay framebuffer: wsfb
(WW) Falling back to old probe method for wsfb
(II) wsfb(0): using default device
(II) Running in FRAMEBUFFER Mode
(II) wsfb(0): Creating default Display subsection in Screen section
        "Screen0" for depth/fbbpp 32/32
(EE) wsfb(0): specified depth (32) or bpp (32) doesn't match framebuffer depth (8)
(II) UnloadModule: "wsfb"
(EE) Screen(s) found, but none have a usable configuration.
The exact same messages are produced with the wildcatfb driver, substituting "wsfb" for "wildcatfb".

From what I've read there's also the accelerated ifb driver which should work with this card, but I don't have any modules for it installed in /usr/X11R6/lib/modules/drivers, and don't know where I'd go about getting them.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
no-tab-mode in mg? Sunnz OpenBSD General 0 10th March 2010 12:10 PM
Freebsd Ath0 mode monitor mateusrico FreeBSD General 3 8th April 2009 09:34 AM
wlan -> monitor mode ccc FreeBSD Security 2 4th November 2008 09:19 PM
How to check CPU state in non-interactive mode? bsddaemon FreeBSD General 2 18th October 2008 04:50 PM
Setting a nic to promiscuous mode? kardon33 OpenBSD General 4 31st July 2008 02:36 PM


All times are GMT. The time now is 03:31 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick