DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 22nd May 2008
tanked tanked is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 56
Thanked 1 Time in 1 Post
Default Set time in Jail

Hello, when I try to set the time in my jail running the date command I get an "operation not permitted" error. The host that the jail is running on has the correct time, and I assumed the jail would get it's time from that however it appears not. How can I change the time in my jail?

Thanks.
Reply With Quote
  #2   (View Single Post)  
Old 22nd May 2008
anomie's Avatar
anomie anomie is offline
Local
 
Join Date: Apr 2008
Location: Texas
Posts: 446
Thanked 69 Times in 46 Posts
Default

Your jail's date/time is set by the host environment. It sounds like you may just need to set the correct time zone within your jail -- use tzsetup for that.

While you're at it, you may want to comment out the following line in /etc/crontab within the jail:
Code:
#1,31   0-5     *       *       *       root    adjkerntz -a
Otherwise you'll just get lots of warning emails about it within the jail.
__________________
Kill your t.v.
Reply With Quote
  #3   (View Single Post)  
Old 22nd May 2008
tanked tanked is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 56
Thanked 1 Time in 1 Post
Default

Thanks, it was already in the correct time zone but commenting out the crontab entry appears to have fixed it.
Reply With Quote
  #4   (View Single Post)  
Old 21st August 2008
tanked tanked is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 56
Thanked 1 Time in 1 Post
Default

Hello again, I seem to be running into this problem again - I haven't changed any settings on either the jail or the host but for some reason the jail's time is exactly an hour slower than the host's time, I've only just noticed this in the last couple of weeks, the time was correct until recently.

***EDIT*** Sorry, just used tzsetup to change the timezone and it has worked, however I still don't understand how the problem arose in the first place as I haven't touched any of the settings.

Last edited by tanked; 21st August 2008 at 03:52 PM.
Reply With Quote
  #5   (View Single Post)  
Old 21st August 2008
anomie's Avatar
anomie anomie is offline
Local
 
Join Date: Apr 2008
Location: Texas
Posts: 446
Thanked 69 Times in 46 Posts
Default

Please run
% date
in both the host and the jail and post the exact output here.
__________________
Kill your t.v.
Reply With Quote
  #6   (View Single Post)  
Old 22nd August 2008
tanked tanked is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 56
Thanked 1 Time in 1 Post
Default

Hello thanks for replying anomie, as I said tzsetup fixed the problem and its still working today.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
minimal jail install with sysinstall daemon-dd FreeBSD General 3 16th September 2008 08:28 AM
Getting around Jail IP Adresses starbuck FreeBSD Security 8 9th August 2008 01:15 AM
Internet access within jail Weaseal FreeBSD General 5 26th June 2008 02:45 PM
no internet connection inside jail...? bgobs FreeBSD General 11 17th June 2008 04:36 PM
Network not working in my jail. krreagan FreeBSD Security 7 5th May 2008 11:43 PM


All times are GMT. The time now is 11:49 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick