DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 25th August 2010
amorphousone amorphousone is offline
Port Guard
 
Join Date: Nov 2009
Posts: 11
Thanked 0 Times in 0 Posts
Default OBSD client hangs mounting NFS; Linux client doesn't

client 1: Arch linux i686
client 2: OBSD 4.7 i386
server: OBSD 4.7 powerpc

client 1 mounts perfectly and reliably

client 2:
Code:
mount -t nfs myserver:/mnt/mydir /mydir
nothing...

ctrl-c gets me an error message about server not responding (speaking of which; could someone point me to where i can find shutdown and in-use logs? nothing in /var/log/ seemed to have the errors i've seen)

to be sure my server pf.conf wasn't the problem, i disabled it; no change.

server rc.conf.local has:
portmap=YES
nfs_server=YES

i would have thought 2 vanilla OBSD boxes would share without adding any other options, so i basically followed the procedures on faq (and yes i did read the suggested manpages).

what totally obvious thing am i missing here?
Reply With Quote
  #2   (View Single Post)  
Old 25th August 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,902
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by amorphousone View Post
what totally obvious thing am i missing here?
NTFS support is not enabled by default in the kernel as NTFS support is deemed experimental. Reading from NTFS partitions should be fine; writing is for the adventurous.

In order to enable NTFS support, yo will need to uncomment "NTFS" in the GENERIC kernel configuration file, & recompile the kernel according to the informationg found in Section 5.3 of the FAQ.

You should also read the mount_ntfs(8) manpage. There, it states that the kernel supports only NTFS4 & NTFS5.
Reply With Quote
  #3   (View Single Post)  
Old 25th August 2010
IdOp's Avatar
IdOp IdOp is offline
Too dumb for a smartphone
 
Join Date: May 2008
Location: twisting on the daemon's fork(2)
Posts: 572
Thanked 14 Times in 13 Posts
Default

@amorphousone

I probably can't help you with this more than the content of this post, because I've never used OpenBSD for nfs, but it might be helpful if you post the contents of the /etc/exports file on the server and post the nfs options being used by each of the clients.
Reply With Quote
  #4   (View Single Post)  
Old 25th August 2010
amorphousone amorphousone is offline
Port Guard
 
Join Date: Nov 2009
Posts: 11
Thanked 0 Times in 0 Posts
Default

@ocicat,
are you not reading my mount option -t nfs and transposing the letters?
this is a ffs drive i'm trying to share.

mount -t nfs myserver:/mnt/mydir /mydir

or alternately:

Code:
mount_nfs myserver:/mnt/mydir /mydir


@IdOp:
server /etc/exports:
mnt/mydir -maproot=daemon -alldirs myclient

(btw, do we add code tags to .conf contents also?)

OBSD client:
Code:
mount -t nfs myserver:/mnt/mydir /mydir
Linux client:
Code:
mount myserver:/mnt/mydir /mydir

Last edited by amorphousone; 25th August 2010 at 05:09 PM. Reason: added exports and mount info
Reply With Quote
  #5   (View Single Post)  
Old 25th August 2010
IdOp's Avatar
IdOp IdOp is offline
Too dumb for a smartphone
 
Join Date: May 2008
Location: twisting on the daemon's fork(2)
Posts: 572
Thanked 14 Times in 13 Posts
Default

One further thought along the same line. On the client machines, are there entries in /etc/fstab for this nfs mount, which have options which may be getting picked up?

For example, my Linux client accessing NetBSD NFS server uses these options in the fstab:
Code:
myserver:/home/dos  /home/dos  nfs   rw,rsize=65536,wsize=65536,posix,noauto,nfsvers=3,nordirplus
(The details of this example are probably not relevant to your problem.)

Last edited by IdOp; 29th August 2010 at 07:14 PM. Reason: acronym failure
Reply With Quote
  #6   (View Single Post)  
Old 25th August 2010
amorphousone amorphousone is offline
Port Guard
 
Join Date: Nov 2009
Posts: 11
Thanked 0 Times in 0 Posts
Default

yes, in my linux fstab i've specified read and write size for optimal performance. however i'd like to avoid exploring fstab options because it should just work with mount and fstab is just adding another complication into the mix.

from most of the OBSD docs i've read, defaults are generally optimal/sane (for example i read that defining read/write size is generally not needed, a case that wasn't true on my linux box).

from OpenBSD faq (http://www.openbsd.org/faq/faq6.html#NFS:

Quote:
NFS filesystems can be mounted from a client without needing to enable any services or daemons. They can be mounted just like any other filesystem.

NFS filesystems should be mounted via mount(8), or more specifically, mount_nfs(8). To mount a filesystem /work on host 10.0.0.1 to local filesystem /mnt, do this (note that you don't need to use an IP address; mount will resolve host names):

# mount -t nfs 10.0.0.1:/work /mnt
my single mount command should "just work"
Reply With Quote
  #7   (View Single Post)  
Old 25th August 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,902
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by amorphousone View Post
are you not reading my mount option -t nfs and transposing the letters?
My bad. This is what I get for attempting to answer questions while running out the door when going to fight the morning commute...

Reply With Quote
  #8   (View Single Post)  
Old 26th August 2010
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,797
Thanked 214 Times in 189 Posts
Default

I have OBSD systems with NFS mounts working fine. I have also had trouble in the deep dark past, which I will reiterate in short form, in the hope it may help:

The situation:

Mounts would hang using the UDP default protocol. Connections via TCP would work fine.

The root cause:

My server had multiple IP addresses sharing the same NIC. My client was using one of the alias address in the mount request. Traces with tcpdump(8) showed the UDP the mount request arriving at the alias address, but server responses were coming from the base IP address. Because UDP is stateless, the client was ignoring the responses from this address that it did not associate with the server. (TCP, being stateful, did not have this issue.)

The moral of my story:

You may not be using an alias address on your server, as I was. But you may want to still test TCP protocol, to see if there is a different result. As I did, you may discover that learning to use tcpdump(8) to analyze network problems will be more helpful for more things than you'd ever imagined.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Server-Client c0mrade Programming 3 18th March 2009 05:22 PM
ipsec with client nat sicute OpenBSD General 0 30th October 2008 05:39 PM
IM Client schrodinger OpenBSD Packages and Ports 6 16th September 2008 02:09 PM
DDNS Client revzalot OpenBSD Installation and Upgrading 3 12th August 2008 02:21 AM
Client torrent ! gnowar OpenBSD General 10 3rd June 2008 10:50 AM


All times are GMT. The time now is 11:54 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick