DaemonForums  

Go Back   DaemonForums > Miscellaneous > Guides

Guides All Guides and HOWTO's.

Reply
 
Thread Tools Display Modes
Old 30th August 2010
vato vato is offline
Port Guard
 
Join Date: Aug 2010
Posts: 31
Thanked 0 Times in 0 Posts
Default

what does [e.g.]
Code:
pkg_add: warning: package 'xfce4-session-4.6.2' requires 'python26-2.6.5_1', but 'python26-2.6.5' is installed
mean?

Code:
pkg_add -r xfce4
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/Latest/xfce4.tbz... Done.
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/icons-tango-0.8.90_1.tbz... Done.
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/icons-tango-extras-0.1.0_4.tbz... Done.
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/xfce4-wm-themes-4.6.0.tbz... Done.
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/a2ps-a4-4.13b_4.tbz... Done.
pkg_add: warning: package 'a2ps-a4-4.13b_4' requires 'perl-5.10.1_2', but 'perl-5.10.1_1' is installed
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/gtk-xfce-engine-2.6.0_3.tbz... Done.
pkg_add: warning: package 'gtk-xfce-engine-2.6.0_3' requires 'python26-2.6.5_1', but 'python26-2.6.5' is installed
pkg_add: warning: package 'gtk-xfce-engine-2.6.0_3' requires 'perl-5.10.1_2', but 'perl-5.10.1_1' is installed
pkg_add: warning: package 'gtk-xfce-engine-2.6.0_3' requires 'pkg-config-0.25', but 'pkg-config-0.23_1' is installed
pkg_add: warning: package 'gtk-xfce-engine-2.6.0_3' requires 'freetype2-2.4.1', but 'freetype2-2.3.12' is installed
pkg_add: warning: package 'gtk-xfce-engine-2.6.0_3' requires 'pcre-8.10', but 'pcre-8.02' is installed
pkg_add: warning: package 'gtk-xfce-engine-2.6.0_3' requires 'pango-1.28.1', but 'pango-1.28.0_1' is installed
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/xfce4-session-4.6.2.tbz... Done.
pkg_add: warning: package 'xfce4-session-4.6.2' requires 'python26-2.6.5_1', but 'python26-2.6.5' is installed
pkg_add: warning: package 'xfce4-session-4.6.2' requires 'perl-5.10.1_2', but 'perl-5.10.1_1' is installed
pkg_add: warning: package 'xfce4-session-4.6.2' requires 'pkg-config-0.25', but 'pkg-config-0.23_1' is installed
pkg_add: warning: package 'xfce4-session-4.6.2' requires 'freetype2-2.4.1', but 'freetype2-2.3.12' is installed
pkg_add: warning: package 'xfce4-session-4.6.2' requires 'pcre-8.10', but 'pcre-8.02' is installed
pkg_add: warning: package 'xfce4-session-4.6.2' requires 'startup-notification-0.10_1', but 'startup-notification-0.10' is installed
pkg_add: warning: package 'xfce4-session-4.6.2' requires 'pango-1.28.1', but 'pango-1.28.0_1' is installed
pkg_add: warning: package 'xfce4-session-4.6.2' requires 'libwnck-2.30.2', but 'libwnck-2.30.0_1' is installed
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/xfce4-print-4.6.1_6.tbz... Done.
pkg_add: warning: package 'xfce4-print-4.6.1_6' requires 'python26-2.6.5_1', but 'python26-2.6.5' is installed
pkg_add: warning: package 'xfce4-print-4.6.1_6' requires 'perl-5.10.1_2', but 'perl-5.10.1_1' is installed
pkg_add: warning: package 'xfce4-print-4.6.1_6' requires 'pkg-config-0.25', but 'pkg-config-0.23_1' is installed
pkg_add: warning: package 'xfce4-print-4.6.1_6' requires 'freetype2-2.4.1', but 'freetype2-2.3.12' is installed
pkg_add: warning: package 'xfce4-print-4.6.1_6' requires 'pcre-8.10', but 'pcre-8.02' is installed
pkg_add: warning: package 'xfce4-print-4.6.1_6' requires 'startup-notification-0.10_1', but 'startup-notification-0.10' is installed
pkg_add: warning: package 'xfce4-print-4.6.1_6' requires 'pango-1.28.1', but 'pango-1.28.0_1' is installed
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/mousepad-0.2.16_7.tbz... Done.
pkg_add: warning: package 'mousepad-0.2.16_7' requires 'python26-2.6.5_1', but 'python26-2.6.5' is installed
pkg_add: warning: package 'mousepad-0.2.16_7' requires 'perl-5.10.1_2', but 'perl-5.10.1_1' is installed
pkg_add: warning: package 'mousepad-0.2.16_7' requires 'pkg-config-0.25', but 'pkg-config-0.23_1' is installed
pkg_add: warning: package 'mousepad-0.2.16_7' requires 'freetype2-2.4.1', but 'freetype2-2.3.12' is installed
pkg_add: warning: package 'mousepad-0.2.16_7' requires 'pcre-8.10', but 'pcre-8.02' is installed
pkg_add: warning: package 'mousepad-0.2.16_7' requires 'startup-notification-0.10_1', but 'startup-notification-0.10' is installed
pkg_add: warning: package 'mousepad-0.2.16_7' requires 'pango-1.28.1', but 'pango-1.28.0_1' is installed
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/xfce4-settings-4.6.5.tbz... Done.
pkg_add: warning: package 'xfce4-settings-4.6.5' requires 'python26-2.6.5_1', but 'python26-2.6.5' is installed
pkg_add: warning: package 'xfce4-settings-4.6.5' requires 'perl-5.10.1_2', but 'perl-5.10.1_1' is installed
pkg_add: warning: package 'xfce4-settings-4.6.5' requires 'pkg-config-0.25', but 'pkg-config-0.23_1' is installed
pkg_add: warning: package 'xfce4-settings-4.6.5' requires 'freetype2-2.4.1', but 'freetype2-2.3.12' is installed
pkg_add: warning: package 'xfce4-settings-4.6.5' requires 'pcre-8.10', but 'pcre-8.02' is installed
pkg_add: warning: package 'xfce4-settings-4.6.5' requires 'startup-notification-0.10_1', but 'startup-notification-0.10' is installed
pkg_add: warning: package 'xfce4-settings-4.6.5' requires 'pango-1.28.1', but 'pango-1.28.0_1' is installed
pkg_add: warning: package 'xfce4-settings-4.6.5' requires 'consolekit-0.4.1_4', but 'consolekit-0.4.1_3' is installed
pkg_add: warning: package 'xfce4-settings-4.6.5' requires 'libwnck-2.30.2', but 'libwnck-2.30.0_1' is installed
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/xfce4-utils-4.6.2.tbz... Done.
pkg_add: warning: package 'xfce4-utils-4.6.2' requires 'python26-2.6.5_1', but 'python26-2.6.5' is installed
pkg_add: warning: package 'xfce4-utils-4.6.2' requires 'perl-5.10.1_2', but 'perl-5.10.1_1' is installed
pkg_add: warning: package 'xfce4-utils-4.6.2' requires 'pkg-config-0.25', but 'pkg-config-0.23_1' is installed
pkg_add: warning: package 'xfce4-utils-4.6.2' requires 'freetype2-2.4.1', but 'freetype2-2.3.12' is installed
pkg_add: warning: package 'xfce4-utils-4.6.2' requires 'pcre-8.10', but 'pcre-8.02' is installed
pkg_add: warning: package 'xfce4-utils-4.6.2' requires 'startup-notification-0.10_1', but 'startup-notification-0.10' is installed
pkg_add: warning: package 'xfce4-utils-4.6.2' requires 'pango-1.28.1', but 'pango-1.28.0_1' is installed
pkg_add: warning: package 'xfce4-utils-4.6.2' requires 'consolekit-0.4.1_4', but 'consolekit-0.4.1_3' is installed
pkg_add: warning: package 'xfce4-utils-4.6.2' requires 'libwnck-2.30.2', but 'libwnck-2.30.0_1' is installed
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/xfce4-mixer-4.6.1_6.tbz... Done.
pkg_add: warning: package 'xfce4-mixer-4.6.1_6' requires 'python26-2.6.5_1', but 'python26-2.6.5' is installed
pkg_add: warning: package 'xfce4-mixer-4.6.1_6' requires 'perl-5.10.1_2', but 'perl-5.10.1_1' is installed
pkg_add: warning: package 'xfce4-mixer-4.6.1_6' requires 'pkg-config-0.25', but 'pkg-config-0.23_1' is installed
pkg_add: warning: package 'xfce4-mixer-4.6.1_6' requires 'freetype2-2.4.1', but 'freetype2-2.3.12' is installed
pkg_add: warning: package 'xfce4-mixer-4.6.1_6' requires 'pcre-8.10', but 'pcre-8.02' is installed
pkg_add: warning: package 'xfce4-mixer-4.6.1_6' requires 'orc-0.4.6', but 'orc-0.4.5' is installed
pkg_add: warning: package 'xfce4-mixer-4.6.1_6' requires 'startup-notification-0.10_1', but 'startup-notification-0.10' is installed
pkg_add: warning: package 'xfce4-mixer-4.6.1_6' requires 'pango-1.28.1', but 'pango-1.28.0_1' is installed
pkg_add: warning: package 'xfce4-mixer-4.6.1_6' requires 'gstreamer-0.10.30', but 'gstreamer-0.10.29_1' is installed
pkg_add: warning: package 'xfce4-mixer-4.6.1_6' requires 'gstreamer-plugins-0.10.30,3', but 'gstreamer-plugins-0.10.29,3' is installed
pkg_add: warning: package 'xfce4-mixer-4.6.1_6' requires 'gstreamer-plugins-good-0.10.24,3', but 'gstreamer-plugins-good-0.10.23,3' is installed
pkg_add: warning: package 'xfce4-mixer-4.6.1_6' requires 'consolekit-0.4.1_4', but 'consolekit-0.4.1_3' is installed
pkg_add: warning: package 'xfce4-mixer-4.6.1_6' requires 'libwnck-2.30.2', but 'libwnck-2.30.0_1' is installed
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/orage-4.6.1_6.tbz... Done.
pkg_add: warning: package 'orage-4.6.1_6' requires 'python26-2.6.5_1', but 'python26-2.6.5' is installed
pkg_add: warning: package 'orage-4.6.1_6' requires 'perl-5.10.1_2', but 'perl-5.10.1_1' is installed
pkg_add: warning: package 'orage-4.6.1_6' requires 'pkg-config-0.25', but 'pkg-config-0.23_1' is installed
pkg_add: warning: package 'orage-4.6.1_6' requires 'freetype2-2.4.1', but 'freetype2-2.3.12' is installed
pkg_add: warning: package 'orage-4.6.1_6' requires 'pcre-8.10', but 'pcre-8.02' is installed
pkg_add: warning: package 'orage-4.6.1_6' requires 'startup-notification-0.10_1', but 'startup-notification-0.10' is installed
pkg_add: warning: package 'orage-4.6.1_6' requires 'pango-1.28.1', but 'pango-1.28.0_1' is installed
pkg_add: warning: package 'orage-4.6.1_6' requires 'consolekit-0.4.1_4', but 'consolekit-0.4.1_3' is installed
pkg_add: warning: package 'orage-4.6.1_6' requires 'libwnck-2.30.2', but 'libwnck-2.30.0_1' is installed
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/xfce4-appfinder-4.6.2.tbz... Done.
pkg_add: warning: package 'xfce4-appfinder-4.6.2' requires 'python26-2.6.5_1', but 'python26-2.6.5' is installed
pkg_add: warning: package 'xfce4-appfinder-4.6.2' requires 'perl-5.10.1_2', but 'perl-5.10.1_1' is installed
pkg_add: warning: package 'xfce4-appfinder-4.6.2' requires 'pkg-config-0.25', but 'pkg-config-0.23_1' is installed
pkg_add: warning: package 'xfce4-appfinder-4.6.2' requires 'freetype2-2.4.1', but 'freetype2-2.3.12' is installed
pkg_add: warning: package 'xfce4-appfinder-4.6.2' requires 'pcre-8.10', but 'pcre-8.02' is installed
pkg_add: warning: package 'xfce4-appfinder-4.6.2' requires 'startup-notification-0.10_1', but 'startup-notification-0.10' is installed
pkg_add: warning: package 'xfce4-appfinder-4.6.2' requires 'pango-1.28.1', but 'pango-1.28.0_1' is installed
pkg_add: warning: package 'xfce4-appfinder-4.6.2' requires 'consolekit-0.4.1_4', but 'consolekit-0.4.1_3' is installed
pkg_add: warning: package 'xfce4-appfinder-4.6.2' requires 'libwnck-2.30.2', but 'libwnck-2.30.0_1' is installed
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/All/Terminal-0.4.5.tbz... Done.
pkg_add: warning: package 'Terminal-0.4.5' requires 'python26-2.6.5_1', but 'python26-2.6.5' is installed
pkg_add: warning: package 'Terminal-0.4.5' requires 'perl-5.10.1_2', but 'perl-5.10.1_1' is installed
pkg_add: warning: package 'Terminal-0.4.5' requires 'pkg-config-0.25', but 'pkg-config-0.23_1' is installed
pkg_add: warning: package 'Terminal-0.4.5' requires 'freetype2-2.4.1', but 'freetype2-2.3.12' is installed
pkg_add: warning: package 'Terminal-0.4.5' requires 'pcre-8.10', but 'pcre-8.02' is installed
pkg_add: warning: package 'Terminal-0.4.5' requires 'pango-1.28.1', but 'pango-1.28.0_1' is installed
pkg_add: warning: package 'Terminal-0.4.5' requires 'consolekit-0.4.1_4', but 'consolekit-0.4.1_3' is installed
pkg_add: warning: package 'Terminal-0.4.5' requires 'vte-0.24.3', but 'vte-0.24.1' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'python26-2.6.5_1', but 'python26-2.6.5' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'perl-5.10.1_2', but 'perl-5.10.1_1' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'pkg-config-0.25', but 'pkg-config-0.23_1' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'freetype2-2.4.1', but 'freetype2-2.3.12' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'pcre-8.10', but 'pcre-8.02' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'orc-0.4.6', but 'orc-0.4.5' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'startup-notification-0.10_1', but 'startup-notification-0.10' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'pango-1.28.1', but 'pango-1.28.0_1' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'gstreamer-0.10.30', but 'gstreamer-0.10.29_1' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'gstreamer-plugins-0.10.30,3', but 'gstreamer-plugins-0.10.29,3' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'gstreamer-plugins-good-0.10.24,3', but 'gstreamer-plugins-good-0.10.23,3' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'consolekit-0.4.1_4', but 'consolekit-0.4.1_3' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'libwnck-2.30.2', but 'libwnck-2.30.0_1' is installed
pkg_add: warning: package 'xfce-4.6.2' requires 'vte-0.24.3', but 'vte-0.24.1' is installed
Reply With Quote
Old 30th August 2010
vato vato is offline
Port Guard
 
Join Date: Aug 2010
Posts: 31
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by vermaden View Post
XFCE is generally light out from the box but it can be a lot more light, to have most of its functionality we need only these 3 processes running:
Code:
VSZ   RSS   COMMAND
14080  9300  xfwm4
23448 12020  xfce4-panel
19836  9512  xfce4-menu-plugin

well...i do not thanq cause(just see my top) a bunch of process:

http://i37.tinypic.com/2im6zv6.jpg

Last edited by Carpetsmoker; 31st August 2010 at 11:47 AM. Reason: Large image removed, please observe the rules on the subject: http://www.daemonforums.org/showthread.php?t=10#images
Reply With Quote
Old 31st August 2010
klanger klanger is offline
Port Guard
 
Join Date: May 2010
Posts: 29
Thanked 1 Time in 1 Post
Default

It is XFCE4 (WM/DM) not magic

You can switch off dbus and hald with vermaden witch was published in BSD Magazine few month ago
Reply With Quote
Old 31st August 2010
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,074
Thanked 198 Times in 156 Posts
Default

Quote:
what does [e.g.] mean
pkg_add: warning: package 'xfce4-session-4.6.2' requires 'python26-2.6.5_1', but 'python26-2.6.5' is installe
FreeBSD CURRENT is a moving target, and it constantly changing.
Likewise, the packages built for CURRENT are also always changing, being built as soon as the ports are updated*.

This is different from FreeBSD RELEASE, as soon as a release is made (For example 8.1). all packages at that moment are built, after which they will stay the same; Updates in the port directory will not affect the packages for 8.1 release.

The above message means that xfce4-session package was built against and expects python26 version 2.6.5_1, however, your system has a previous version installed: 2.6.5.

Does this matter? This depends on the packages and what was changed in the new versions. It will often work if the changes are small, but it may also break things.

As I've mentioned before, FreeBSD 9 CURRENT is intended for developers and advanced users. For mere mortals such as ourselves using FreeBSD 8 (RELEASE/STABLE) is highly recommended.


*: In reality there may actually be a lag of several days or even weeks, depending on how busy the FreeBSD package build system is.
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
Old 31st August 2010
vato vato is offline
Port Guard
 
Join Date: Aug 2010
Posts: 31
Thanked 0 Times in 0 Posts
Default

i'm starting to think that is a mith the 'only these 3 processes running'...
Reply With Quote
Old 1st September 2010
vermaden's Avatar
vermaden vermaden is offline
Administrator
 
Join Date: Apr 2008
Location: pl_PL.lodz
Posts: 1,052
Thanked 118 Times in 93 Posts
Default

Quote:
Originally Posted by vato View Post
i'm starting to think that is a mith the 'only these 3 processes running'...
The HOWTO is from 2008/05 which is more then 2 years old, things could and propably have changed, maybe You now need to kill more 'default' XFCE processes after launching the needed ones.
__________________
religions, worst damnation of mankind
"If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds

Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”.
vermaden's: links resources deviantart spreadbsd
Reply With Quote
Old 2nd September 2010
vato vato is offline
Port Guard
 
Join Date: Aug 2010
Posts: 31
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by klanger View Post
You can switch off dbus and hald with vermaden witch was published in BSD Magazine few month ago
oh yeah i want it...how's so?

Quote:
with vermaden witch was published in BSD Magazine few month ago
Wtf!...
Reply With Quote
Old 2nd September 2010
vermaden's Avatar
vermaden vermaden is offline
Administrator
 
Join Date: Apr 2008
Location: pl_PL.lodz
Posts: 1,052
Thanked 118 Times in 93 Posts
Default

Quote:
Originally Posted by vato View Post
oh yeah i want it...how's so?
http://forums.freebsd.org/showthread.php?t=7956
__________________
religions, worst damnation of mankind
"If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds

Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”.
vermaden's: links resources deviantart spreadbsd
Reply With Quote
Reply

Tags
xfce

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HOWTO: XFCE MacOS-like menu plugin vermaden Guides 13 20th April 2009 06:40 AM
Xfce. Why didnt anyone tell me? neurosis FreeBSD Ports and Packages 4 21st October 2008 03:10 PM
xfce darken FreeBSD Ports and Packages 4 31st July 2008 05:28 PM
Autostart Xfce ninjatux FreeBSD General 8 16th June 2008 06:47 AM
Howto start the Xfce? aleunix OpenBSD Packages and Ports 5 3rd June 2008 10:58 AM


All times are GMT. The time now is 12:19 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick