DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 13th January 2011
jackthechemist jackthechemist is offline
Port Guard
 
Join Date: Dec 2010
Posts: 14
Thanked 0 Times in 0 Posts
Default Is the problem X11, Fvwm2, or Firefox? Key binding config...

Greetings everyone,

My OpenBSD UI is sillier than a barrel of frogs and I can't figure out why!

So far my experience on this forum has been good, and before giving up and installing Fluxbox I thought I'd ask ... actually I don't even know the question ... but these are the problems I have:

I installed Firefox. Works fine but the title bar is above the topmost virtual desktop, I cannot reach it nor can I move the window (it's like that whenever I start Firefox) and further, if I left-click in the window, anyway, it just scrolls up? I can't click links or buttons or anything!

I cannot seem to move, or resize the terminal window (or any other window). Now, I may not be an OpenBSD expert, but I am not stupid! And after a week I still can't move a window, I think there may be something wrong.

I'm not sure if these two things are related. Currently I'm trying to understand the Fvwm configuration file hoping to find a line that says "LetWindowsMoveAndResize==NO".

I've heard a couple people say that, by default, dragging and resizing windows should be trivial....

Sorry for the long post .... anyone have any ideas/suggestions? I'm really stumped!

Jack
Reply With Quote
  #2   (View Single Post)  
Old 14th January 2011
graudeejs's Avatar
graudeejs graudeejs is offline
Real Name: Aldis Berjoza
formerly killasmurf86
 
Join Date: Jul 2008
Location: Riga, Latvia
Posts: 588
Thanked 29 Times in 26 Posts
Default

This is for fvwm 2.5.x, but much applies to 2.4.x as well
http://fvwm.org/doc/unstable/allCommands.html

Here's my fvwm config.
http://hg.bsdroot.lv/aldis/dot.fvwm/
It is designed for fvwm 2.5.x
I wrote some stuff little different, so you may need to make a link to ~/.fvwm/config
I don't remember which file fvwm 2.4 was reading.

in my config there's config.sh script. I wrote my config very dynamic using sh as preprocessor
in .xinitrc you need to add
Code:
exec sh -c "$HOME/.fvwm/config.sh; exec fvwm > $HOME/.fvwm/logs/fvwm.log 2> $HOME/.fvwm/logs/fvwm.err.log"
check out manual for fvwm
Code:
man fvwm
Here's entire fvwm documentation
http://www.fvwm.org/documentation/

Also:
You may want to remove your current fvwm config, and then see if default config works (it should)

Last edited by graudeejs; 14th January 2011 at 06:21 AM.
Reply With Quote
  #3   (View Single Post)  
Old 14th January 2011
wimwauters wimwauters is offline
Port Guard
 
Join Date: Aug 2008
Posts: 36
Thanked 1 Time in 1 Post
Default

Also, you did start with a coherent set of installation binaries and a matching set of packages, yes?
Reply With Quote
  #4   (View Single Post)  
Old 14th January 2011
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,608
Thanked 214 Times in 189 Posts
Default

Is it possible you've left your FF session in "Full Screen" mode? F11 will toggle back and forth.
Reply With Quote
  #5   (View Single Post)  
Old 15th January 2011
jackthechemist jackthechemist is offline
Port Guard
 
Join Date: Dec 2010
Posts: 14
Thanked 0 Times in 0 Posts
Question

jggimi,
No, Firefox is not in full screen mode. All I know is that I somehow coaxed the browser window into moving up and now I can't get it back, or move any other window apparently.

wimwauters,
coherent binaries and matching packages? I'm not entirely sure what you mean. I installed from cd48.iso as is and firefox 3.6.8 was the first and only package i installed (it was the only version listed so I installed it)

killasmurf,
Thanks for the links. They will be helpful. But I'm afraid your config files are a little over my head :P

I did find something odd though...

By default fvwm loads one 3x3 desktop, but nothing is returned when I run:

cat /home/user/.fvwm2rc | grep Desktop # (looking for DesktopName or DesktopSize)

I ran the same command for the system.fvwm2rc, system.fvwm2rc-sample-1, and system.fvwm2rc-2 files in /usr/X11R6/lib/X11/fvwm/ and nothing is returned.

So I added "DesktopSize 2x2" and "DesktopName 0 Main" to my home config, restarted fvwm, and I still have a 3x3 desktop?!

So obviously fvwm is not being affected by my /home/user/.fvwm2rc file!
Now, I don't mind fiddling around until the key bindings are they way I like, but does anyone have any idea why fvwm is not being affected by the changes I make in the file??

Jack
Reply With Quote
  #6   (View Single Post)  
Old 15th January 2011
graudeejs's Avatar
graudeejs graudeejs is offline
Real Name: Aldis Berjoza
formerly killasmurf86
 
Join Date: Jul 2008
Location: Riga, Latvia
Posts: 588
Thanked 29 Times in 26 Posts
Default

Post your fvwm config
also when you start fvwm (from xinitrc redirect output to file and post it as well)

Last edited by graudeejs; 15th January 2011 at 10:08 AM.
Reply With Quote
  #7   (View Single Post)  
Old 15th January 2011
Beastie Beastie is offline
Daemonology student
 
Join Date: Jan 2009
Location: /dev/earth0
Posts: 269
Thanked 23 Times in 23 Posts
Default

Quote:
Originally Posted by jackthechemist View Post
So obviously fvwm is not being affected by my /home/user/.fvwm2rc file!
The man page says this is valid, but I've never used it. I always use the first location mentioned, i.e. ~/.fvwm/config.

To solve your problem you can add these keyboard bindings and reload the configuration:
Code:
Key	Left	A	CM	Move w-25p keep
Key	Right	A	CM	Move w+25p keep
Key	Up	A	CM	Move keep w-25p
Key	Down	A	CM	Move keep w+25p
Just activate your browser's window and use Ctrl + Alt + an arrow key to move it. Change the key combinations and distance (25 pixels) as you see fit.

And to make your life easier, add these items to your root menu:
Code:
+ "Reload configuration" Read config
+ "Restart fvwm" Restart
These are pretty straightforward: the first rereads the configuration file named config and the second does a full restart of fvwm.

Quote:
Originally Posted by jackthechemist View Post
I cannot seem to move, or resize the terminal window (or any other window).
You must write functions to do that (and everything else) and "enable" these functions by linking them to mouse/keyboard bindings or menu items.
__________________
May the source be with you!
Reply With Quote
  #8   (View Single Post)  
Old 15th January 2011
Mako_Elite Mako_Elite is offline
BSD_ROCKS
 
Join Date: Nov 2010
Posts: 39
Thanked 0 Times in 0 Posts
Default

jackthechemist,

Your problem is fvwm2rc in your /home/usr/.fvwm2rc it should read .fvwmrc.

Your options are to rename it or better to delete it and do following.

cd /usr/X11/R6/lib/X11/fvwm
(you will see system.fvwm2rc file, copy it to your home directory.) Make sure you logged in as user not root.

cp system.fvwm2rc ~/.fvwmrc
(This will copy the file to home directory
and rename it to .fvwmrc)

cd ~/ (Change to home directory)

ls -lA (Check to see if the file .fvwmrc is there)

chmod 660 .fvwmrc (This will give the file permission to modify)

Make sure there is . (period) in front of .fvwmrc

Log out and log in to X and you should be able to have good running X and be able to tweak your .fvwmrc.

Suggestion, before you make any changes to .fvwmrc make copy of it
something like .fvwmrc_copy. This way when you screw too much your original you can rename your .fvwmrc_copy to .fvwmrc and you back to
original.
Reply With Quote
  #9   (View Single Post)  
Old 28th January 2011
jackthechemist jackthechemist is offline
Port Guard
 
Join Date: Dec 2010
Posts: 14
Thanked 0 Times in 0 Posts
Default

Hey again! Thanks for your help. I renamed the config file from .fvwm2rc to .fvwmrc and tested it using Beastie's key bindings, which worked (Thanks Mako). Actually, I did this quite a while ago and played around with the config file for about a week. I've decided I appreciate and admire fvwm, and will now use dwm for now anyways.

This worked out well however as it elucidated the source of one of my initial concerns:

PROBLEM: Left clicking in a window causes the page to scroll up. (Firefox, xterm (e.g. when viewing a manual pages, even emacs (sometimes) ! This occurs under fvwm or dwm so is it X?


Not sure if it helps but I switched window managers by editing "fvwm || xterm" in ~/.xinitrc to read "dwm || xterm" and also I sometimes get "(firefox-bin:10752) Gtk-CTRITICAL **" or "(firefox-bin:10752) Gtk-CTRITICAL **") sent to my terminal...but somehow I doubt these are the problems...

Any suggestions regarding the mouse-left-click-scroll-up problem would be great appreciated, I'm really stumped on this one! :S
Reply With Quote
Old 28th January 2011
graudeejs's Avatar
graudeejs graudeejs is offline
Real Name: Aldis Berjoza
formerly killasmurf86
 
Join Date: Jul 2008
Location: Riga, Latvia
Posts: 588
Thanked 29 Times in 26 Posts
Default

Whatever it is it is not FVWM fault
Reply With Quote
Old 30th January 2011
TerryP's Avatar
TerryP TerryP is offline
Arp Constable
 
Join Date: May 2008
Location: USofA
Posts: 1,547
Thanked 112 Times in 104 Posts
Default

I the only one to think of checking if the build accepts the -geometry flag? You know, the one that lets you set the start size and position of an X app?

Although steaming pile of Mozilla is usually a headache, so it might totally ignore both what the user and the window manager say ^_^.
__________________
My Journal

Thou shalt check the array bounds of all strings (indeed, all arrays), for surely where thou typest ``foo'' someone someday shall type ``supercalifragilisticexpialidocious''.
Reply With Quote
Old 1st February 2011
girarde girarde is offline
Port Guard
 
Join Date: Nov 2010
Location: NW FL
Posts: 26
Thanked 1 Time in 1 Post
Default

To the best of my knowledge, Firefox ignores -geometry.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to re-run make config? FreeBee FreeBSD Ports and Packages 5 11th January 2010 10:56 AM
Fluxbox + Firefox = UTF8 title problem.. DNAeon FreeBSD Ports and Packages 7 10th December 2008 08:52 AM
Need to use full path to commands and xorg.config problem phreud FreeBSD General 4 17th November 2008 07:44 PM
Firefox 2.0 Crash Problem disappearedng FreeBSD General 13 8th November 2008 05:54 AM
Upgrading firefox to firefox 3 -keeping plugins+bookmarks kasse FreeBSD Ports and Packages 11 5th July 2008 01:34 PM


All times are GMT. The time now is 07:34 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick