DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Installation and Upgrading

OpenBSD Installation and Upgrading Installing and upgrading OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 31st January 2011
plexter plexter is offline
Shell Scout
 
Join Date: May 2008
Posts: 124
Thanked 0 Times in 0 Posts
Question Error in Gettext

Hello all,

I've just finished upgrading an OpenBSD system to the latest. For the most part it seems to be running fine.

However when I try and update the packages some of the packages give errors regarding gettext. I've tried updating manually via pkg_add and ports.

The error I seem to get is something like this:

Code:
*** Error code 1

Stop in /usr/ports/devel/gettext (line 1611 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1
Note: the above was from trying to make update php5.

I believe gettext must be corrupt? However trying to install/reinstall fails.

Code:
*** Error code 1

Stop in /usr/ports/devel/gettext (line 1611 of /usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/devel/gettext (line 2116 of /usr/ports/infrastructure/mk/bsd.port.mk).
Anyone have any thoughts?
Reply With Quote
  #2   (View Single Post)  
Old 31st January 2011
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,935
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by plexter View Post
I've just finished upgrading an OpenBSD system to the latest.
Which version? To OpenBSD 4.8-release or to a snaphot of -current?
Quote:
However when I try and update the packages some of the packages give errors regarding gettext. I've tried updating manually via pkg_add and ports.
What command did you use to obtain the ports tree? If you used the following:

# cvs -d$CVSROOT checkout -P ports

This command will get the HEAD of CVS for the ports branch which targets -current. The command which should have been used is (assuming OpenBSD 4.8 is installed...):

# cvs -d$CVSROOT checkout -rOPENBSD_4_8 -P ports

Section 15.4.1 of the FAQ discusses common errors made which will cause compilation errors. Mismatching the version of .the tree to what version of the operating system installed is perhaps the most common cause.
Reply With Quote
  #3   (View Single Post)  
Old 31st January 2011
plexter plexter is offline
Shell Scout
 
Join Date: May 2008
Posts: 124
Thanked 0 Times in 0 Posts
Default

Okay resolved the gettext errors but I still don't seem to be able to update php5. Am I doing something wrong here?

Code:
pkg_add -u php5-core
php5-core-5.2.6->php5-core-5.2.13p0 forward dependencies:
| Dependency of php5-mysql-5.2.6 on php5-core-5.2.6 doesn't match
| Dependency of php5-mbstring-5.2.6 on php5-core-5.2.6 doesn't match
| Dependency of php5-imap-5.2.6 on php5-core-5.2.6 doesn't match
| Dependency of php5-gd-5.2.6 on php5-core-5.2.6 doesn't match
| Dependency of php5-mhash-5.2.6 on php5-core-5.2.6 doesn't match
| Dependency of php5-extensions-5.2.6 on php5-core-5.2.6 doesn't match
| Dependency of php5-mcrypt-5.2.6 on php5-core-5.2.6 doesn't match
| Dependency of php5-gmp-5.2.6 on php5-core-5.2.6 doesn't match
Merging php5-mysql-5.2.6->php5-mysql-5.2.13p0 (ok)
Merging php5-mbstring-5.2.6->php5-mbstring-5.2.13p0 (ok)
Merging php5-imap-5.2.6->php5-imap-5.2.13p0 (ok)
Merging php5-gd-5.2.6->php5-gd-5.2.13p0 (ok)
Merging php5-mhash-5.2.6->php5-mhash-5.2.13p0 (ok)
Merging php5-extensions-5.2.6->php5-extensions-5.2.13p0 (ok)
Merging php5-mcrypt-5.2.6->php5-mcrypt-5.2.13p0 (ok)
Merging php5-gmp-5.2.6->php5-gmp-5.2.13p0 (ok)
Can't install php5-gd-5.2.13p0 because of libraries
|library X11.13.0 not found
| /usr/X11R6/lib/libX11.so.11.1 (system): bad major
|library freetype.17.1 not found
| /usr/X11R6/lib/libfreetype.so.16.1 (system): bad major
Direct dependencies for php5-core-5.2.6+php5-extensions-5.2.6+php5-gd-5.2.6+php5-gmp-5.2.6+php5-imap-5.2.6+php5-mbstring-5.2.6+php5-mcrypt-5.2.6+php5-mhash-5.2.6+php5-mysql-5.2.6->php5-core-5.2.13p0+php5-extensions-5.2.13p0+php5-gd-5.2.13p0+php5-gmp-5.2.13p0+php5-imap-5.2.13p0+php5-mbstring-5.2.13p0+php5-mcrypt-5.2.13p0+php5-mhash-5.2.13p0+php5-mysql-5.2.13p0 resolve to: libltdl-1.5.26p0 libxml-2.7.6 libiconv-1.13p1 php5-core-5.2.13p0 libmcrypt-2.5.8p1 c-client-2007ep0 png-1.2.44 mysql-client-5.1.48 t1lib-5.1.0p2 jpeg-8b mhash-0.9.9.9 gettext-0.18.1 gmp-4.3.1
Full dependency tree is libltdl-1.5.26p0 libxml-2.7.6 php5-core-5.2.13p0 libiconv-1.13p1 libmcrypt-2.5.8p1 c-client-2007ep0 png-1.2.44 mysql-client-5.1.48 jpeg-8b t1lib-5.1.0p2 mhash-0.9.9.9 gettext-0.18.1 gmp-4.3.1
Couldn't find updates for php5-mysql-5.2.6, php5-mbstring-5.2.6, php5-imap-5.2.6, php5-core-5.2.6, php5-gd-5.2.6, php5-mhash-5.2.6, php5-extensions-5.2.6, php5-mcrypt-5.2.6, php5-gmp-5.2.6
Updated to 4.8 via CD

Thanks
Reply With Quote
  #4   (View Single Post)  
Old 1st February 2011
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

What release did you upgrade from? only consecutive releases are supported.. 4.7->4.8 but not <= 4.6->4.8.

You should backup and reinstall cleanly.
Reply With Quote
  #5   (View Single Post)  
Old 1st February 2011
plexter plexter is offline
Shell Scout
 
Join Date: May 2008
Posts: 124
Thanked 0 Times in 0 Posts
Default

I started from 4.4 and updated to each consecutive release one by one following the upgrade page for each. I would prefer not to re: install the whole system.

Is there not a way to resolve this?
Reply With Quote
  #6   (View Single Post)  
Old 1st February 2011
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,891
Thanked 214 Times in 189 Posts
Default

You have a forward dependency problem.

The easiest way to fix this is to 1) get a list of your existing packages:
# pkg_info > /path/to/some/place/existing.package.list
2) delete all of your packages at once:
# pkg_delete /var/db/pkg/*
3) confirm you have no remaining older dependent library packages remaining, use pkg_delete /var/db/pkg/.lib* if any are still installed
# ls -a /var/db/pkg
4) review your package list, and install what you need, avoiding the use of version numbers, and ensuring you have $PKG_PATH set correctly.
# less /path/to/some/place/existing.package.list
# echo $PKG_PATH
# pkg_add <package1 package2 package3...>
Reply With Quote
  #7   (View Single Post)  
Old 1st February 2011
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,891
Thanked 214 Times in 189 Posts
Default

Just to be clear, you have this problem because you did not upgrade your packages from 4.4 to 4.8 step by step along with the system. But deleting and reinstalling packages will not take too long or be too difficult. Chose only the apps you use, let pkg_add find the dependencies for you.
Reply With Quote
  #8   (View Single Post)  
Old 1st February 2011
plexter plexter is offline
Shell Scout
 
Join Date: May 2008
Posts: 124
Thanked 0 Times in 0 Posts
Default

Hmm thanks for the info. Didn't occure to me that that not updating the packages each time would also cause issue. I have a system backup of the whole drive prior to upgrading. I believe it might be safest to try again?
Reply With Quote
  #9   (View Single Post)  
Old 1st February 2011
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,891
Thanked 214 Times in 189 Posts
Default

Entirely up to you, but I would think removing and reinstalling your packages would be easier and faster.
Reply With Quote
Old 2nd February 2011
plexter plexter is offline
Shell Scout
 
Join Date: May 2008
Posts: 124
Thanked 0 Times in 0 Posts
Default

Thanks again for your help. All seems to be working now. Least I'll know for next time that I gotta do the packages each version as well.

Thanks!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
shc unistd.h:239: error: syntax error before '&' token laraaj OpenBSD General 3 11th September 2010 07:21 AM
Anyone know if /gettext/ can be migrated to /gettext6/ gettext8/ etc? jb_daefo FreeBSD Ports and Packages 4 9th July 2008 11:24 AM
UPDATING says rebuild all gettext !! HowSoEver; READ yes REPLY maybe just wait jb_daefo FreeBSD Ports and Packages 4 8th June 2008 06:13 AM


All times are GMT. The time now is 06:16 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick