DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 6th March 2011
craze craze is offline
Port Guard
 
Join Date: Mar 2011
Posts: 12
Thanked 0 Times in 0 Posts
Red face three problems :)

Sorry for a lot of questions
Left I have three problems
I want to helping so I can study the system slowly step by step
1 - Problem How can I install unrar
i see
http://www.daemonforums.org/showthre...ighlight=unrar
and
http://openports.se/archivers/unrar
# pkg_add ftp://ftp.usa.openbsd.org/pub/OpenBS...c-4.0.2.tar.gz

Error from ftp://ftp.usa.openbsd.org/pub/OpenBS...0.2.tar.gz.tgz
550 unrarsrc-4.0.2.tar.gz.tgz: No such file or directory.
Can't find ftp://ftp.usa.openbsd.org/pub/OpenBS...c-4.0.2.tar.gz
--- unrarsrc-4.0.2.tar.gz -------------------
Can't install unrarsrc-4.0.2.tar.gz: not found
and
#pkg_add /home/craze/Downloads/unrarsrc-4.0.2.tar.gz

Can't find /home/craze/Downloads/unrarsrc-4.0.2.tar.gz
--- unrarsrc-4.0.2.tar.gz -------------------
Can't install unrarsrc-4.0.2.tar.gz: not found


2 - Problem How can I install Flash Player
3 - the problem of how can a graphics card "ATI" supported by the system? How do I view all hard ware
linux = lspci
unix = .....
Reply With Quote
  #2   (View Single Post)  
Old 6th March 2011
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,888
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by craze View Post
Wrong directory. The distfiles directory is used when building the port. The directory you should specify is explained in Section 15.2.2 of the FAQ.
Quote:
Problem How can I install Flash Player
In general, Flash support in OpenBSD is quite weak, however, you should read through Section 13.14 of the FAQ. Another alternative is to install the gnash package, however, this is not a perfect (or totally transparent...) solution. Yes, it is common knowledge that Flash support is nearly non-existent in OpenBSD.
Quote:
the problem of how can a graphics card "ATI" supported by the system? How do I view all hard ware
  • First, look at the output of dmesg(8).
  • There is also sysctl(8), but given the information presented, dmesg(8) output is what you want to focus upon.
In fact, if you want us to comment on ATI support, post the entire output of dmesg(8) here.
Reply With Quote
  #3   (View Single Post)  
Old 6th March 2011
craze craze is offline
Port Guard
 
Join Date: Mar 2011
Posts: 12
Thanked 0 Times in 0 Posts
Default

I will try install unrar + flash player and go youtube .!
output of dmesg
========
OpenBSD 4.8 (GENERIC.MP) #359: Mon Aug 16 09:16:26 MDT 2010
deraadt@i386.openbsd.org:/usr/src/sy...ile/GENERIC.MP
cpu0: Pentium(R) Dual-Core CPU E5200 @ 2.50GHz ("GenuineIntel" 686-class) 2.50 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,P GE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE, SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,EST,TM2,SSSE3,CX16,xTPR,PDCM
real mem = 3487719424 (3326MB)
avail mem = 3420692480 (3262MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 06/20/08, BIOS32 rev. 0 @ 0xfb9d0, SMBIOS rev. 2.5 @ 0xf0000 (50 entries)
bios0: vendor Dell Inc. version "1.0.15" date 06/20/2008
bios0: Dell Inc. Inspiron 530s
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP HPET MCFG SLIC DMY2 APIC SSDT
acpi0: wakeup devices PEX0(S5) PEX1(S5) PEX2(S5) PEX3(S5) PEX4(S5) PEX5(S5) HUB0(S5) IGBE(S5) USB0(S3) USB1(S3) USB2(S3) USB3(S3) USB4(S3) USB5(S3) EHC1(S3) EHC2(S3) AZAL(S5) PCI0(S5)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 14318179 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: apic clock running at 199MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Pentium(R) Dual-Core CPU E5200 @ 2.50GHz ("GenuineIntel" 686-class) 2.50 GHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,P GE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE, SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,EST,TM2,SSSE3,CX16,xTPR,PDCM
ioapic0 at mainbus0: apid 4 pa 0xfec00000, version 20, 24 pins
ioapic0: misconfigured as apic 0, remapped to apid 4
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PEX0)
acpiprt2 at acpi0: bus -1 (PEX1)
acpiprt3 at acpi0: bus -1 (PEX2)
acpiprt4 at acpi0: bus -1 (PEX3)
acpiprt5 at acpi0: bus -1 (PEX4)
acpiprt6 at acpi0: bus -1 (PEX5)
acpiprt7 at acpi0: bus 2 (HUB0)
acpicpu0 at acpi0: PSS
acpicpu1 at acpi0: PSS
acpitz0 at acpi0: critical temperature 120 degC
acpibtn0 at acpi0: PWRB
bios0: ROM list: 0xc0000/0x10000
cpu0: Enhanced SpeedStep 2494 MHz: speeds: 2500, 2000, 1600, 1200 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82G33 Host" rev 0x02
ppb0 at pci0 dev 1 function 0 "Intel 82G33 PCIE" rev 0x02: apic 4 int 16 (irq 5)
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "ATI Radeon HD 4350" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
radeondrm0 at vga1: apic 4 int 16 (irq 5)
drm0 at radeondrm0
azalia0 at pci1 dev 0 function 1 "ATI Radeon HD 4000 HD Audio" rev 0x00: apic 4 int 17 (irq 4)
azalia0: no supported codecs
azalia0: initialization failure, detaching
em0 at pci0 dev 25 function 0 "Intel ICH9 IFE" rev 0x02: apic 4 int 20 (irq 10), address 00:21:9b:23:a9:c0
uhci0 at pci0 dev 26 function 0 "Intel 82801I USB" rev 0x02: apic 4 int 16 (irq 5)
uhci1 at pci0 dev 26 function 1 "Intel 82801I USB" rev 0x02: apic 4 int 21 (irq 9)
uhci2 at pci0 dev 26 function 2 "Intel 82801I USB" rev 0x02: apic 4 int 19 (irq 10)
ehci0 at pci0 dev 26 function 7 "Intel 82801I USB" rev 0x02: apic 4 int 18 (irq 11)
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia1 at pci0 dev 27 function 0 "Intel 82801I HD Audio" rev 0x02: apic 4 int 22 (irq 3)
azalia1: codecs: Realtek ALC888
audio0 at azalia1
uhci3 at pci0 dev 29 function 0 "Intel 82801I USB" rev 0x02: apic 4 int 23 (irq 11)
uhci4 at pci0 dev 29 function 1 "Intel 82801I USB" rev 0x02: apic 4 int 19 (irq 11)
uhci5 at pci0 dev 29 function 2 "Intel 82801I USB" rev 0x02: apic 4 int 18 (irq 10)
ehci1 at pci0 dev 29 function 7 "Intel 82801I USB" rev 0x02: apic 4 int 23 (irq 11)
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb1 at pci0 dev 30 function 0 "Intel 82801BA Hub-to-PCI" rev 0x92
pci2 at ppb1 bus 2
vendor "Conexant", unknown product 0x2f20 (class communications subclass miscellaneous, rev 0x00) at pci2 dev 0 function 0 not configured
ichpcib0 at pci0 dev 31 function 0 "Intel 82801IR LPC" rev 0x02: PM disabled
pciide0 at pci0 dev 31 function 2 "Intel 82801I SATA" rev 0x02: DMA, channel 0 configured to native-PCI, channel 1 configured to native-PCI
pciide0: using apic 4 int 19 (irq 11) for native-PCI interrupt
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <TSSTcorp, DVD+-RW TS-H653F, D200> ATAPI 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 5
ichiic0 at pci0 dev 31 function 3 "Intel 82801I SMBus" rev 0x02: apic 4 int 18 (irq 11)
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 1GB DDR2 SDRAM non-parity PC2-6400CL5
spdmem1 at iic0 addr 0x51: 1GB DDR2 SDRAM non-parity PC2-6400CL5
spdmem2 at iic0 addr 0x52: 1GB DDR2 SDRAM non-parity PC2-6400CL5
spdmem3 at iic0 addr 0x53: 1GB DDR2 SDRAM non-parity PC2-6400CL5
pciide1 at pci0 dev 31 function 5 "Intel 82801I SATA" rev 0x02: DMA, channel 0 wired to native-PCI, channel 1 wired to native-PCI
pciide1: using apic 4 int 19 (irq 11) for native-PCI interrupt
wd0 at pciide1 channel 1 drive 0: <WDC WD5000AAKS-75A7B2>
wd0: 16-sector PIO, LBA48, 476940MB, 976773168 sectors
wd0(pciide1:1:0): using PIO mode 4, Ultra-DMA mode 6
usb2 at uhci0: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci1: USB revision 1.0
uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci2: USB revision 1.0
uhub4 at usb4 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb5 at uhci3: USB revision 1.0
uhub5 at usb5 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb6 at uhci4: USB revision 1.0
uhub6 at usb6 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb7 at uhci5: USB revision 1.0
uhub7 at usb7 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
it0 at isa0 port 0x2e/2: IT8718F rev 3, EC port 0x290
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
mtrr: Pentium Pro MTRR support
uhidev0 at uhub4 port 1 configuration 1 interface 0 "Dell Dell USB Optical Mouse" rev 2.00/43.01 addr 2
uhidev0: iclass 3/1
ums0 at uhidev0: 3 buttons, Z dir
wsmouse0 at ums0 mux 0
uhidev1 at uhub4 port 2 configuration 1 interface 0 "Dell Dell USB Keyboard" rev 1.10/3.52 addr 3
uhidev1: iclass 3/1
ukbd0 at uhidev1: 8 modifier keys, 6 key codes
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
softraid0 at root
root on wd0a swap on wd0b dump on wd0b
cd0(atapiscsi0:0:0): Check Condition (error 0x70) on opcode 0x0
SENSE KEY: Not Ready
ASC/ASCQ: Medium Not Present
cd0(atapiscsi0:0:0): Check Condition (error 0x70) on opcode 0x0
SENSE KEY: Not Ready
ASC/ASCQ: Medium Not Present
Reply With Quote
  #4   (View Single Post)  
Old 6th March 2011
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,888
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by craze View Post
I will try install unrar + flash player and go youtube .!
As I have said before, don't get your hopes up too high. Undeadly also discussed alternatives some time back:

http://undeadly.org/cgi?action=artic...20070907181228
Quote:
output of dmesg
Code:
... 
vga1 at pci1 dev 0 function 0 "ATI Radeon HD 4350" rev 0x00
...
It appears that your ATI video is detected fine. What is/was the issue?

Last edited by ocicat; 6th March 2011 at 11:18 AM.
Reply With Quote
  #5   (View Single Post)  
Old 6th March 2011
craze craze is offline
Port Guard
 
Join Date: Mar 2011
Posts: 12
Thanked 0 Times in 0 Posts
Default

thank you
not problem ATI You want to make sure
I have gone mad and is not installed unrar
Tried all the solutions
how install unrar ..!!!!
Reply With Quote
  #6   (View Single Post)  
Old 6th March 2011
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

The license for unrar prevents binary package distribution, you'll have to build the port manually.. this does NOT mean fetching the source distfile and manually building it in your home directory.

http://www.openbsd.org/faq/faq15.html#Ports

An alternative program, p7zip, supports a wide variety of formats.. however some newer RAR archives are incompatible.

There is no native Adobe Flash player for OpenBSD, if you wait for 4.9, some browsers now partially support playing YouTube videos using the HTML5 support.. but it's always hit and miss in what codecs work, the midori browser in the tree supports HTML5/h264 I believe.. WebM probably doesn't work in 4.8.

It might be a good idea to just use one of the many methods of downloading if such distractions are important to you.. however now would be a good time to ween yourself off of them, they're pointless.

As for ATI graphics, OpenBSD's ATI driver is still slightly old.. due to some developers depending on a feature that was deprecated/broken upstream.

For the HD 4350, there may have been patches added to 4.9 so that XVideo/2D acceleration will work.. pretty much all the driver will be capable of is modesetting and slightly more tolerable performance than the VESA VBE driver.

Good luck.. read the FAQ, etc.
Reply With Quote
  #7   (View Single Post)  
Old 6th March 2011
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,888
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by craze View Post
how install unrar ..!!!!
BSDfan666 beat me in responding. Per the OpenPorts entry:

http://openports.se/archivers/unrar
Quote:
The unRAR utility is a freeware program, distributed with source code...
As stated, licensing prevents distribution of a binary, so you will need to:
  1. Study Section 15.3 of the FAQ.
  2. Download the ports tree as described in Section 15.3.2. Be sure to download the version of the ports tree precisely described in this section. Mixing different versions is not supported.
  3. Section 15.3.5 describes how to build. Unrar can be found in /usr/ports/archivers/unrar.
Good luck.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GDM Problems Saint OpenBSD Packages and Ports 4 29th August 2010 09:42 AM
Problems with my new DNS server sniper007 General software and network 21 10th December 2009 04:31 PM
xpidl.c problems Mr-Biscuit FreeBSD General 1 7th October 2008 09:33 PM
Shutdown problems radtek FreeBSD General 11 13th September 2008 12:42 AM
ATI DRI problems harisman FreeBSD General 16 11th May 2008 05:12 PM


All times are GMT. The time now is 02:42 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick