DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 20th March 2011
godfrank godfrank is offline
Port Guard
 
Join Date: Jun 2008
Posts: 14
Thanked 0 Times in 0 Posts
Default ZFS filenames encoding misrepresentation with non-ASCII characters

Hello!
It seems like it is a relatively common problem but I couldn't manage to find an explanation or fix online.

I copied data from UFS to ZFS and at least one folder containing characters out of the ASCII table, such as "ö", is now set to "??".

Is there a way to force Unicode on ZFS? What can I do to keep filename encoding integrity?

Thanks!
Frank
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
.plan file, add picture ascii Simon OpenBSD General 5 29th April 2010 04:53 PM
Non US-ASCII characters on console under ksh or bash quique OpenBSD General 1 6th February 2010 03:36 AM
Programming QL-500 (ASCII Code) PetitConcept FreeBSD General 1 29th June 2009 10:08 PM
Encoding issue with GNU Screen TerryP General software and network 3 28th December 2008 07:04 AM
Changing encoding of text in MySQL database stukov Programming 5 15th July 2008 09:48 PM


All times are GMT. The time now is 02:03 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick