DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD General

NetBSD General Other questions regarding NetBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 5th April 2011
nihonto nihonto is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 65
Thanked 1 Time in 1 Post
Default Ugly fonts in Opera

Hi there,

I like the Opera browser, so I installed the binary package of Opera and set up the linux emulation.

But actually, there are still very ugly fonts in Opera. Is there any workaround to solve this problem?
Reply With Quote
  #2   (View Single Post)  
Old 5th April 2011
vermaden's Avatar
vermaden vermaden is offline
Administrator
 
Join Date: Apr 2008
Location: pl_PL.lodz
Posts: 1,052
Thanked 118 Times in 93 Posts
Default

Exacly which version of Opera?
__________________
religions, worst damnation of mankind
"If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds

Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”.
vermaden's: links resources deviantart spreadbsd
Reply With Quote
  #3   (View Single Post)  
Old 5th April 2011
nihonto nihonto is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 65
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by vermaden View Post
Exacly which version of Opera?
Quote:
pkg_info | grep opera
opera-9.64 Small, fast and customizable WWW client
... from pkgsrc-2010Q4

Ok?
Reply With Quote
  #4   (View Single Post)  
Old 5th April 2011
classicmanpro's Avatar
classicmanpro classicmanpro is offline
Real Name: Turea Alexandru Teodor
Fdisk Soldier
 
Join Date: Oct 2010
Location: Romania (SE Europe)
Posts: 49
Thanked 1 Time in 1 Post
Post

I don't use Opera but, as far as I know, all browsers allow the user to change the fonts, thus, one way might be to install/copy your favorite fonts in $HOME/.fonts then run FC-CACHE(1).

PS: Before you try to change the fonts, you should install Opera's favorite/default fonts, I think (in your case) it's using the next best thing, a fail-safe font.
__________________
A daemon in need is a daemon indeed.

Last edited by classicmanpro; 5th April 2011 at 08:25 PM. Reason: Extend the reply with a suggestion
Reply With Quote
  #5   (View Single Post)  
Old 5th April 2011
vermaden's Avatar
vermaden vermaden is offline
Administrator
 
Join Date: Apr 2008
Location: pl_PL.lodz
Posts: 1,052
Thanked 118 Times in 93 Posts
Default

@nihonto

I remember that Opera 9.x fonts looked flawlessly (after proper ~/.fonts.conf tweak), Opera 10.x has had TERRIBLE fonts rendering and now with Opera 11.x font rendering is OK again, here is my ~/.fonts.conf if You wish: http://strony.toya.net.pl/~vermaden/text/dot.fonts.conf
__________________
religions, worst damnation of mankind
"If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds

Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”.
vermaden's: links resources deviantart spreadbsd
Reply With Quote
  #6   (View Single Post)  
Old 5th April 2011
classicmanpro's Avatar
classicmanpro classicmanpro is offline
Real Name: Turea Alexandru Teodor
Fdisk Soldier
 
Join Date: Oct 2010
Location: Romania (SE Europe)
Posts: 49
Thanked 1 Time in 1 Post
Thumbs up

@vermaden: I'm speechless, what a great way to change the defaults.
__________________
A daemon in need is a daemon indeed.
Reply With Quote
  #7   (View Single Post)  
Old 6th April 2011
jb_daefo jb_daefo is offline
Package Pilot
 
Join Date: May 2008
Posts: 196
Thanked 5 Times in 5 Posts
Default

Seconded; readability appears dramatically heightened.
Reply With Quote
  #8   (View Single Post)  
Old 6th April 2011
vermaden's Avatar
vermaden vermaden is offline
Administrator
 
Join Date: Apr 2008
Location: pl_PL.lodz
Posts: 1,052
Thanked 118 Times in 93 Posts
Default

Welcome
__________________
religions, worst damnation of mankind
"If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds

Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”.
vermaden's: links resources deviantart spreadbsd
Reply With Quote
  #9   (View Single Post)  
Old 6th April 2011
nihonto nihonto is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 65
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by vermaden View Post
@nihonto

I remember that Opera 9.x fonts looked flawlessly (after proper ~/.fonts.conf tweak), Opera 10.x has had TERRIBLE fonts rendering and now with Opera 11.x font rendering is OK again, here is my ~/.fonts.conf if You wish: http://strony.toya.net.pl/~vermaden/text/dot.fonts.conf
Thx man! But - how do I have to apply this to my system?

I have copied your file as ".fonts.conf" to my /home/<user>-directory and then run "fc-cache -v". But that didn't change anything.
Reply With Quote
Old 6th April 2011
vermaden's Avatar
vermaden vermaden is offline
Administrator
 
Join Date: Apr 2008
Location: pl_PL.lodz
Posts: 1,052
Thanked 118 Times in 93 Posts
Default

@nihonto

Try fc-cache -r -v mate.
__________________
religions, worst damnation of mankind
"If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds

Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”.
vermaden's: links resources deviantart spreadbsd
Reply With Quote
Old 6th April 2011
nihonto nihonto is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 65
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by vermaden View Post
@nihonto

Try fc-cache -r -v mate.
Sorry, again - nothing changes

Edit: By the way - some sites look good in Opera (for example this german BSD-Forum: bsdforen.de), others - like daemonforums.org or heise.de - look somewhat unsexy ...

And another funny thing: While I can use the german "umlauts" in the gnome-terminal (although I never need to) and in Firefox, I can not use them in Opera

Last edited by nihonto; 6th April 2011 at 04:26 PM.
Reply With Quote
Old 6th April 2011
nihonto nihonto is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 65
Thanked 1 Time in 1 Post
Default

Maybe this is of some use: When I start opera from the command-line, I get back this information:

Quote:
operapluginwrapper:1162): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.

(operapluginwrapper:1162): Gdk-WARNING **: Error converting from UTF-8 to STRING: Conversion from character set 'UTF-8' to 'ISO-8859-1' is not supported
Reply With Quote
Old 6th April 2011
vermaden's Avatar
vermaden vermaden is offline
Administrator
 
Join Date: Apr 2008
Location: pl_PL.lodz
Posts: 1,052
Thanked 118 Times in 93 Posts
Default

Here's how they look on my box:
http://ompldr.org/vODU3cw
http://ompldr.org/vODU3dA
http://ompldr.org/vODU3dg

Have You tried to restart whole x11?
__________________
religions, worst damnation of mankind
"If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds

Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”.
vermaden's: links resources deviantart spreadbsd
Reply With Quote
Old 6th April 2011
nihonto nihonto is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 65
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by vermaden View Post
Here's how they look on my box:
http://ompldr.org/vODU3cw
http://ompldr.org/vODU3dA
http://ompldr.org/vODU3dg

Have You tried to restart whole x11?
I even restartet the computer. Yours look perfect! In the attachment, you can see how it looks on my system.
Attached Images
File Type: png daemonforums.png (35.3 KB, 62 views)
File Type: png heise.png (166.3 KB, 38 views)
Reply With Quote
Old 6th April 2011
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

The issue is antialiasing, or the lack of it.. you can fix this using a .fonts.conf or by setting Xft.antialias: true in your .Xdefaults/.Xresources file.

Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
	<match target="font">
		<edit mode="assign" name="antialias">
			<bool>true</bool>
		</edit>
	</match>
</fontconfig>
Good luck.
Reply With Quote
Old 6th April 2011
nihonto nihonto is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 65
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by BSDfan666 View Post
The issue is antialiasing, or the lack of it.
Jepp, you're right!

Quote:
Originally Posted by BSDfan666 View Post
you can fix this using a .fonts.conf or by setting Xft.antialias: true in your .Xdefaults/.Xresources file.

Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
	<match target="font">
		<edit mode="assign" name="antialias">
			<bool>true</bool>
		</edit>
	</match>
</fontconfig>
Hmmm, the .fonts.conf Vermaden proposed contains these lines:

Quote:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">

<fontconfig>

<!-- antialias all fonts -->
<match target="font">
<edit name="antialias" mode="assign"><bool>true</bool></edit>
<edit name="hinting" mode="assign"><bool>false</bool></edit>
<edit name="hintstyle" mode="assign"><int>0</int></edit>
<edit name="dpi" mode="assign"><double>75</double></edit>
<edit name="rgba" mode="assign"><const>none</const> </edit>
</match>
I thought that should solve the problem ...

Quote:
Originally Posted by BSDfan666 View Post
Good luck.
THX
Reply With Quote
Old 6th April 2011
nihonto nihonto is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 65
Thanked 1 Time in 1 Post
Default

Pffff, now I have tried the .Xdefaults solution BSDfan666 has proposed. But it doesn't work. I have even tried the solution proposed in this forum-thread I found on the web:

Quote:
1- Remove (or rename) your ~/fonts.conf
2- create an ~/.Xdefaults and add the following:

Xft.antialias: 1
Xft.autohint: 1
Xft.hinting: 1
Xft.hintstyle: hintslight
Xft.rgba: rgb

Save and restart Xorg.
It doesn't work, either.

The most awkward thing about it is - I suggest the problem is sitting in front of my laptop ...
Reply With Quote
Old 6th April 2011
classicmanpro's Avatar
classicmanpro classicmanpro is offline
Real Name: Turea Alexandru Teodor
Fdisk Soldier
 
Join Date: Oct 2010
Location: Romania (SE Europe)
Posts: 49
Thanked 1 Time in 1 Post
Post

Try a different gtk2-engine and use gtk2-chtheme or gtk2-theme-switch to apply them.

PS: Xfce has its own tools for setting the themes.
__________________
A daemon in need is a daemon indeed.
Reply With Quote
Old 6th April 2011
nihonto nihonto is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 65
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by classicmanpro View Post
Try a different gtk2-engine and use gtk2-chtheme or gtk2-theme-switch to apply them.

PS: Xfce has its own tools for setting the themes.
A different GTK-theme should solve my problem? Hmmm, does it have any influence on the fonts of a webpage?
Reply With Quote
Old 6th April 2011
classicmanpro's Avatar
classicmanpro classicmanpro is offline
Real Name: Turea Alexandru Teodor
Fdisk Soldier
 
Join Date: Oct 2010
Location: Romania (SE Europe)
Posts: 49
Thanked 1 Time in 1 Post
Default

I don't know if this helps but in my .fonts.conf file I have:

Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
	<dir>~/.fonts</dir>
</fontconfig>
PS: In my previous reply I assumed that everything is GTK2-based. For QT-based applications try some QT engines.
__________________
A daemon in need is a daemon indeed.

Last edited by classicmanpro; 6th April 2011 at 09:07 PM. Reason: Full example
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Have nice fonts in OpenBSD 4.6 mfaridi OpenBSD General 10 11th April 2010 01:38 PM
Console Fonts JMJ_coder General software and network 6 10th September 2008 09:57 PM
ImageMagick 6.3.6.10 on OpenBSD 4.3 ... ghostscript and fonts... superslot OpenBSD Packages and Ports 9 28th July 2008 09:36 AM
NetBSD: pretty fonts anomie NetBSD General 3 21st May 2008 03:00 PM
Want to get rid of ugly color of rox rex FreeBSD General 6 12th May 2008 12:02 AM


All times are GMT. The time now is 02:58 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick