DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 24th May 2011
RJPugh RJPugh is offline
Port Guard
 
Join Date: Jun 2008
Location: Culpeper, VA
Posts: 42
Thanked 0 Times in 0 Posts
Default Fuse mounting question

Hello again. I'm still sorting out various mounting issues with my FreeBSD 8.2 setup. My latest issue with with /dev/fuse.

I have three non-BSD partitions within my computer, all of them are NTFS (Windows XP). I can mount them using Dolphin. After they are mounted, they appear like this in df:

Code:
/dev/fuse0          54420152 37130452  17289700    68%    /media/WinXP
/dev/fuse1          76895088 22842292  54052796    30%    /media/filz
/dev/fuse2          76895088 22842292  54052796    30%    /media/filz-1
/dev/fuse3          78146708 40807612  37339096    52%    /media/vee
The duplication of /filz is because I accidentally tripple-clicked. That doesn't normally happen. My bad.

Anyway, those partitions also have labels in /dev, with names like ad0s1. I attempted to mount the WinXP partition by mounting /dev/ad0s1 to a prepared mount point, but it failed. In fact, the only place I can mount these partitions is in the /media directory, according to the whim of fuse.

Simply put, I would rather mount these partitions the old-fashioned way, with either a mount command or the fstab. I do not want to be restricted to fuse. Furthermore, fuse only appears to work in conjunction with Dolphin, and I generally prefer to use a lighter-weight file cruncher like xfe or Midnight Commander. Dolphin is effective and nice looking, but personally I prefer a simpler display.

Can anyone give me any pointers on how to, essentially, bypass or override fuse?

As I've said elsewhere, and if it matters, my computer is running PC-BSD 8.2, which is essentially FreeBSD 8.2 with some added bells and whistles. And I'm beginning to find some of those bells and whistles annoying...

Thanks in advance,

RJPugh
Reply With Quote
  #2   (View Single Post)  
Old 24th May 2011
vermaden's Avatar
vermaden vermaden is offline
Administrator
 
Join Date: Apr 2008
Location: pl_PL.lodz
Posts: 1,052
Thanked 118 Times in 93 Posts
Default

This should work: # ntfs-3g /dev/ad0s1 /mnt
__________________
religions, worst damnation of mankind
"If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds

Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”.
vermaden's: links resources deviantart spreadbsd
Reply With Quote
  #3   (View Single Post)  
Old 24th May 2011
nilsgecko's Avatar
nilsgecko nilsgecko is offline
Port Guard
 
Join Date: Apr 2011
Location: Chicago, USA
Posts: 45
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by RJPugh View Post
And I'm beginning to find some of those bells and whistles annoying...
I'm with you!!
Reply With Quote
  #4   (View Single Post)  
Old 24th May 2011
sharris sharris is offline
Package Pilot
 
Join Date: Jun 2010
Posts: 146
Thanked 0 Times in 0 Posts
Default

I just installed virtualbox-4.0.6-amd64.pbi and I'm now running Vista, Windows-7 (32) and (64). Is your mounting method about doing the same thing but in a more manual way?

Nothing is perfect, but PcBSD is darn close compared to the rest. I don't like Explorer (KDE). I simply PBI a GNOME install and PcBSD do the rest. No tutor tells you about the 5000 GNOME dependency and to install xWINDOWS anymore. It makes me feel it's All-In-One until I get stuipt enough to try again behind those words .. And I did twice back when it was really hard

http://www.cyberciti.biz/tips/howdo-...op-system.html

It would be nice to find information on how to turn something off, but not many are saying or even know. Anyway, I think these are the best place to start ... From another BSD install, I did it so I can log-in as root to get some things dones in PcBSD. Go to around line (200).

ee /usr/local/kde4/share/config/kdm/kdmrc

/etc/rc.conf

... than work with the boot loader.conf I guest. KDE is pretty but real men use GNONE!
Reply With Quote
  #5   (View Single Post)  
Old 24th May 2011
RJPugh RJPugh is offline
Port Guard
 
Join Date: Jun 2008
Location: Culpeper, VA
Posts: 42
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by vermaden View Post
This should work: # ntfs-3g /dev/ad0s1 /mnt
Thanks, Vermaden. I'll try this command when I get home.

To Nilsgecko and Sharris:
PC-BSD is far from perfect, but my collective experience with it has been good. When I first installed it, my experience with BSD was minimal, but PC-BSD allowed me to get a BSD system up and running quickly, and it took most of the guesswork out of instillation. With a system that has a lot of mixed components (like mine), that can be a very big deal. Once the system was running, I was then able to examine the FreeBSD system at my own pace, and customize it as I choose. One of FreeBSD's biggest selling points is the ability to extensively customize it. In PC-BSD, you can still do that, but I suspect it takes a little longer because you have to bypass the added value stuff before you can access the guts of the system. But once you're there, FreeBSD's array of options are easily available. Furthermore, should you ever need to use some of the fancy-schmancy tools that come with PC-BSD, like the PBI framework, they are still available when you need them. It's a real win/win.

My own system started out as a shake-the-box PC-BSD 8.2 system, complete with KDE 4.2.1. (Yuch!) Now, it's running all kinds of software from the ports tree, and I generally use one of the "classic" x-window managers, Window Maker. This fuse business is just the latest alteration I've attempted. If someone from the PC-BSD team were to look at my system, they may not recognize it as running their product.


If the aim of PC-BSD is to get more people to try and use FreeBSD, then I think it's working. It worked on me.

I like my little red daemon.
Reply With Quote
  #6   (View Single Post)  
Old 25th May 2011
RJPugh RJPugh is offline
Port Guard
 
Join Date: Jun 2008
Location: Culpeper, VA
Posts: 42
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by vermaden View Post
This should work: # ntfs-3g /dev/ad0s1 /mnt
I tried this, and unfortunately, it doesn't work. The result I get is:

Code:
ntfs-3g /dev/ad0s1 /mnt
fuse: failed to open fuse device: No such file or directory
This happens as both a user and as root. Apparently, fuse is not going to relinquish control of those hard drives! Which is precisely what I want.

I'm going to go looking for documentation on how to disable fuse, but in the mean time, I'm open to more suggestions.

RJPugh
Reply With Quote
  #7   (View Single Post)  
Old 25th May 2011
RJPugh RJPugh is offline
Port Guard
 
Join Date: Jun 2008
Location: Culpeper, VA
Posts: 42
Thanked 0 Times in 0 Posts
Default

Further information:

It occurred to me that I may be using the ntfs-3g command the wrong way. Should I be using it as part of a script? If it's designed to be a script command, well, that would explain a lot of things.

Please understand that I'm learning FreeBSD as I go; if my questions seem boneheaded, it's due to lack of experience. I'm trying. Honest.

I'm thinking of trying this rc script:

Code:
#!/bin/sh

# PROVIDE: mountall
	 
. /etc/rc.subr
	 
name="mountall"
rcvar=`set_rcvar`
start_cmd="mountall_start"
stop_cmd=":"
	 
load_rc_config $name
	 
mountall_start()
{
    if checkyesno ${rcvar}; then
	ntfs-3g /dev/ad0s1 /usr/home/rjp/xwp
	ntfs-3g /dev/ad3s1 /usr/home/rjp/filz
	ntfs-3g /dev/ad3s2 /usr/home/rjp/vee
    fi
}
	 
run_rc_command "$1"
I found a script template, and ran with it. This is new to me, so I only half know what I'm doing. For all I know, I may still be going about this the wrong way.

One thing I have done is enable fusefs in rc.conf. I saw a notice of this in the startup scroll, but I still can't mount the internal partitions. Still, I like to think I'm a step closer. I suspect that since fusefs wasn't enabled in rc.conf, it was somehow tied to the Dolphin file manager. If that's the case, then I'll have to make sure that fuse is running separately from Dolphin at all times. Does Dolphin have configuration scripts of it's own? If so, then I'll be paying them a visit. Baby steps...

Thanks in advance,

RJPugh
(recovering newbie)
Reply With Quote
  #8   (View Single Post)  
Old 26th May 2011
vermaden's Avatar
vermaden vermaden is offline
Administrator
 
Join Date: Apr 2008
Location: pl_PL.lodz
Posts: 1,052
Thanked 118 Times in 93 Posts
Default

Quote:
Originally Posted by RJPugh View Post
I tried this, and unfortunately, it doesn't work. The result I get is:

Code:
ntfs-3g /dev/ad0s1 /mnt
fuse: failed to open fuse device: No such file or directory
Do You have fusefs_enable=YES in /etc/rc.conf file?

Code:
% grep fuse /etc/rc.conf
fusefs_enable=YES
__________________
religions, worst damnation of mankind
"If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds

Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”.
vermaden's: links resources deviantart spreadbsd
Reply With Quote
  #9   (View Single Post)  
Old 27th May 2011
RJPugh RJPugh is offline
Port Guard
 
Join Date: Jun 2008
Location: Culpeper, VA
Posts: 42
Thanked 0 Times in 0 Posts
Default

Here's the output, from not 45 seconds ago:

Code:
[rjp@saturn3] ~> grep fuse /etc/rc.conf
# Enable fuse
fusefs_enable="YES"

[rjp@saturn3] ~> ntfs-3g /dev/ad0s1 /usr/home/rjp/wxp
mount_fusefs: /dev/fuse0 on /usr/home/rjp/wxp: Operation not permitted
fuse: failed to mount file system: No such file or directory

[rjp@saturn3] ~>
I must be missing something painfully obvious.

RJPugh
Reply With Quote
Old 22nd November 2011
teig teig is offline
Port Guard
 
Join Date: May 2008
Posts: 20
Thanked 0 Times in 0 Posts
Default

Just upgraded to 9.0 RC2 and get the same error!

I was on 8.2 and not a current set of ports, where it worked fine.
sshfs also worked fine before, now the same error.

The plain read-only ntfs works, but sucks at setting proper file permissions.
Reply With Quote
Old 22nd November 2011
roddierod's Avatar
roddierod roddierod is offline
Real Name: Rod Person
VPN Cryptographer
 
Join Date: Apr 2008
Location: Pittsburgh, Pa
Posts: 382
Thanked 13 Times in 13 Posts
Default

To use the ntfs-3g command, you need to make sure that the fuse kernel module is loading.

Try the command kldstat, you should get an output similar to this:
Code:
# kldstat
Id Refs Address    Size     Name
 1   24 0xc0400000 754a80   kernel
 2    1 0xc0b5c000 ad95b8   nvidia.ko
 3    1 0xc1636000 33c1c    vboxdrv.ko
 4    1 0xc6d10000 8000     linprocfs.ko
 5    1 0xc6d19000 28000    linux.ko
 6    1 0xcdc85000 e000     fuse.ko
If you do not see the fuse.ko then issue the command
Code:
kldload fuse
And try and mount again.
__________________
"The basic tool for the manipulation of reality is the manipulation of words. If you can control the meaning of words, you can control the people who must use the words." -Philip K. Dick
Reply With Quote
Old 22nd November 2011
teig teig is offline
Port Guard
 
Join Date: May 2008
Posts: 20
Thanked 0 Times in 0 Posts
Default

RJPugh, have you set sysctl vfs.usermount=1?

Yes, I have fuse.ko loaded, just unloaded and restarted fusefs.

The message I get is slightly different:
Quote:
# ntfs-3g /dev/da0s1 /mnt/hd
mount_fusefs: /dev/fuse0 on /mnt/hd: Invalid argument
fuse: failed to mount file system: No such file or directory
This accesses the device (lamp is blinking) before giving the message.

And I do have /dev/fuse0
Quote:
# ll /dev/fuse0
crw-rw---- 1 root operator 0, 136 22 nov 15:38 /dev/fuse0
Doing: mount -t ntfs /dev/da0s1 /mnt/hd is working.
Reply With Quote
Old 22nd November 2011
roddierod's Avatar
roddierod roddierod is offline
Real Name: Rod Person
VPN Cryptographer
 
Join Date: Apr 2008
Location: Pittsburgh, Pa
Posts: 382
Thanked 13 Times in 13 Posts
Default

I have no /dev/fuse devices and ntfs-3g works fine for me.

Have you tried
Code:
ntfs-3g /dev/da0 /mnt/hd
__________________
"The basic tool for the manipulation of reality is the manipulation of words. If you can control the meaning of words, you can control the people who must use the words." -Philip K. Dick
Reply With Quote
Old 22nd November 2011
teig teig is offline
Port Guard
 
Join Date: May 2008
Posts: 20
Thanked 0 Times in 0 Posts
Default

No, it gives 'NTFS signature is missing.'

Removed /dev/fuse0, but then it complains: can't open fuse device.
Oddly, restarting fusefs doesn't bring back the device!
Reply With Quote
Old 22nd November 2011
roddierod's Avatar
roddierod roddierod is offline
Real Name: Rod Person
VPN Cryptographer
 
Join Date: Apr 2008
Location: Pittsburgh, Pa
Posts: 382
Thanked 13 Times in 13 Posts
Default

Just noticed your using PC-BSD, although "essentially" it is FreeBSD, I believe they do modify somethings. I'm not sure where you got the /dev/fuse devices as I have not seen these and being that it worked in one directory and not another leads me to believe it to be something modified by PC-BSD.

But, I have none of that and I'm using just freebsd and fuse for some years now and it works fine.
__________________
"The basic tool for the manipulation of reality is the manipulation of words. If you can control the meaning of words, you can control the people who must use the words." -Philip K. Dick
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange fdisk and mounting question RJPugh FreeBSD General 11 3rd March 2011 02:25 PM
external drive partition question + fdisk question gosha OpenBSD General 15 15th June 2009 02:00 PM
smb mounting question zerhacke FreeBSD General 5 3rd January 2009 01:47 AM
Mounting sniper007 FreeBSD General 7 2nd July 2008 06:50 AM
mounting UFS hirohitosan Other BSD and UNIX/UNIX-like 2 27th June 2008 02:40 PM


All times are GMT. The time now is 06:54 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick