DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 17th August 2011
map7 map7 is offline
Fdisk Soldier
 
Join Date: Jun 2008
Posts: 75
Thanked 3 Times in 3 Posts
Default Installing Musicpd issue

I'm trying to install musicpd through the ports system on a FreeBSD 7.0 machine. I've done a portsnap fetch update.

When I try to make the musicpd port I get this error:

Code:
r/local/lib -lFLAC -lm   -logg -L/usr/local/lib -lvorbisenc -lvorbis -lm -logg   -lwrap         -pthread -L/usr/local/lib -lgthread-2.0 -lglib-2.0 -liconv   
/usr/bin/ld: warning: libx264.so.50, needed by /usr/local/lib/libavcodec.so, not found (try using -rpath or -rpath-link)
/usr/local/lib/libavcodec.so: undefined reference to `x264_encoder_close'
/usr/local/lib/libavcodec.so: undefined reference to `x264_param_default'
/usr/local/lib/libavcodec.so: undefined reference to `x264_encoder_headers'
/usr/local/lib/libavcodec.so: undefined reference to `x264_nal_encode'
/usr/local/lib/libavcodec.so: undefined reference to `x264_encoder_open'
/usr/local/lib/libavcodec.so: undefined reference to `x264_encoder_encode'
gmake[1]: *** [src/mpd] Error 1
gmake[1]: Leaving directory `/usr/ports/audio/musicpd/work/mpd-0.16.3'
gmake: *** [all] Error 2
*** Error code 1

Stop in /usr/ports/audio/musicpd.
*** Error code 1

Stop in /usr/ports/audio/musicpd.
Am I missing a dependency or something?
Reply With Quote
  #2   (View Single Post)  
Old 17th August 2011
jb_daefo jb_daefo is offline
Package Pilot
 
Join Date: May 2008
Posts: 197
Thanked 5 Times in 5 Posts
Default

musicpd >> fffmpeg >> x264. Not expert here, but maybe rebuild ffmpeg with or without x264, and/or try musicpd without ffmpeg selected... unsure which you may wish to do.
Code:
 ldd /usr/local/bin/ffmpeg
may show at least if that port is missing any dependency library or not.
__________________
using /LOOKAT/ with /var/db/pkg files and portmaster/aliases/pipes/find/grep to meteorically speedup port upgrades/installs...
Reply With Quote
  #3   (View Single Post)  
Old 17th August 2011
map7 map7 is offline
Fdisk Soldier
 
Join Date: Jun 2008
Posts: 75
Thanked 3 Times in 3 Posts
Default

Ok, so it's ffmpeg's fault this is not compiling

Here is my output of ldd:
# ldd /usr/local/bin/ffmpeg
/usr/local/bin/ffmpeg:
liba52.so.0 => /usr/local/lib/liba52.so.0 (0x2808e000)
libswscale.so.1 => /usr/local/lib/libswscale.so.1 (0x2809b000)
libavdevice.so.1 => /usr/local/lib/libavdevice.so.1 (0x280c2000)
libavformat.so.1 => /usr/local/lib/libavformat.so.1 (0x280c6000)
libavcodec.so.1 => /usr/local/lib/libavcodec.so.1 (0x28166000)
libavutil.so.1 => /usr/local/lib/libavutil.so.1 (0x28778000)
libm.so.5 => /lib/libm.so.5 (0x28787000)
libthr.so.3 => /lib/libthr.so.3 (0x2879c000)
libc.so.7 => /lib/libc.so.7 (0x287af000)
libz.so.4 => /lib/libz.so.4 (0x288ab000)
libbz2.so.3 => /usr/lib/libbz2.so.3 (0x288bd000)
libtheora.so.0 => /usr/local/lib/libtheora.so.0 (0x288cd000)
libvorbisenc.so.2 => /usr/local/lib/libvorbisenc.so.2 (0x28918000)
libvorbis.so.4 => /usr/local/lib/libvorbis.so.4 (0x28a11000)
libx264.so.50 => not found (0x0)
libogg.so.5 => /usr/local/lib/libogg.so.5 (0x28a39000)

If I compile musicpd without ffmpeg it compiles fine.

Now if I try and recompile ffmpeg I get this error:
Code:
e-2.8.4/Source   -I/usr/ports/devel/cmake/work/cmake-2.8.4/Bootstrap.cmk -DKWSYS_NAMESPACE=cmsys -c /usr/ports/devel/cmake/work/cmake-2.8.4/Source/kwsys/SystemTools.cxx -o SystemTools.o
In file included from /usr/include/c++/4.2/backward/strstream:51,
                 from /usr/ports/devel/cmake/work/cmake-2.8.4/Bootstrap.cmk/cmsys/ios/sstream:38,
                 from /usr/ports/devel/cmake/work/cmake-2.8.4/Source/kwsys/SystemTools.cxx:26:
/usr/include/c++/4.2/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header. Please consider using one of the 32 headers found in section 17.4.1.2 of the C++ standard. Examples include substituting the <X> header for the <X.h> header for C++ includes, or <iostream> instead of the deprecated header <iostream.h>. To disable this warning use -Wno-deprecated.
In file included from /usr/ports/devel/cmake/work/cmake-2.8.4/Source/kwsys/SystemTools.cxx:26:
/usr/ports/devel/cmake/work/cmake-2.8.4/Bootstrap.cmk/cmsys/ios/sstream: In member function 'void cmsys_ios::istringstream::clear(int)':
/usr/ports/devel/cmake/work/cmake-2.8.4/Bootstrap.cmk/cmsys/ios/sstream:176: error: invalid conversion from 'int' to 'std::_Ios_Iostate'
/usr/ports/devel/cmake/work/cmake-2.8.4/Bootstrap.cmk/cmsys/ios/sstream:176: error:   initializing argument 1 of 'void std::basic_ios<_CharT, _Traits>::clear(std::_Ios_Iostate) [with _CharT = char, _Traits = std::char_traits<char>]'
*** Error code 1

Stop in /usr/ports/devel/cmake/work/cmake-2.8.4/Bootstrap.cmk.
---------------------------------------------
Error when bootstrapping CMake:
Problem while running make
---------------------------------------------
Log of errors: /usr/ports/devel/cmake/work/cmake-2.8.4/Bootstrap.cmk/cmake_bootstrap.log
---------------------------------------------
===>  Script "configure" failed unexpectedly.
Please report the problem to kde@FreeBSD.org [maintainer] and attach the
"/usr/ports/devel/cmake/work/cmake-2.8.4/config.log" including the output of
the failure of your make command. Also, it might be a good idea to provide
an overview of all packages installed on your system (e.g. an `ls
/var/db/pkg`).
*** Error code 1

Stop in /usr/ports/devel/cmake.
*** Error code 1

Stop in /usr/ports/graphics/opencv-core.
*** Error code 1

Stop in /usr/ports/multimedia/ffmpeg.
*** Error code 1

Stop in /usr/ports/multimedia/ffmpeg.
Reply With Quote
  #4   (View Single Post)  
Old 17th August 2011
jb_daefo jb_daefo is offline
Package Pilot
 
Join Date: May 2008
Posts: 197
Thanked 5 Times in 5 Posts
Default

You may want to
Code:
 cd /usr/ports/multimedia/ffmpeg && make config
and deselect opencv-core, it is a new dependency sort of huge. And your post indicates that it is "cmake" and not ffmpeg which is failing to build... cmake being required for opencv-core. So by deselecting opencv in ffmpeg, maybe not requiring cmake (another issue for you to ignore? fix?) maybe ffmpeg rebuilding would fix musicpd ... OTOH I know absolutely nothing about opencv-core other than the fact that it requires cmake...
__________________
using /LOOKAT/ with /var/db/pkg files and portmaster/aliases/pipes/find/grep to meteorically speedup port upgrades/installs...
Reply With Quote
Reply

Tags
install, libx264.so.50, musicpd

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
VPN Nat issue on 4.8 copetts OpenBSD Security 2 12th April 2011 10:34 AM
sudo issue rpindy OpenBSD General 6 31st May 2010 04:12 PM
FTP issue in pf.conf Simon OpenBSD Security 0 29th April 2010 06:19 AM
Possible SMP Issue? MetalHead OpenBSD General 1 25th November 2008 03:52 AM
RAM issue nikkon FreeBSD General 5 7th May 2008 04:26 AM


All times are GMT. The time now is 10:44 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick