DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 28th May 2008
mfaridi's Avatar
mfaridi mfaridi is offline
Spam Deminer
 
Join Date: May 2008
Location: Afghanistan
Posts: 282
Thanked 5 Times in 5 Posts
Default VLC run error

I use OpenBSD 4.2 and I install VLC , it work good before , but today when I want run it I see this error

Code:
mostafa% vlc /home/mostafa/movie/T.avi 
VLC media player 0.8.6c Janus
vlc:/usr/local/lib/vlc/codec/libquicktime_plugin.so: undefined symbol 'NewHandleClear'
zsh: segmentation fault (core dumped)  vlc /home/mostafa/movie/T.avi
How I can fix this problem ?
Reply With Quote
  #2   (View Single Post)  
Old 28th May 2008
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,719
Thanked 214 Times in 189 Posts
Default

The Quicktime codec either couldn't handle your particular video stream, or, there is a problem with the codec or the plugin or VLC.

Try a different video player. If you get the same results, your file may be damaged.
Reply With Quote
  #3   (View Single Post)  
Old 28th May 2008
mfaridi's Avatar
mfaridi mfaridi is offline
Spam Deminer
 
Join Date: May 2008
Location: Afghanistan
Posts: 282
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by jggimi View Post
The Quicktime codec either couldn't handle your particular video stream, or, there is a problem with the codec or the plugin or VLC.

Try a different video player. If you get the same results, your file may be damaged.
I use mplayer and it work good , so file is not damage
I install VLC with pkg_add

how I install codec ??
Reply With Quote
  #4   (View Single Post)  
Old 28th May 2008
TerryP's Avatar
TerryP TerryP is offline
Arp Constable
 
Join Date: May 2008
Location: USofA
Posts: 1,547
Thanked 112 Times in 104 Posts
Default

Personalyl I would think that the VLC and QT plugin builds are some how miss matched.

bar: undefined symbol in 'beer'

generally doesn't meant he bar is out of beer, it means you asked for the wrong kind of brew so to speak.


I would also assume that your using 4.3-Release or the latest 4.3-Stable and packages built on your release level. Otherwise such an error does not surprise me.
__________________
My Journal

Thou shalt check the array bounds of all strings (indeed, all arrays), for surely where thou typest ``foo'' someone someday shall type ``supercalifragilisticexpialidocious''.
Reply With Quote
  #5   (View Single Post)  
Old 28th May 2008
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,719
Thanked 214 Times in 189 Posts
Default

mfaridi is running 4.2, and his release of VLC is in sync.
Reply With Quote
  #6   (View Single Post)  
Old 28th May 2008
TerryP's Avatar
TerryP TerryP is offline
Arp Constable
 
Join Date: May 2008
Location: USofA
Posts: 1,547
Thanked 112 Times in 104 Posts
Default

i never said i could read and omni-task at the same time perfectlu ops
__________________
My Journal

Thou shalt check the array bounds of all strings (indeed, all arrays), for surely where thou typest ``foo'' someone someday shall type ``supercalifragilisticexpialidocious''.
Reply With Quote
  #7   (View Single Post)  
Old 28th May 2008
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,719
Thanked 214 Times in 189 Posts
Default

I happened to go look at the Makefile for VLC. For the version of the Makefile for 4.2, it has, at line #104:
Code:
                --disable-quicktime \
This has been there since 3.8-release, when the port for VLC 0.8.2 was added to the tree.

It is still that way, even in the -current Makefile.
Quote:
...how I install codec ??...
It is not enabled in VLC for OpenBSD. I recommend you use mplayer for video encoded with the Quicktime codec.
Reply With Quote
  #8   (View Single Post)  
Old 28th May 2008
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

I use VLC and that message always appears, it's not related to the issue he is facing... perhaps it's a zsh issue, I use ksh and experience no problems.

That file is probably not a Quicktime video..

Clearly none of you are using OpenBSD+vlc, that message has been around least since 4.1.
Reply With Quote
  #9   (View Single Post)  
Old 28th May 2008
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,719
Thanked 214 Times in 189 Posts
Default

Well, mfaridi uses it.

I use mplayer unless I need dvd navigation, then I use ogle.
Reply With Quote
Old 28th May 2008
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

@mfaridi, type: % vlc -v /home/mostafa/movie/T.avi and see what it prints out, again, ignore the Quicktime information.

Also, paste the output of: % ffmpeg -i /home/mostafa/movie/T.avi to help us identify the audio/video codec in use.

Thanks.

EDIT: You're using OpenBSD 4.2? Why? If you insist.. there was an Xorg errata which fixed a crippling bug, VLC was one of those applications that flaked out.

Apply ftp://ftp.openbsd.org/pub/OpenBSD/pa...006_xorg.patch and recompile Xenocara.. (It might be easier to just upgrade to 4.3..).

Last edited by BSDfan666; 28th May 2008 at 06:18 PM.
Reply With Quote
Old 28th May 2008
TerryP's Avatar
TerryP TerryP is offline
Arp Constable
 
Join Date: May 2008
Location: USofA
Posts: 1,547
Thanked 112 Times in 104 Posts
Default

I've used OpenBSD since 3.9... but I've yet to give X a whirl.
__________________
My Journal

Thou shalt check the array bounds of all strings (indeed, all arrays), for surely where thou typest ``foo'' someone someday shall type ``supercalifragilisticexpialidocious''.
Reply With Quote
Old 28th May 2008
lvlamb's Avatar
lvlamb lvlamb is offline
Real Name: Louis V. Lambrecht
Spam Deminer
 
Join Date: May 2008
Location: .be
Posts: 221
Thanked 25 Times in 24 Posts
Default

There are Quicktime problems with several apps (I can mention xawtv).
Mostly, what happens, is that if you configure a source to use Quicktime when the maintainer did disable it, the app would crash. Both Free- and OpenBSD.
So, if the maintainer enables Quicktime, it should work.

Afaik, libquicktime is in the tree but needs qt, meaning you need KDE apps?
__________________
da more I know I know I know nuttin'
Reply With Quote
Old 29th May 2008
mfaridi's Avatar
mfaridi mfaridi is offline
Spam Deminer
 
Join Date: May 2008
Location: Afghanistan
Posts: 282
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by BSDfan666 View Post
@mfaridi, type: % vlc -v /home/mostafa/movie/T.avi and see what it prints out, again, ignore the Quicktime information.

Also, paste the output of: % ffmpeg -i /home/mostafa/movie/T.avi to help us identify the audio/video codec in use.

Thanks.

EDIT: You're using OpenBSD 4.2? Why? If you insist.. there was an Xorg errata which fixed a crippling bug, VLC was one of those applications that flaked out.

Apply ftp://ftp.openbsd.org/pub/OpenBSD/pa...006_xorg.patch and recompile Xenocara.. (It might be easier to just upgrade to 4.3..).
thanks when I type
Code:
vlc -v /home/mostafa/movie/The.avi
after sometimes I see this error and VLC can not play this movie

Code:
VLC media player 0.8.6c Janus
vlc:/usr/local/lib/vlc/codec/libquicktime_plugin.so: undefined symbol 'NewHandleClear'
[00000264] avi private warning: unknown chunk (not loaded)
zsh: segmentation fault (core dumped)  vlc -v /home/mostafa/movie/T.avi
and when I type this command

Code:
ffmpeg -i /home/mostafa/movie/The.avi
I see this message

Code:
FFmpeg version SVN-r8862, Copyright (c) 2000-2007 Fabrice Bellard, et al.
  configuration: --enable-shared --cc=cc --disable-opts --enable-liba52 --enable-pp --enable-gpl --enable-pthreads --disable-debug --enable-libfaac --enable-libfaad --enable-libmp3lame --enable-libogg --enable-libvorbis --enable-libtheora --enable-x264 --extra-libs=-L/usr/local/lib --extra-cflags=-I/usr/local/include
  libavutil version: 49.4.0
  libavcodec version: 51.40.4
  libavformat version: 51.12.1
  built on Aug 15 2007 20:46:19, gcc: 3.3.5 (propolice)
Input #0, avi, from '/home/mostafa/movie/T.avi':
  Duration: 01:40:06.9, start: 0.000000, bitrate: 977 kb/s
  Stream #0.0: Video: mpeg4, yuv420p, 640x352, 25.00 fps(r)
  Stream #0.1: Audio: mp3, 48000 Hz, stereo, 112 kb/s
Must supply at least one output file
Reply With Quote
Old 29th May 2008
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

Try:
% ffplay -bug -debug -fs /home/mostafa/movie/T.aviIf it still fails, consider upgrading to 4.3, it will be worth the effort..
Reply With Quote
Old 29th May 2008
mfaridi's Avatar
mfaridi mfaridi is offline
Spam Deminer
 
Join Date: May 2008
Location: Afghanistan
Posts: 282
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by BSDfan666 View Post
Try:
% ffplay -bug -debug -fs /home/mostafa/movie/T.aviIf it still fails, consider upgrading to 4.3, it will be worth the effort..
Thanks
your command work good and I can see this movie
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:02 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick