DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 21st February 2012
riotnrrd's Avatar
riotnrrd riotnrrd is offline
New User
 
Join Date: Feb 2010
Posts: 8
Thanked 0 Times in 0 Posts
Default Xorg problem

I have been running my FreeBSD box text-only for a while now, but I decided to try to get a graphical environment up for a change. However, it seems X config is just as annoying as it was a few years ago, the last time I had to go through it...

Hitting
Code:
startx
just sends my monitor to sleep, which looks like the sync is out of range. Fair enough, it's an older monitor (Samsung SyncMaster 913v, native res 1280x1024). The really annoying thing is that I can't seem to recover from this mode without rebooting. Switching consoles or killing X via SSH does not get me back to a text console to try again. Fortunately I can still access the box over the network when this happens to e.g. retrieve logs or do a clean reboot, but it's not getting me any closer to success.

Contents of Xorg.0.log:

Quote:
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 11, (OK)
drmOpenByBusid: drmOpenMinor returns 11
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
(II) [drm] loaded kernel module for "i915" driver.
(II) [drm] DRM interface version 1.2
(II) [drm] DRM open master succeeded.
(II) intel(0): [drm] Using the DRM lock SAREA also for drawables.
(II) intel(0): [drm] framebuffer mapped by ddx driver
(II) intel(0): [drm] added 1 reserved context for kernel
(II) intel(0): X context handle = 0x1
(II) intel(0): [drm] installed DRM signal handler
(**) intel(0): Framebuffer compression enabled
(**) intel(0): Tiling enabled
(==) intel(0): VideoRam: 262144 KB
(II) intel(0): Attempting memory allocation with tiled buffers.
(II) intel(0): Tiled allocation successful.
(II) intel(0): [drm] Registers = 0x00000000
(II) intel(0): [drm] ring buffer = 0x00000000
(II) intel(0): [drm] mapped front buffer at 0xd1000000, handle = 0x00000000
(II) intel(0): [drm] mapped back buffer at 0xd4000000, handle = 0x00000000
(II) intel(0): [drm] mapped depth buffer at 0xd5000000, handle = 0x00000000
(II) intel(0): [drm] mapped classic textures at 0xd6000000, handle = 0x00000000
(II) intel(0): [drm] Initialized kernel agp heap manager, 33554432
(II) intel(0): [dri] visual configs initialized
(II) intel(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
(==) intel(0): Write-combining range (0xa0000,0x10000) was already clear
(II) EXA(0): Offscreen pixmap area of 31457280 bytes
(II) EXA(0): Driver registered support for the following operations:
(II) Solid
(II) Copy
(II) Composite (RENDER acceleration)
(==) intel(0): Backing store disabled
(==) intel(0): Silken mouse enabled
(II) intel(0): Initializing HW Cursor
(II) intel(0): [DRI] installation complete
(WW) intel(0): drmDropMaster failed: Unknown error: -1
The X client is running because I can export to X servers on the network. My xorg.conf looks like this:

Quote:
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "DontZap" "off"
EndSection

Section "Files"
ModulePath "/usr/local/lib/xorg/modules"
FontPath "/usr/local/lib/X11/fonts/misc/"
FontPath "/usr/local/lib/X11/fonts/TTF/"
FontPath "/usr/local/lib/X11/fonts/OTF"
FontPath "/usr/local/lib/X11/fonts/Type1/"
FontPath "/usr/local/lib/X11/fonts/100dpi/"
FontPath "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
Load "dbe"
Load "dri"
Load "dri2"
Load "extmod"
Load "glx"
Load "record"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/sysmouse"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Samsung"
ModelName "SyncMaster913v"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "dpms"
Modeline "1280x1024@69" 140.00 1280 1312 1840 1872 1024 1044 1056 1076
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
Option "DRI" "true" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
#Option "PageFlip" # [<bool>]
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "N10 Family Integrated Graphics Controller"
BusID "PCI:0:2:0"
Option "ModeValidation" "NoDFPNativeResolutionCheck"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 4
Modes "1280x1024"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
Thanks in advance for any assistance!

Last edited by riotnrrd; 21st February 2012 at 04:31 PM. Reason: politeness
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FreeBSD 7.1 Ati Xpress 200M Xorg 7.4 problem raduenea FreeBSD Installation and Upgrading 11 1st July 2009 12:46 AM
Xorg + Xfce4 resolution problem sniper007 FreeBSD General 4 30th April 2009 04:38 PM
4.4 on macmini ppc xorg problem gosha OpenBSD Installation and Upgrading 27 14th February 2009 10:06 PM
Need to use full path to commands and xorg.config problem phreud FreeBSD General 4 17th November 2008 07:44 PM
Xorg very slow (problem with DRI?) Hihihi OpenBSD General 6 18th July 2008 06:21 PM


All times are GMT. The time now is 03:13 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick