DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 25th March 2012
marconi marconi is offline
Port Guard
 
Join Date: Mar 2012
Posts: 10
Thanked 0 Times in 0 Posts
Default ifconfig athn0

Two hours i trying to configure wireless interface without dhcp.

After adding two nameservers to /etc/resolv.conf i create /etc/mygate with ip address of router. With hostname.athn0 in etc nothing is happening.

Code:
ifconfig athn0 inet 192.168.0.2 netmask 255.255.255.0 nwid myssid wpa wpapsk 'password'
After this command network status is active, but when ping some ip i get the message "no route to host".

What I missed?
Reply With Quote
  #2   (View Single Post)  
Old 25th March 2012
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,686
Thanked 214 Times in 189 Posts
Default

With the information provided, the only thing I see in error is the use of "wpapsk". You should be using "wpakey" instead, if you are using OpenBSD 5.0 as you mentioned in your earlier thread. Please see the ifconfig(8) man page. WPA key configuration has been simplified in OpenBSD within the last two years; "wpapsk" has not been used since 4.8. If you have been directed to use "wpapsk" you are using outdated information.
Reply With Quote
  #3   (View Single Post)  
Old 25th March 2012
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,686
Thanked 214 Times in 189 Posts
Default

Here is a description of the change in WPA management from the OpenBSD Upgrade Guide for 4.9:
Quote:
WPA configuration changes:
wpa-psk(8) is no longer used because wpakey support is now built directly into ifconfig(8). Inspect your /etc/hostname.* files for wireless devices using WPA and replace:
nwid myssid wpapsk `wpa-psk myssid wpapassword`
with the simpler form:
nwid myssid wpakey wpapassword
Please avoid using third party "how to" documents you find on the Internet, if that was the source of your "wpapsk" directive. They are often not kept up to date, and are regularly found to be incomplete, misleading, or incorrect.
Reply With Quote
  #4   (View Single Post)  
Old 25th March 2012
marconi marconi is offline
Port Guard
 
Join Date: Mar 2012
Posts: 10
Thanked 0 Times in 0 Posts
Default

Yes, OpenBSD 5.0 is on machine. I found that description and enable dhcp on router, after that i test first command and command with wpakey and both commands work.
But without dhcp when try to ping someone message is "no route to host".

Quote:
Please avoid using third party "how to" documents you find on the Internet, if that was the source of your "wpapsk" directive. They are often not kept up to date, and are regularly found to be incomplete, misleading, or incorrect.
Thanks for this, i'm just started with OpenBSD.
Reply With Quote
  #5   (View Single Post)  
Old 25th March 2012
denta denta is offline
Fdisk Soldier
 
Join Date: Nov 2009
Posts: 73
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by marconi View Post
After adding two nameservers to /etc/resolv.conf i create /etc/mygate with ip address of router. With hostname.athn0 in etc nothing is happening.
Editing the hostname.if file is not enough. Run netstart aswell to setup default routes etc.
Code:
$ sudo sh /etc/netstart
If you have been doing that already, check your current routing table to see if the route is there.
Code:
$ route show -inet
If not, its probably a pf issue.
Reply With Quote
  #6   (View Single Post)  
Old 25th March 2012
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,686
Thanked 214 Times in 189 Posts
Default

Static configuration requires a default route, at minimum.

Create an /etc/mygate file, per FAQ 6.2.2 and the mygate(5) man page.
Reply With Quote
  #7   (View Single Post)  
Old 25th March 2012
marconi marconi is offline
Port Guard
 
Join Date: Mar 2012
Posts: 10
Thanked 0 Times in 0 Posts
Default

I found a mistake in /etc/hostname.if none -> NONE.

If someone needs the following command:
Code:
inet machineip netmask NONE nwid ssid wpakey 'password'
Thanks friends!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PF - ifconfig problem ripp3r OpenBSD Security 5 12th December 2010 04:10 PM
need some basic help on ifconfig daemon-dd FreeBSD General 4 29th July 2008 03:21 PM
FreeBSD's Ifconfig for WEP tz24 FreeBSD General 15 13th June 2008 02:17 AM
hard lock on ifconfig wi0 up reuteler OpenBSD General 11 25th May 2008 06:22 PM
ifconfig problem ichigo OpenBSD General 3 20th May 2008 10:59 PM


All times are GMT. The time now is 06:13 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick