DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 21st June 2012
sw2wolf sw2wolf is offline
λ programmer
 
Join Date: Mar 2012
Location: China
Posts: 89
Thanked 0 Times in 0 Posts
Default No sound on my FreeBSD box

Code:
$uname -a
FreeBSD mybsd.zsoft.com 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:15:25 UTC 2012     
root@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  i386

$mixer
Mixer vol      is currently set to  75:75
Mixer pcm      is currently set to  75:75
Mixer speaker  is currently set to  75:75
Mixer line     is currently set to  75:75
Mixer mic      is currently set to   0:0
Mixer cd       is currently set to  75:75
Mixer rec      is currently set to  75:75
Mixer igain    is currently set to   0:0
Mixer line1    is currently set to  75:75
Mixer phin     is currently set to   0:0

$pciconf -lv | grep -i audio
    device     = '82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller'
    subclass   = audio
    subclass   = audio

$dmesg | grep -i audio
pci1: <multimedia, audio> at device 0.0 (no driver attached)

$dmesg -a | grep -i pcm0
pcm0: <Intel ICH4 (82801DB)> port 0xe000-0xe0ff,0xe400-0xe43f mem 0xde081000-0xde0811ff,0xde082000-0xde0820ff irq 17 at device 31.5 on pci0
pcm0: <Avance Logic ALC101 AC97 Codec>

$cat /dev/sndstat 
FreeBSD Audio Driver (newpcm: 32bit 2009061500/i386)
Installed devices:
pcm0: <Intel ICH4 (82801DB)> (play/rec) default
It seems ok but i indeed cannot hear anything . Meanwhile the sound is OK using XP on the same box. so the hardware shouldnot have any problem.

FYI:
Code:
when i playing mp3 using mpc, the irq 17 indeed occurs:
 [COvmstat -i
 interrupt total rate
 irq1: atkbd0 2740 3
 irq12: psm0 26212 30
 irq14: ata0 4831 5
 irq15: ata1 24 0
 irq16: uhci0+ 909 1
 irq17: pcm0 23239 26
 irq21: rl0 905 1
 cpu0:timer 155696 178
 Total 214556 246DE]
Any suggestion is appreciated !
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound on FreeBSD corey_james Guides 19 13th August 2010 11:05 PM
Recording sound with external sound card backrow OpenBSD General 5 21st August 2009 08:17 PM
FreeBSD 7.2 amd64 no sound erim FreeBSD General 5 3rd June 2009 07:54 AM
Have no sound freeBSD 7.0 yavko FreeBSD Installation and Upgrading 3 31st July 2008 10:20 AM
problem with Virtual Sound Channels in FreeBSD 7 casper007 FreeBSD Installation and Upgrading 3 16th July 2008 04:22 PM


All times are GMT. The time now is 03:37 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick