DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 15th August 2012
adam adam is offline
New User
 
Join Date: Aug 2012
Posts: 2
Thanked 0 Times in 0 Posts
Default Samsung SCX 4200

Hello all!
This is my first post so don't diss me too much
I use 5.1 GENERIC#160 i386 and want to print using my printer Samsung SCX-4200. I disabled ulpt in the kernel. Changed ownership /dev/u{gen*,sb*} to be read and write by _cups user. CUPS works and I can see printer in admin panel.
I have got this error (this time):
Code:
E [15/Aug/2012:22:41:18 +0200] [Job 1] Ghostscript exited with value 0
E [15/Aug/2012:22:41:18 +0200] [Job 1] SpliX Cannot open job
E [15/Aug/2012:22:41:18 +0200] [Job 1] SpliX Error while rendering the request. Check the previous message
E [15/Aug/2012:22:41:18 +0200] [Job 1] Job stopped due to filter errors; please consult the error_log file for details.
D [15/Aug/2012:22:41:18 +0200] [Job 1] The following messages were recorded from 22:41:17 to 22:41:18
D [15/Aug/2012:22:41:18 +0200] [Job 1] Job restarted by user.
D [15/Aug/2012:22:41:18 +0200] [Job 1] job-sheets=none,none
D [15/Aug/2012:22:41:18 +0200] [Job 1] argv[0]="Samsung_SCX-4200_Series"
D [15/Aug/2012:22:41:18 +0200] [Job 1] argv[1]="1"
D [15/Aug/2012:22:41:18 +0200] [Job 1] argv[2]="root"
D [15/Aug/2012:22:41:18 +0200] [Job 1] argv[3]="Test Page"
D [15/Aug/2012:22:41:18 +0200] [Job 1] argv[4]="1"
D [15/Aug/2012:22:41:18 +0200] [Job 1] argv[5]="job-uuid=urn:uuid:1cd8e159-d4b0-3746-42b1-474beced8677 job-originating-host-name=localhost time-at-creation=1345061429 time-at-processing=1345063277 AP_D_InputSlot="
D [15/Aug/2012:22:41:18 +0200] [Job 1] argv[6]="/var/spool/cups/d00001-001"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[0]="CUPS_CACHEDIR=/var/cache/cups"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[1]="CUPS_DATADIR=/usr/local/share/cups"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[2]="CUPS_DOCROOT=/usr/local/share/doc/cups"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[3]="CUPS_FONTPATH=/usr/local/share/cups/fonts"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[4]="CUPS_REQUESTROOT=/var/spool/cups"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[5]="CUPS_SERVERBIN=/usr/local/libexec/cups"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[6]="CUPS_SERVERROOT=/etc/cups"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[7]="CUPS_STATEDIR=/var/run/cups"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[8]="HOME=/var/spool/cups/tmp"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[9]="PATH=/usr/local/libexec/cups/filter:/usr/local/bin:/usr/local/sbin:/bin:/usr/bin"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[10]="SERVER_ADMIN=root@3sierpien2012.my.domain"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[11]="SOFTWARE=CUPS/1.5.0"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[12]="TMPDIR=/var/spool/cups/tmp"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[13]="USER=root"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[14]="CUPS_SERVER=/var/run/cups/cups.sock"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[15]="CUPS_ENCRYPTION=IfRequested"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[16]="IPP_PORT=631"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[17]="CHARSET=utf-8"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[18]="LANG=en_US.UTF-8"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[19]="PPD=/etc/cups/ppd/Samsung_SCX-4200_Series.ppd"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[20]="RIP_MAX_CACHE=128m"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[21]="CONTENT_TYPE=application/vnd.cups-banner"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[22]="DEVICE_URI=usb://Samsung/SCX-4200%20Series?serial=8T21BADL415763B.&interface=1"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[23]="PRINTER_INFO=Samsung SCX-4200 Series"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[24]="PRINTER_LOCATION="
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[25]="PRINTER=Samsung_SCX-4200_Series"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[26]="PRINTER_STATE_REASONS=none"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[27]="CUPS_FILETYPE=document"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[28]="FINAL_CONTENT_TYPE=printer/Samsung_SCX-4200_Series"
D [15/Aug/2012:22:41:18 +0200] [Job 1] envp[29]="AUTH_I****"
D [15/Aug/2012:22:41:18 +0200] [Job 1] Started filter /usr/local/libexec/cups/filter/bannertops (PID 21411)
D [15/Aug/2012:22:41:18 +0200] [Job 1] Started filter /usr/local/libexec/cups/filter/gstoraster (PID 4948)
D [15/Aug/2012:22:41:18 +0200] [Job 1] Started filter /usr/local/libexec/cups/filter/rastertoqpdl (PID 21836)
D [15/Aug/2012:22:41:18 +0200] [Job 1] Started backend /usr/local/libexec/cups/backend/usb (PID 9586)
D [15/Aug/2012:22:41:18 +0200] [Job 1] Restarted by "root".
D [15/Aug/2012:22:41:18 +0200] [Job 1] print_device
D [15/Aug/2012:22:41:18 +0200] [Job 1] load_banner(filename="/var/spool/cups/d00001-001")
D [15/Aug/2012:22:41:18 +0200] [Job 1] SpliX SpliX filter V. 2.0.0 by Aurélien Croc (AP²C)
D [15/Aug/2012:22:41:18 +0200] [Job 1] 1 #CUPS-BANNER
D [15/Aug/2012:22:41:18 +0200] [Job 1] SpliX More information at: 
D [15/Aug/2012:22:41:18 +0200] [Job 1] 2 Show printer-name printer-info printer-location printer-make-and-model printer-driver-name printer-driver-version paper-size imageable-area
D [15/Aug/2012:22:41:18 +0200] [Job 1] SpliX Compiled with: Threads=enabled (#=2, Cache=30), JBIG=enabled, BlackOptim=enabled
D [15/Aug/2012:22:41:18 +0200] [Job 1] 3 Header Printer Test Page
D [15/Aug/2012:22:41:18 +0200] [Job 1] Set job-printer-state-message to "SpliX Cannot get input slot information.", current level=ERROR
D [15/Aug/2012:22:41:18 +0200] [Job 1] 4 Footer Printer Test Page
D [15/Aug/2012:22:41:18 +0200] [Job 1] 5 Notice CUPS 1.5.0.
D [15/Aug/2012:22:41:18 +0200] [Job 1] 6 Image images/cups.png
D [15/Aug/2012:22:41:18 +0200] [Job 1] 7 Image images/color-wheel.png
D [15/Aug/2012:22:41:18 +0200] [Job 1] Page = 595x842; 11,15 to 584,827
D [15/Aug/2012:22:41:18 +0200] [Job 1] SpliX Monochrome printer Samsung SCX-4200 with QPDL v. 1
D [15/Aug/2012:22:41:18 +0200] [Job 1] SpliX Cache controller thread loaded and is waiting for a job
D [15/Aug/2012:22:41:18 +0200] [Job 1] usb_find_busses=1
D [15/Aug/2012:22:41:18 +0200] [Job 1] usb_find_devices=1
D [15/Aug/2012:22:41:18 +0200] [Job 1] STATE: +connecting-to-device
D [15/Aug/2012:22:41:18 +0200] [Job 1] STATE: -connecting-to-device
D [15/Aug/2012:22:41:18 +0200] [Job 1] Page = 595x842; 11,15 to 584,827
D [15/Aug/2012:22:41:18 +0200] [Job 1] slow_collate=0, slow_duplex=0, slow_order=0
D [15/Aug/2012:22:41:18 +0200] [Job 1] Before copy_comments - %!PS-Adobe-3.0
D [15/Aug/2012:22:41:18 +0200] [Job 1] %!PS-Adobe-3.0
D [15/Aug/2012:22:41:18 +0200] [Job 1] %%Title: label printing configuration file
D [15/Aug/2012:22:41:18 +0200] [Job 1] %%BoundingBox: (atend)
D [15/Aug/2012:22:41:18 +0200] [Job 1] %%Pages: 0
D [15/Aug/2012:22:41:18 +0200] [Job 1] %%EndComments
D [15/Aug/2012:22:41:18 +0200] [Job 1] Before copy_prolog - %%BeginProlog
D [15/Aug/2012:22:41:18 +0200] [Job 1] Before copy_setup - %%BeginSetup
D [15/Aug/2012:22:41:18 +0200] [Job 1] Before page loop - DEBUG: Wrote 0 pages...
D [15/Aug/2012:22:41:18 +0200] [Job 1] Segmentation fault 
D [15/Aug/2012:22:41:18 +0200] [Job 1] INFO: Start rendering...
D [15/Aug/2012:22:41:18 +0200] [Job 1] Start rendering...
D [15/Aug/2012:22:41:18 +0200] [Job 1] INFO: Processing page 1...
D [15/Aug/2012:22:41:18 +0200] [Job 1] Processing page 1...
D [15/Aug/2012:22:41:18 +0200] [Job 1] PNG image: 128x128x8, color_type=6 (RGB+ALPHA)
D [15/Aug/2012:22:41:18 +0200] [Job 1] PNG image: 192x128x8, color_type=2 (RGB)
D [15/Aug/2012:22:41:18 +0200] [Job 1] Start rendering...
D [15/Aug/2012:22:41:18 +0200] [Job 1] Processing page 1...
D [15/Aug/2012:22:41:18 +0200] [Job 1] SpliX Cache controller unloaded. See ya
D [15/Aug/2012:22:41:18 +0200] [Job 1] End of messages
D [15/Aug/2012:22:41:18 +0200] [Job 1] printer-state=3(idle)
D [15/Aug/2012:22:41:18 +0200] [Job 1] printer-state-message="SpliX Error while rendering the request. Check the previous message"
D [15/Aug/2012:22:41:18 +0200] [Job 1] printer-state-reasons=none
E [15/Aug/2012:22:46:19 +0200] [Job 1] Stopping unresponsive job!
but an hour ago the problem was something like that:
...rastertoqpdl exited with status 1 (or 4)
and ...gstoraster exited with status 1 or 4.
had someone have similar problem? how did you solve this?

I just would like to print some text

Last edited by ocicat; 15th August 2012 at 09:43 PM. Reason: Please use [code] & [/code] tags when posting log file contents.
Reply With Quote
  #2   (View Single Post)  
Old 16th August 2012
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,610
Thanked 214 Times in 189 Posts
Default

Hello, and welcome. It can be difficult to diagnose interoperability issues with CUPS.

There are two log messages that I think might indicate where to look for possible problem sources.

The first error is "Splix Cannot open job".

Splix is nothing more than two conversion programs and a library of .ppd files. I assume the pstoqpdl filter can't reach out and open a spool file. I would look to permission issues first, as you were modifying them.

Later, there is a segmentation fault. But what program abended? It's not clear from the log. Perhaps more detailed logs can be produced, but I'm no longer a CUPS user so I don't have specific guidance.

Perhaps the Splix filters can be used with a different print subsystem? If so, you may be able to rule CUPS in our out as a root cause of the problem.

Last edited by jggimi; 16th August 2012 at 12:34 AM. Reason: typos. Damned autocorrecting phone.
Reply With Quote
  #3   (View Single Post)  
Old 16th August 2012
adam adam is offline
New User
 
Join Date: Aug 2012
Posts: 2
Thanked 0 Times in 0 Posts
Default

dmesg
Code:
OpenBSD 5.1 (GENERIC) #160: Sun Feb 12 09:46:33 MST 2012
    deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: AMD Athlon(tm) XP 2600+ ("AuthenticAMD" 686-class, 256KB L2 cache) 2.08 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE,MMXX,3DNOW2,3DNOW
real mem  = 1073217536 (1023MB)
avail mem = 1045565440 (997MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 05/14/03, BIOS32 rev. 0 @ 0xfb470, SMBIOS rev. 2.2 @ 0xf0000 (48 entries)
bios0: vendor Phoenix Technologies, LTD version "ASUS A7N8X-X ACPI BIOS Rev 1005" date 05/14/2003
bios0: ASUSTeK Computer INC. A7N8X-X
apm0 at bios0: Power Management spec V1.2 (slowidle)
acpi at bios0 function 0x0 not configured
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xdf84
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdeb0/208 (11 entries)
pcibios0: PCI Exclusive IRQs: 5 11 12
pcibios0: no compatible PCI ICU found
pcibios0: Warning, unable to fix up PCI interrupt routing
pcibios0: PCI bus #2 is the last bus
bios0: ROM list: 0xc0000/0xd000 0xd0000/0x1800
cpu0 at mainbus0: (uniprocessor)
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "NVIDIA nForce2 PCI" rev 0xc1
agp at pchb0 not configured
"NVIDIA nForce2" rev 0xc1 at pci0 dev 0 function 1 not configured
"NVIDIA nForce2" rev 0xc1 at pci0 dev 0 function 2 not configured
"NVIDIA nForce2" rev 0xc1 at pci0 dev 0 function 3 not configured
"NVIDIA nForce2" rev 0xc1 at pci0 dev 0 function 4 not configured
"NVIDIA nForce2" rev 0xc1 at pci0 dev 0 function 5 not configured
pcib0 at pci0 dev 1 function 0 "NVIDIA nForce2 ISA" rev 0xa4
nviic0 at pci0 dev 1 function 1 "NVIDIA nForce2 SMBus" rev 0xa2
iic0 at nviic0
spdmem0 at iic0 addr 0x52: 512MB DDR SDRAM non-parity PC3200CL3.0
iic1 at nviic0
wbenv0 at iic1 addr 0x2e: W83L785TS-L
iic1: addr 0x49 04=1c 07=50 12=4b 17=50 22=4b 24=1c 2f=50 3a=50 3f=50 4d=00 4e=4b 50=1c 5e=4b 66=4b 6c=1c 74=1c 7b=50 86=4b 8f=50 93=50 9e=4b a1=00 a2=4b ab=50 b2=4b ba=4b c0=1c c9=00 ca=4b d5=00 d6=4b d9=00 da=4b e8=1c ec=1c f9=00 fa=4b words 00=ffff 01=ffff 02=ffff 03=ffff 04=1c80 05=00ff 06=4b00 07=5000
ohci0 at pci0 dev 2 function 0 "NVIDIA nForce2 USB" rev 0xa4: irq 5, version 1.0, legacy support
ohci1 at pci0 dev 2 function 1 "NVIDIA nForce2 USB" rev 0xa4: irq 12, version 1.0, legacy support
ehci0 at pci0 dev 2 function 2 "NVIDIA nForce2 USB" rev 0xa4: irq 11
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "NVIDIA EHCI root hub" rev 2.00/1.00 addr 1
nfe0 at pci0 dev 4 function 0 "NVIDIA nForce2 LAN" rev 0xa1: irq 11, address 00:0c:6e:91:c5:c8
rlphy0 at nfe0 phy 1: RTL8201L 10/100 PHY, rev. 1
auich0 at pci0 dev 6 function 0 "NVIDIA nForce2 AC97" rev 0xa1: irq 5, nForce2 AC97
ac97: codec id 0x414c4720 (Avance Logic ALC650)
ac97: codec features 20 bit DAC, 18 bit ADC, Realtek 3D
audio0 at auich0
ppb0 at pci0 dev 8 function 0 "NVIDIA nForce2 PCI-PCI" rev 0xa3
pci1 at ppb0 bus 1
pciide0 at pci0 dev 9 function 0 "NVIDIA nForce2 IDE" rev 0xa2: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <QUANTUM FIREBALL CR8.4A>
wd0: 16-sector PIO, LBA, 8063MB, 16514064 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 4
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <HL-DT-ST, DVD-ROM GDR8162B, 0015> ATAPI 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
ppb1 at pci0 dev 30 function 0 "NVIDIA nForce2 AGP" rev 0xc1
pci2 at ppb1 bus 2
vga1 at pci2 dev 0 function 0 "ATI Radeon 9200 SE Sec" rev 0x01
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
radeondrm0 at vga1: irq 12
drm0 at radeondrm0
"ATI Radeon 9200 SE" rev 0x01 at pci2 dev 0 function 1 not configured
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
com1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
usb1 at ohci0: USB revision 1.0
uhub1 at usb1 "NVIDIA OHCI root hub" rev 1.00/1.00 addr 1
usb2 at ohci1: USB revision 1.0
uhub2 at usb2 "NVIDIA OHCI root hub" rev 1.00/1.00 addr 1
mtrr: Pentium Pro MTRR support
run0 at uhub0 port 1 "Ralink 802.11 g WLAN" rev 2.00/1.01 addr 2
run0: MAC/BBP RT3070 (rev 0x0201), RF RT2020 (MIMO 1T1R), address 54:e6:fc:90:39:c4
ugen0 at uhub0 port 2 "Samsung SCX-4200 Series" rev 2.00/1.00 addr 3
uhidev0 at uhub2 port 1 configuration 1 interface 0 "A4Tech PS/2+USB Mouse" rev 1.10/0.01 addr 2
uhidev0: iclass 3/1
ums0 at uhidev0: 7 buttons, Z dir
wsmouse0 at ums0 mux 0
uhidev1 at uhub2 port 2 configuration 1 interface 0 "USB USB Keykoard" rev 1.10/1.10 addr 3
uhidev1: iclass 3/1
ukbd0 at uhidev1: 8 modifier keys, 6 key codes
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
uhidev2 at uhub2 port 2 configuration 1 interface 1 "USB USB Keykoard" rev 1.10/1.10 addr 3
uhidev2: iclass 3/0, 2 report ids
uhid0 at uhidev2 reportid 1: input=2, output=0, feature=0
uhid1 at uhidev2 reportid 2: input=1, output=0, feature=0
vscsi0 at root
scsibus1 at vscsi0: 256 targets
softraid0 at root
scsibus2 at softraid0: 256 targets
root on wd0a (2ae35dd4deb5c4f3.a) swap on wd0b dump on wd0b
lpt0: out of paper
hmm what does "lpt0: out of paper" mean here?
I disabled ulpt.

usbdevs -vd
Code:
Controller /dev/usb0:
addr 1: high speed, self powered, config 1, EHCI root hub(0x0000), NVIDIA(0x10de), rev 1.00
  uhub0
 port 1 addr 2: high speed, power 450 mA, config 1, 802.11 g WLAN(0x2070), Ralink(0x148f), rev 1.01, iSerialNumber 1.0
   run0
 port 2 addr 3: high speed, self powered, config 1, SCX-4200 Series(0x341b), Samsung(0x04e8), rev 1.00, iSerialNumber 8T21BADL415763B.
   ugen0
 port 3 powered
 port 4 powered
 port 5 powered
 port 6 powered
Controller /dev/usb1:
addr 1: full speed, self powered, config 1, OHCI root hub(0x0000), NVIDIA(0x10de), rev 1.00
  uhub1
 port 1 powered
 port 2 powered
 port 3 powered
Controller /dev/usb2:
addr 1: full speed, self powered, config 1, OHCI root hub(0x0000), NVIDIA(0x10de), rev 1.00
  uhub2
 port 1 addr 2: low speed, power 100 mA, config 1, PS/2+USB Mouse(0x0006), A4Tech(0x09da), rev 0.01
   uhidev0
 port 2 addr 3: low speed, power 98 mA, config 1, USB Keykoard(0x0023), USB(0x1a2c), rev 1.10
   uhidev1
   uhidev2
 port 3 powered
so I did: sudo chown _cups /dev/ugen0.* /dev/usb0

localhost:631/admin/log/error_log
Code:
X [17/Aug/2012:00:16:55 +0200] kevent() returned Bad file descriptor
X [17/Aug/2012:00:22:39 +0200] kevent() returned Bad file descriptor
X [17/Aug/2012:00:36:59 +0200] kevent() returned Bad file descriptor
E [17/Aug/2012:00:39:17 +0200] [Job 1] SpliX Cannot get input slot information.
E [17/Aug/2012:00:39:20 +0200] [Job 1] Ghostscript exited with value 0
E [17/Aug/2012:00:39:20 +0200] [Job 1] SpliX Cannot open job
E [17/Aug/2012:00:39:20 +0200] [Job 1] SpliX Error while rendering the request. Check the previous message
E [17/Aug/2012:00:39:20 +0200] [Job 1] Job stopped due to filter errors; please consult the error_log file for details.
D [17/Aug/2012:00:39:20 +0200] [Job 1] The following messages were recorded from 00:39:17 to 00:39:20
D [17/Aug/2012:00:39:20 +0200] [Job 1] Adding start banner page "none".
D [17/Aug/2012:00:39:20 +0200] [Job 1] Adding end banner page "none".
D [17/Aug/2012:00:39:20 +0200] [Job 1] File of type application/vnd.cups-banner queued by "root".
D [17/Aug/2012:00:39:20 +0200] [Job 1] hold_until=0
D [17/Aug/2012:00:39:20 +0200] [Job 1] Queued on "Samsung_SCX-4200_Series" by "root".
D [17/Aug/2012:00:39:20 +0200] [Job 1] job-sheets=none,none
D [17/Aug/2012:00:39:20 +0200] [Job 1] argv[0]="Samsung_SCX-4200_Series"
D [17/Aug/2012:00:39:20 +0200] [Job 1] argv[1]="1"
D [17/Aug/2012:00:39:20 +0200] [Job 1] argv[2]="root"
D [17/Aug/2012:00:39:20 +0200] [Job 1] argv[3]="Test Page"
D [17/Aug/2012:00:39:20 +0200] [Job 1] argv[4]="1"
D [17/Aug/2012:00:39:20 +0200] [Job 1] argv[5]="job-uuid=urn:uuid:9dd4fbac-c946-3519-7e8f-9f5fadfee042 job-originating-host-name=localhost time-at-creation=1345156757 time-at-processing=1345156757 AP_D_InputSlot="
D [17/Aug/2012:00:39:20 +0200] [Job 1] argv[6]="/var/spool/cups/d00001-001"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[0]="CUPS_CACHEDIR=/var/cache/cups"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[1]="CUPS_DATADIR=/usr/local/share/cups"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[2]="CUPS_DOCROOT=/usr/local/share/doc/cups"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[3]="CUPS_FONTPATH=/usr/local/share/cups/fonts"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[4]="CUPS_REQUESTROOT=/var/spool/cups"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[5]="CUPS_SERVERBIN=/usr/local/libexec/cups"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[6]="CUPS_SERVERROOT=/etc/cups"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[7]="CUPS_STATEDIR=/var/run/cups"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[8]="HOME=/var/spool/cups/tmp"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[9]="PATH=/usr/local/libexec/cups/filter:/usr/local/bin:/usr/local/sbin:/bin:/usr/bin"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[10]="SERVER_ADMIN=root@kaszka.my.domain"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[11]="SOFTWARE=CUPS/1.5.0"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[12]="TMPDIR=/var/spool/cups/tmp"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[13]="USER=root"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[14]="CUPS_SERVER=/var/run/cups/cups.sock"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[15]="CUPS_ENCRYPTION=IfRequested"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[16]="IPP_PORT=631"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[17]="CHARSET=utf-8"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[18]="LANG=en_US.UTF-8"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[19]="PPD=/etc/cups/ppd/Samsung_SCX-4200_Series.ppd"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[20]="RIP_MAX_CACHE=128m"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[21]="CONTENT_TYPE=application/vnd.cups-banner"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[22]="DEVICE_URI=usb://Samsung/SCX-4200%20Series?serial=8T21BADL415763B.&interface=1"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[23]="PRINTER_INFO=Samsung SCX-4200 Series"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[24]="PRINTER_LOCATION="
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[25]="PRINTER=Samsung_SCX-4200_Series"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[26]="PRINTER_STATE_REASONS=none"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[27]="CUPS_FILETYPE=document"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[28]="FINAL_CONTENT_TYPE=printer/Samsung_SCX-4200_Series"
D [17/Aug/2012:00:39:20 +0200] [Job 1] envp[29]="AUTH_I****"
D [17/Aug/2012:00:39:20 +0200] [Job 1] Started filter /usr/local/libexec/cups/filter/bannertops (PID 26764)
D [17/Aug/2012:00:39:20 +0200] [Job 1] Started filter /usr/local/libexec/cups/filter/gstoraster (PID 1067)
D [17/Aug/2012:00:39:20 +0200] [Job 1] Started filter /usr/local/libexec/cups/filter/rastertoqpdl (PID 30189)
D [17/Aug/2012:00:39:20 +0200] [Job 1] Started backend /usr/local/libexec/cups/backend/usb (PID 2277)
D [17/Aug/2012:00:39:20 +0200] [Job 1] print_device
D [17/Aug/2012:00:39:20 +0200] [Job 1] usb_find_busses=1
D [17/Aug/2012:00:39:20 +0200] [Job 1] usb_find_devices=1
D [17/Aug/2012:00:39:20 +0200] [Job 1] STATE: +connecting-to-device
D [17/Aug/2012:00:39:20 +0200] [Job 1] STATE: -connecting-to-device
D [17/Aug/2012:00:39:20 +0200] [Job 1] load_banner(filename="/var/spool/cups/d00001-001")
D [17/Aug/2012:00:39:20 +0200] [Job 1] 1 #CUPS-BANNER
D [17/Aug/2012:00:39:20 +0200] [Job 1] 2 Show printer-name printer-info printer-location printer-make-and-model printer-driver-name printer-driver-version paper-size imageable-area
D [17/Aug/2012:00:39:20 +0200] [Job 1] 3 Header Printer Test Page
D [17/Aug/2012:00:39:20 +0200] [Job 1] 4 Footer Printer Test Page
D [17/Aug/2012:00:39:20 +0200] [Job 1] 5 Notice CUPS 1.5.0.
D [17/Aug/2012:00:39:20 +0200] [Job 1] 6 Image images/cups.png
D [17/Aug/2012:00:39:20 +0200] [Job 1] Page = 595x842; 11,15 to 584,827
D [17/Aug/2012:00:39:20 +0200] [Job 1] slow_collate=0, slow_duplex=0, slow_order=0
D [17/Aug/2012:00:39:20 +0200] [Job 1] SpliX SpliX filter V. 2.0.0 by Aurélien Croc (AP²C)
D [17/Aug/2012:00:39:20 +0200] [Job 1] SpliX More information at: http://splix.ap2c.org
D [17/Aug/2012:00:39:20 +0200] [Job 1] SpliX Compiled with: Threads=enabled (#=2, Cache=30), JBIG=enabled, BlackOptim=enabled
D [17/Aug/2012:00:39:20 +0200] [Job 1] Set job-printer-state-message to "SpliX Cannot get input slot information.", current level=ERROR
D [17/Aug/2012:00:39:20 +0200] [Job 1] SpliX Monochrome printer Samsung SCX-4200 with QPDL v. 1
D [17/Aug/2012:00:39:20 +0200] [Job 1] SpliX Cache controller thread loaded and is waiting for a job
D [17/Aug/2012:00:39:20 +0200] [Job 1] Before copy_comments - %!PS-Adobe-3.0
D [17/Aug/2012:00:39:20 +0200] [Job 1] %!PS-Adobe-3.0
D [17/Aug/2012:00:39:20 +0200] [Job 1] %%Title: label printing configuration file
D [17/Aug/2012:00:39:20 +0200] [Job 1] %%BoundingBox: (atend)
D [17/Aug/2012:00:39:20 +0200] [Job 1] %%Pages: 0
D [17/Aug/2012:00:39:20 +0200] [Job 1] %%EndComments
D [17/Aug/2012:00:39:20 +0200] [Job 1] Before copy_prolog - %%BeginProlog
D [17/Aug/2012:00:39:20 +0200] [Job 1] Before copy_setup - %%BeginSetup
D [17/Aug/2012:00:39:20 +0200] [Job 1] Before page loop - DEBUG: Wrote 0 pages...
D [17/Aug/2012:00:39:20 +0200] [Job 1] 7 Image images/color-wheel.png
D [17/Aug/2012:00:39:20 +0200] [Job 1] Page = 595x842; 11,15 to 584,827
D [17/Aug/2012:00:39:20 +0200] [Job 1] Segmentation fault 
D [17/Aug/2012:00:39:20 +0200] [Job 1] INFO: Start rendering...
D [17/Aug/2012:00:39:20 +0200] [Job 1] Start rendering...
D [17/Aug/2012:00:39:20 +0200] [Job 1] INFO: Processing page 1...
D [17/Aug/2012:00:39:20 +0200] [Job 1] Processing page 1...
D [17/Aug/2012:00:39:20 +0200] [Job 1] PNG image: 128x128x8, color_type=6 (RGB+ALPHA)
D [17/Aug/2012:00:39:20 +0200] [Job 1] PNG image: 192x128x8, color_type=2 (RGB)
D [17/Aug/2012:00:39:20 +0200] [Job 1] Start rendering...
D [17/Aug/2012:00:39:20 +0200] [Job 1] Processing page 1...
D [17/Aug/2012:00:39:20 +0200] [Job 1] SpliX Cache controller unloaded. See ya
D [17/Aug/2012:00:39:20 +0200] [Job 1] End of messages
D [17/Aug/2012:00:39:20 +0200] [Job 1] printer-state=3(idle)
D [17/Aug/2012:00:39:20 +0200] [Job 1] printer-state-message="SpliX Error while rendering the request. Check the previous message"
D [17/Aug/2012:00:39:20 +0200] [Job 1] printer-state-reasons=none
What else should I show you to help resolve this problema?
Reply With Quote
  #4   (View Single Post)  
Old 17th August 2012
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,610
Thanked 214 Times in 189 Posts
Default

My best guess is that Splix failed to open a file, not a device. I guessed the spool file. But its just a guess. I don't use CUPS, and I've never used Splix.

I do not understand why you found it necessary to disable ulpt(4). I've done so with some multifunction printers in order to do things like use their scanners. Is it needed?

I also don't understand why you touched any ownerships or permissions in /dev. My thought was the permissions problem was with a spool file, not the device (which is managed by CUPS, not by the Splix filter, to the best of my understanding). You should be able to easily revert your /dev settings to their defaults by using the MAKEDEV tool. eg:
Code:
# cd /dev; sh MAKEDEV all
-----

A search of the ports@ mailing list only had one short conversation about Splix, unassociated with your problem.

I recommend you post to ports@ with your problem description as you have done here. The Splix port maintainer is Antoine Jacoutot (ajacoutot@), he is active on the ports@ mailing list or you may contact him directly.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hardware Samsung: 4TB 3.5 disks possible to create with 1TB platters vermaden News 0 10th March 2011 09:34 AM
Mounting/Reading Samsung USB drive Gogglehead FreeBSD General 11 25th February 2011 09:55 PM
Samsung syncmaster 933sn xorg.conf trombel FreeBSD General 11 8th June 2010 11:02 AM
NetBSD on Samsung 2410.... nmohture NetBSD General 1 23rd July 2009 11:08 AM


All times are GMT. The time now is 02:41 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick