DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 15th January 2013
nico_h nico_h is offline
Port Guard
 
Join Date: Jun 2008
Posts: 23
Thanked 0 Times in 0 Posts
Question conflicts between two packages

Hello everyone,


When installing a new package (with make install clean) it happens quite often that the install ends up on a conflict, like :

Code:
Installing XXX ...pkg: XXX conflicts with YYY (installs files into the same place).  Problematic file: ...
For instance, I've had this problem with mod_fcgid and apache. If there is an upgrade of apache, then the compilation ends on a conflict between mod_fcgid and apache. For this case, I've found this roundabout : first delete mod_fcgid and then upgrade apache and then reinstall mod_fcgid. It works, but it's a bit weird.

And note that :
Code:
# grep mod_fcgid /usr/ports/UPDATING 
#
Same problem with texlive now (ports tree installed from portshaker) :
If I do : cd /usr/ports/print/texlive-scheme-full && make install clean, then after a while it ends up here :
Code:
===>   Registering installation for texlive-kpathsea-20130112 as automatic
Installing texlive-kpathsea-20130112...pkg: texlive-kpathsea-20130112 conflicts with texlive-core-20120628 (installs files into the same place).  Problematic file: /usr/local/share/texmf/web2c/fmtutil.cnf
*** Error code 70

Stop in /usr/ports/print/texlive-kpathsea.
*** Error code 1

Stop in /usr/ports/print/texlive-bibtex.
*** Error code 1

Stop in /usr/ports/print/texlive-scheme-full.
Very strangely, if I rerun make install clean, I get another conflict :
Code:
Installing texlive-texlive-scripts-20130107...pkg: texlive-texlive-scripts-20130107 conflicts with texlive-core-20120628 (installs files into the same place).  Problematic file: /usr/local/share/texmf/scripts/texlive/rungs.tlu
*** Error code 70

Stop in /usr/ports/print/texlive-texlive-scripts.
*** Error code 1

Stop in /usr/ports/print/texlive-scheme-full
This situation is a bit confusing. I don't know how to resolve the problem with texlive, there are so many dependencies... I just don't know what to do.

Is there any trick to bypass this kind of problem ? Any option of make that could tell which files to keep, for instance ?

Thanks for any hint !
Reply With Quote
  #2   (View Single Post)  
Old 16th February 2013
bsdnotbdsm bsdnotbdsm is offline
Port Guard
 
Join Date: Jan 2013
Posts: 26
Thanked 0 Times in 0 Posts
Default

Hello,
First of all, I don't use portshaker, but I encountered the problem with files conflicting, several times. Usually I notice it when upgrading my whole ports collecion (which for me is portmaster -ad)..
So we can conclude that this is a general ports collection's problem.

Usually, I noticed there are two main reasons for this:
1) A port change its name (eg tools-foobar becomes foobarutils). Then it's obvious that the "tools-foobar" must be uninstalled before attempting the ports upgrade.

2) A port gets merged into another port (eg foobar-modules becomes part of the foobar-all). Again, the problem is solved by uninstalling foobar-modules before attempting the ports upgrade.

As far as I could see, these issues are mentioned in /usr/ports/UPDATING file, together with the complete commands to solve the conflicting files, so you only have to copy/paste the removal commands and then re-attempt upgrade.

However, there could be mistakes maybe, like the one you mentioned with mod_fcgid. I don't have a clear explanation for that one..

Last edited by bsdnotbdsm; 17th February 2013 at 05:37 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I have 18 GB rpm packages mfaridi Programming 5 15th April 2010 09:41 PM
[Beginner]perl-5.10.1 conflicts with installed package(s): Noclue FreeBSD Installation and Upgrading 2 13th April 2010 09:14 PM
FreeBSD ports conflicts handling J65nko FreeBSD Ports and Packages 1 17th January 2010 05:16 PM
libslang2-2.1.4 conflicts with installed package(s): libslang-1.4.9 edhunter FreeBSD Ports and Packages 1 9th October 2008 10:52 AM
gnome; librsvg package conflicts bsdnewbie999 OpenBSD General 8 21st June 2008 09:08 AM


All times are GMT. The time now is 01:13 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick