DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Installation and Upgrading

OpenBSD Installation and Upgrading Installing and upgrading OpenBSD.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 22nd September 2013
stan98765 stan98765 is offline
Hardcore OpenBSD User
 
Join Date: Jun 2008
Location: USA
Posts: 2
Thanked 0 Times in 0 Posts
Default OpenBSD 5.4 Nvidia Driver Issue and KDE Desktop disappearing text.

Hi all,

I have been using OpenBSD for the last 8 years. It does an excellent job as a firewall and partial desktop. Here is my dilemma listed below.

Scenario:
I have used OpenBSD 5.3 on my older PC using motherboard GA-8IK1100 and a Nvidia GeForce4 Ti 4600 - 128MB DDR (AGP 4x) - RAMDAC 350MHz, using NV25 chip. All has worked well.

Attacked files:
1. dmesg.boot_OB53
2. Xorg.0.log_OB53
3. dmesg.boot_OB54
4. Xorg.0.log_OB54
5. xorg.conf_OB54

I next tried a (NEW) install with OpenBSD 5.4 snapshot from the Alberta, Canada ftp web link using the openbsd.org/pub/OpenBSD/snapshots/i386 and openbsd.org/pub/OpenBSD/snapshots/packages/i368.

I use KDE for my Desktop display and only install kdebase-3.5.10p25.tgz as minimal KDE setup.

I had no problems with basic console setup after installation of OpenBSD 5.4 snapshot. The problem started with the installation of kdebase-3.5.10p25.tgz. I did my basic KDE setup as usual. The desktop pops up with text disappearing on my display monitor.

I created a (NEW) xcorg.conf file and copied it to the /etc directory. I am using the "nv" and "vesa" settings from the OpenBSD manual for this configuration. After some experimentation, I noticed that if I change Option "NoAccel" "false" and Option "ShadowFB" "false", I get the text disappearing on my LCD display. Next if I, change Option "NoAccel" "true" and Option "ShadowFB" "false", I get the text appearing on the LCD display. The only problem with this is that the KDE Konqueror Windows display properly, but if moved, they refresh themselves very slowly.

Attachment "xorg.conf_OB54.txt" causes the disappearing text on KDE desktop.
NOTE: It is only a quick modified setup to tweak my graphics card.

I have read on the X.Org Web Site that they decided to take out the "xaa" extension and replacing it with "exa". Noticed that some of the /usr/X11R6/lib/modules/extensions and /usr/X11R6/lib/modules have missing files in OpenBSD 5.4. Read that "exa" only used for Nvidia (nv80) chipsets and upward.

IDEA... Can they not keep both modules in? One for for older and the other for newer systems.

This leads me to the next question.
Why can't OpenBSD 5.4 be backwards compatible with older hardware and newer hardware at the same time? Like backing up to previous older drivers that work with older hardware.

X.org Web Site development document mentions quote "xaa is largely inadequate for accelerating modern desktop usage."
Here is the Link: http://www.x.org/wiki/Development/Do...on/Performance

The "exa" does not help me with the nv25 chip on my graphics card.

I don't want to buy another Graphics Card if the one I have work great with OpenBSD 5.3.
Question: Is there a work around, tweak or patch for OpenBSD 5.4 for using the Nvidia GeForce4 Ti 4600 - 128MB DDR (AGP 4x).

I've been searching the Internet for a solution, but have not found any helpful information.
Thank you for any ideas on this issue.

NOTE: I'll try to keep this issue updated until I find a solution.
Attached Files
File Type: txt xorg.conf_OB54.txt (3.6 KB, 41 views)
File Type: txt Xorg.0.log_OB54.txt (37.8 KB, 11 views)
File Type: txt Xorg.0.log_OB53.txt (40.0 KB, 13 views)
File Type: txt dmesg.boot_OB54.txt (6.6 KB, 10 views)
File Type: txt dmesg.boot_OB53.txt (6.6 KB, 34 views)

Last edited by stan98765; 23rd September 2013 at 01:59 AM.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
nVidia Driver on FreeBSD 8.1 x64? kasumi General software and network 5 5th March 2011 04:15 AM
Is nVidia driver stable? rex FreeBSD General 14 31st October 2008 06:40 PM
Image artifacts with nvidia-driver KernelPanic FreeBSD Ports and Packages 1 10th July 2008 09:56 PM
problems with nvidia-driver-169.12 greencross FreeBSD General 8 21st May 2008 01:41 PM


All times are GMT. The time now is 08:06 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick