DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 23rd November 2013
spacebar_permissions spacebar_permissions is offline
New User
 
Join Date: Nov 2013
Posts: 4
Thanked 0 Times in 0 Posts
Default Tmux basic fcns not working; Dell Inspiron, OpenBSD 5.4

System Information: OpenBSD 5.4 Generic#37 amd64, Dell Inspiron 11z, env TERM=vt220

Need help: I can start tmux but basic functionality isn't working, like Ctrl-b d. A point in the right direction would be greatly appreciated.

After performing a new install (I am new to OpenBSD), I tried the tmux tutorial from the OpenBSD faq:

http://www.openbsd.org/faq/faq7.html#tmux

Start tmux, start top, then Ctrl-b d results in top displaying "Command not understood". I quit top, then try Ctrl-b d, still does not detach tmux. I exit tmux.

Tmux man page says ~/.tmux.conf is default configuration file:

http://www.openbsd.org/cgi-bin/man.c...mat=html#FILES

I do not have this dot file in my home directory. Man page also says /etc/tmux.conf is system-wide configuration file that tmux loads /if present/. This file is not located in /etc directory. I would think a dotfile in my home directory would be created after I start tmux, perhaps pulling in the system defaults, or starting with a bare bones setup. Since it does not, I think I must have selected something incorrectly on the OpenBSD install process.

Web search for tmux.conf points to archlinux forum user asking, "Where's my tmux.conf?"

https://bbs.archlinux.org/viewtopic....817246#p817246

It mentions another directory that might contain tmux.conf, /usr/share/tmux, but I have no such tmux directory. A "whereis tmux" shows only /usr/bin tmux.

A response in the archlinux forum above indicates that in the example directory there is no tmux.conf file:

https://bbs.archlinux.org/viewtopic....816732#p816732

I can accept that, but when I look at the tmux FAQ (http://tmux.svn.sourceforge.net/viewvc/tmux/trunk/FAQ/) it gives an answer to, "How do I see the default configuration?", by using:

$ tmux -Lfoo -f/dev/null start\; show -g

The command string above displays a list of commands referred to in the tmux man page, so it seems to be pulling a default configuration.

Again, a point in the right direction would be greatly appreciated.

--spacebar_permissions
Reply With Quote
  #2   (View Single Post)  
Old 23rd November 2013
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,796
Thanked 214 Times in 189 Posts
Default

Hello, and welcome!

First step is to make sure your keystroke that follows the CTRL-b sequence does not also use the CTRL key. To detach, you type CTRL-b followed by "d" alone.

Second step is to make sure you're not using an environment where CTRL-b needs to be escaped ... such as starting a tmux session from within another tmux session.

---

The tmux configuration files do not exist by default; if you wish to use either a personal or system-wide configuration file, you must create it with your $EDITOR of choice.
Reply With Quote
  #3   (View Single Post)  
Old 23rd November 2013
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,902
Thanked 190 Times in 160 Posts
Default

When doing Internet-wide searches on OpenBSD tools which have been ported to other Unix-like operating systems (like Linux...), recognize that OpenBSD's file system is laid out differently (see the hier(7) manpage...). Following Linux-oriented documentation may be pointing you into the weeds when the target is actually OpenBSD.

Having said that, The Pragmatic Programmers subsidiary of O'Reilly has published a book on tmux(1), & the associated YouTube video (found at the link below...) might aid in your quest to master the utility:

http://pragprog.com/book/bhtmux/tmux
Reply With Quote
  #4   (View Single Post)  
Old 23rd November 2013
spacebar_permissions spacebar_permissions is offline
New User
 
Join Date: Nov 2013
Posts: 4
Thanked 0 Times in 0 Posts
Default

Thank you jggimi and ocicat for the quick responses!

jggimi, you identified the issue; instead of releasing the Ctrl-b keys, I was keeping them depressed while depressing the d-key at the same time. Feel real silly... Thank you for confirming that the configuration files do not exist by default.

ocicat, good point about referring to the archlinux forum while troubleshooting an (non)issue in OpenBSD. I got so busy trying to "do my homework" before posting, that I went off the grid :-) Thank you, also, for the book reference; if the video is any indication, the book looks to be worthwhile.

Thank you both, again!
--spacebar_permissions
Reply With Quote
  #5   (View Single Post)  
Old 24th November 2013
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,796
Thanked 214 Times in 189 Posts
Default

I wouldn't have recognized a "sticky" CTRL key if I hadn't made a similar mistake at some point. Please don't worry, we've all been there, done that (or something very akin to it).
Reply With Quote
  #6   (View Single Post)  
Old 24th November 2013
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 610
Thanked 9 Times in 9 Posts
Default

Quote:
It mentions another directory that might contain tmux.conf, /usr/share/tmux, but I have no such tmux directory. A "whereis tmux" shows only /usr/bin tmux.
One of the major differences between Linux and the BSD's is where files are placed. In general, user installed files in OpenBSD and FreeBSD are placed in /usr/local. Since Linux is just a kernel, everything else is essentially user installed in /usr.

OpenBSD places all configuration files in /etc irregardless of whether they are base applications or user applications. For example, the dhcp code is a core application and its configuration file is /etc/dhcpd.conf while mpd is user installed with its configuration file in /etc/mpd.conf.

Tmux is core package in OpenBSD which is why it is installed in /usr/bin. Prior to tmux being included as a core package, the executable binary, if you would have installed it, would have ended up in /usr/local/bin.

In OpenBSD, if it is likely that different users might tweak a configuration file to their own preferences, one can copy the /etc configuration file to one's home directory and modifiy it. The modification will overided the system conf files in /etc

Last edited by shep; 24th November 2013 at 03:00 AM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
openbsd basic questions barti OpenBSD General 12 17th July 2012 08:38 PM
Dell Inspiron 1525 - OpenBSD Scott7 OpenBSD General 7 26th March 2011 02:55 AM
NetBSD on Dell Inspiron 5150 kdu NetBSD Installation and Upgrading 5 10th June 2009 01:12 AM
OpenBSD 4.4/4.5 i386 installation on Dell Inspiron 6400 notebook. xixobrax OpenBSD Installation and Upgrading 12 30th April 2009 04:34 AM
Speakers not working in Dell Vostro 1400 mc_i2020 FreeBSD General 3 5th August 2008 09:00 PM


All times are GMT. The time now is 10:52 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick