DaemonForums  

Go Back   DaemonForums > Miscellaneous > General software and network

General software and network General OS-independent software and network questions, X11, MTA, routing, etc.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 8th June 2008
gosha gosha is offline
Spam Deminer
 
Join Date: Jun 2008
Location: China
Posts: 256
Thanked 0 Times in 0 Posts
Default xkb multibyte characters input problem

I just posted in bsdforum, but found out most people moved here.

> Hello folks,
> this time before writing I took my very long time to study and read and try hard to solve it myself, but I'm still stuck.
> Please help
> I really want get rid of Windows, but before I can do it I need all the multilanguage functions it has, it is a must for me.
> I don't care about a full locale, but I need to get multi-bytes carachers input and display.
> At the same time I don't want to have a Windows-like gui, so, no KDE, no GNOME (I guess a lot of my problems would be already solved with them).
> I'm running OpenBSD 4.3 on a laptop (HP Omnibook 900b). I'm sticking to OpenBSD because in my very (VERY) numerous installs to try out what's best for me, the only one that went really smooth and where everything (hardware-wise) works is OpenBSD.
> I'm running: Ion3 as a window manager, Mlterm as terminal, Mined as an editor for multi-language scripts, w3m as a browser, Pidgin for chats, Alpine for imap emails, Postgresql for database (MS Access has screwed up my tiny database, one of the reasons why I'm in a rush to switch. And for my little problem with postgres, see my other thread).
> So, what's the problem?
> First problem:
> I managed to get chinese characters display and input also in terminal, but filenames in chinese are not displayed even after using "convmv" to get them all to utf-8(the encoding I'm using mlterm with), that is, they get displayed by convmv but then disappear again if I do "ls".
> But, strangely enough, if I know the filename I can type it in and get it recognized and opened. Actually, this is not the biggest problem, I'd be ready to change all my filenames to latin letters.
> Second problem:
> I'm using xkb to switch keyboard layouts, but once switched the characters don't work in terminal (that is, after switching keyboard, typing results in no response for russian, and in funny garbage for accented characters), But they work in Firefox in the Google search. So it is probably a misconfiguration of mine, but I've tryed them all without success. The same problem applies to w3m and alpine, where I can input chinese but not cyrillic or accented characters.
>
> Here is the sections of xorg.conf that might help ("wqy" is wenquanyi, chinese bitmap font, very nice):
>
> Section "Files"
> RgbPath "/usr/X11R6/share/X11/rgb"
> ModulePath "/usr/X11R6/lib/modules"
> FontPath "/usr/X11R6/lib/X11/fonts/misc/"
> FontPath "/usr/X11R6/lib/X11/fonts/wqy/"
> FontPath "/usr/X11R6/lib/X11/fonts/cyrillic/"
> FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
> FontPath "/usr/X11R6/lib/X11/fonts/OTF"
> FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
> FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
> FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
> FontPath "/usr/local/lib/X11/fonts/ghostscript/"
> FontPath "/usr/local/lib/X11/fonts/mscorefonts/"
> EndSection
>
> Section "Module"
> Load "GLcore"
> Load "dbe"
> Load "extmod"
> Load "glx"
> Load "record"
> Load "xtrap"
> Load "freetype"
> Load "type1"
> EndSection
>
> Section "InputDevice"
> Identifier "Keyboard0"
> Driver "kbd"
> Option "XkbRules" "xorg"
> Option "XkbModel" "pc101"
> Option "XkbLayout" "us,it,ru(winkeys)"
> Option "XkbOptions" "grp:lwin_toggle"
> Option "XkbVariant" "nodeadkeys"
> EndSection
>
> Here is Mlterm configuration files:
> main:
> ENCODING = UTF-8
> fontsize=12
> input_method = uim
> scrollbar_view_name = simple
> line_space = 1
>
> font:
>ISO10646_UCS4_1=-schumacher-clean-medium-r-normal-*-12-120-75-75-*-*-iso10646-1;
> ISO10646_UCS4_1_BIWIDTH=-wenquanyi-wenquanyi bitmap song-medium-r-normal-*-12-120-75-75-p-*-iso10646-1:120;
>
> .inputrc:
> set convert-meta off
> set input-meta on
> set output-meta on
>
> .profile:
> # $OpenBSD: dot.profile,v 1.4 2005/02/16 06:56:57 matthieu Exp $
> #
> # sh/ksh initialization
>
> PATH=$HOME/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R6/bin:/usr/local/bin:/usr/local/sbin:/usr/games:.
> export PATH HOME TERM
> export PKG_PATH=ftp://ftp.kaist.ac.kr/pub/OpenBSD/4.3/packages/i386/:ftp://ftp.btradianz.se/pub/OpenBSD/.../packages/i386/
> export GDK_USE_XFT=0
> set +o emacs-usemeta
>
> I hope I did not forget anything
> Thank you in advance.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Input foreign characters under X11 Beastie General software and network 5 30th August 2009 11:51 AM
sorting special characters gosha Programming 15 9th April 2009 02:29 AM
Username longer than 16 characters _hmp_ FreeBSD General 5 13th January 2009 10:01 AM
C and file input/output 18Googol2 Programming 3 20th August 2008 04:02 PM
shell script with input c0mrade Programming 5 13th July 2008 04:33 AM


All times are GMT. The time now is 02:13 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick