DaemonForums  

Go Back   DaemonForums > Miscellaneous > General software and network

General software and network General OS-independent software and network questions, X11, MTA, routing, etc.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 8th June 2008
tanked tanked is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 56
Thanked 1 Time in 1 Post
Default DNS problem- name server record

System: FreeBSD 7.0-RELEASE

I'm using BIND from the base system and I'm having a problem, first here is the relevant entry from named.conf:

Code:
zone "wes.internal" {
     type master;
     file "master/wes.internal";
};

zone "1.168.192.in-addr.arpa" {
     type master;
     file "master/1.168.192.in-addr.arpa";
Here is the contents of my forward zone:

Code:
$TTL 1h
@ IN SOA starburst.wes.internal. hostmaster.wes.internal. (
                       20080707 ; Serial
                       1d       ; Refresh
                       2h       ; Retry
                       1000h    ; Expire
                       2d       ; Minimum
                     )

IN  NS  starburst.wes.internal.

localhost IN   A   127.0.0.1
starburst IN   A   192.168.1.1
Here are the contents of my reverse zone:

Code:
$TTL 1h
@ IN SOA starburst.wes.internal. hostmaster.wes.internal. (
                       20080707 ; Serial
                       1d       ; Refresh
                       2h       ; Retry
                       1000h    ; Expire
                       2d       ; Minimum
                     )

IN   NS  starburst.wes.internal.

1    IN   PTR   starburst.wes.internal.
The problem I have is that when named starts it prints the following error message to the console:

Code:
starburst named[752]: zone 1.168.192.in-addr.arpa/IN: has no NS records
starburst named[752]: zone wes.internal/IN: has no NS records
I don't understand why this is as I've defined the NS records in the zone files, can anyone help?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot problem. Geometry problem? gulanito FreeBSD Installation and Upgrading 0 3rd July 2009 03:03 AM
Lost FreeBSD boot record (when installing Ubuntu) TomAmundsen FreeBSD General 6 19th January 2009 09:41 PM
Sun Java System Web Server - Active Server Pages (yes ASP) hopla FreeBSD General 0 26th September 2008 08:22 AM


All times are GMT. The time now is 11:11 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick