DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 11th June 2008
Damien787's Avatar
Damien787 Damien787 is offline
Real Name: Endymion Seiler
Port Guard
 
Join Date: May 2008
Location: Passumpsic, VT
Posts: 22
Thanked 0 Times in 0 Posts
Default How come gnome2 won't compile?

/usr/ports/x11/gnome2 (the evolution data server part) gets stuck on libcamel...says it needs v. 2 or something?


What's up with that? :-)


I'm using FreeBSD 6.3 with a very recent ports tree snapshot.


--Damien
Reply With Quote
  #2   (View Single Post)  
Old 11th June 2008
ninjatux's Avatar
ninjatux ninjatux is offline
Real Name: Baqir Majlisi
Spam Deminer
 
Join Date: May 2008
Location: Antarctica
Posts: 293
Thanked 15 Times in 15 Posts
Default

You need to give more information than that.
__________________
"UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity."
MacBook Pro (Darwin 9), iMac (Darwin 9), iPod Touch (Darwin 9), Dell Optiplex GX620 (FreeBSD 7.1-STABLE)
Reply With Quote
  #3   (View Single Post)  
Old 11th June 2008
Nirbo Nirbo is offline
Real Name: Nicholas Kirby
Fdisk Soldier
 
Join Date: May 2008
Location: Edmonton, Alberta, Canada
Posts: 68
Thanked 11 Times in 9 Posts
Default

A copy of the actual error would rock. Also perhaps try adding said dependency quickly as a package? (or make sure it exists in your distfiles if the machine is offline)
Reply With Quote
  #4   (View Single Post)  
Old 11th June 2008
coppermine's Avatar
coppermine coppermine is offline
Port Guard
 
Join Date: May 2008
Posts: 40
Thanked 0 Times in 0 Posts
Default

Then narrow down the problem to this camel
Delete it, update ports tree, compile and post the results here.
Reply With Quote
  #5   (View Single Post)  
Old 11th June 2008
Damien787's Avatar
Damien787 Damien787 is offline
Real Name: Endymion Seiler
Port Guard
 
Join Date: May 2008
Location: Passumpsic, VT
Posts: 22
Thanked 0 Times in 0 Posts
Default

Well....the error message is printed below. happens during 'configure' for evolution-exchange.

----begin quoted text
checking for GNOME_PLATFORM... configure: error: Package requirements (glib-2.0 >= 2.15.3
gtk+-2.0 >= 2.10.0
camel-1.2 >= 2.21.90
gconf-2.0 >= 2.0.0
libbonobo-2.0 >= 2.20.3
libglade-2.0 >= 2.0.0
libgnomeui-2.0 >= 2.0.0
libxml-2.0 >= 2.0.0
libsoup-2.4 >= 2.3.0) were not met:

Requested 'camel-1.2 >= 2.21.90' but version of camel is 1.12.1
----end
Reply With Quote
  #6   (View Single Post)  
Old 11th June 2008
lvlamb's Avatar
lvlamb lvlamb is offline
Real Name: Louis V. Lambrecht
Spam Deminer
 
Join Date: May 2008
Location: .be
Posts: 221
Thanked 25 Times in 24 Posts
Default

With gnome 2.22, evolution exchange and dataserver had a major version bump, 2.12 > 2.22
This was my first break,
then

Read UPDATING, or
http://www.freshports.org/devel/gettext/
Quote:
2008-06-05

Affects: users of devel/gettext (ie: YOU)

Author: ade@FreeBSD.org

Reason:
As a result of the upgrade to gettext-0.17, the shared library version
of libintl has changed, so you will need to rebuild all ports that
depend on gettext:

# portupgrade -rf gettext
# portmaster -r gettext\*

Given the scope and sheer number of dependent ports, it may be more
advisable to simply blow away all existing install ports (after
keeping any local configuration changes), and rebuilding from scratch.
In many cases, best upgrade is newfs.
I had a similar problem also on OpenBSD with a snapshots and -current upgrade as of June 8. There I could delete the offending packages and had to add some symlinks.
On FreeBSD, best is as advised.
On OpenBSD, http://undeadly.org/cgi?action=artic...panded&count=1
newbiesm stay away from -current.
__________________
da more I know I know I know nuttin'
Reply With Quote
  #7   (View Single Post)  
Old 13th June 2008
Damien787's Avatar
Damien787 Damien787 is offline
Real Name: Endymion Seiler
Port Guard
 
Join Date: May 2008
Location: Passumpsic, VT
Posts: 22
Thanked 0 Times in 0 Posts
Default

good god! it's going to take my 800mHz PIII a few days to compile all that!
Reply With Quote
  #8   (View Single Post)  
Old 13th June 2008
cajunman4life cajunman4life is offline
Real Name: Aaron Graves
Package Pilot
 
Join Date: May 2008
Location: Coolidge, Arizona
Posts: 203
Thanked 16 Times in 14 Posts
Default

Nah, took my 500MHz PIII less than an hour to rebuild all those. And I had to do it for each jail that was running on the system also after the main system.
__________________
I just saved a bunch of money on my car insurance by fleeing the scene of the accident!
Reply With Quote
  #9   (View Single Post)  
Old 13th June 2008
Damien787's Avatar
Damien787 Damien787 is offline
Real Name: Endymion Seiler
Port Guard
 
Join Date: May 2008
Location: Passumpsic, VT
Posts: 22
Thanked 0 Times in 0 Posts
Default

well...my system has over 300 dependent packages..including GNOME and KDE
Reply With Quote
Old 16th June 2008
Errinok Errinok is offline
Port Guard
 
Join Date: Jun 2008
Posts: 14
Thanked 0 Times in 0 Posts
Default

sounds like you just need to build the packages that are giving your errors to a newer/newest version.
Reply With Quote
Old 16th June 2008
Damien787's Avatar
Damien787 Damien787 is offline
Real Name: Endymion Seiler
Port Guard
 
Join Date: May 2008
Location: Passumpsic, VT
Posts: 22
Thanked 0 Times in 0 Posts
Default

yes...but there is no package named 'libcamel' in the ports tree.


Damien
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't compile gcc-4.3.3_20090101 troberts FreeBSD Ports and Packages 7 12th January 2009 10:30 PM
firefox3 will not compile map7 FreeBSD Ports and Packages 8 14th July 2008 11:23 PM
gio-fam-backend will not compile map7 FreeBSD Ports and Packages 0 2nd July 2008 01:59 AM
Why wont this compile? Johnny2Bad FreeBSD General 10 19th May 2008 11:30 PM
Is something broken in BSD-Gnome2 rex FreeBSD General 13 8th May 2008 02:17 PM


All times are GMT. The time now is 11:39 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick