DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 14th June 2008
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 577
Thanked 9 Times in 9 Posts
Default Permanently Change Default sound device.

New FreeBSD 7 Amd64 install with an AMD SB600 Southbridge.

pciconf shows:
Code:
pcm1@pci0:0:20:2:	class=0x040300 card=0x10131019 chip=0x43831002 rev=0x00 hdr=0x00
    vendor     = 'ATI Technologies Inc'
    device     = 'IXP SB600 High Definition Audio Controller'
    class      = multimedia
Portions of dmesg"
Code:
pcm1: <ATI SB600 High Definition Audio Controller> mem 0xfe8f4000-0xfe8f7fff irq 16 at device 20.2 on pci0
pcm1: [ITHREAD]
Code:
acd0: DVDR <LITE-ON DVDRW LH-20A1S/9L03> at ata5-master SATA150
pcm0: <HDA Codec: Unknown Codec>
pcm0: <HDA Driver Revision: 20071129_0050>
pcm1: <HDA Codec: Realtek ALC883>
pcm1: <HDA Driver Revision: 20071129_0050>
SMP: AP CPU #1 Launched!
The default sound device is /dev/dsp which points to
Code:
$ sysctl hw.snd.default_unit
hw.snd.default_unit: 0
If I change hw.snd.default_unit to 1 all is good but I lose the change on the
next boot. How do I make this change permanent? ?/boot/device.hints?

Thanks in advance
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Recording sound with external sound card backrow OpenBSD General 5 21st August 2009 08:17 PM
How do I edit my .profile to permanently have an ftp site to point to badguy OpenBSD Packages and Ports 12 19th July 2009 02:05 AM
change default font of the X rex FreeBSD General 2 26th October 2008 05:54 PM
identifying device associated with USB device? spiderpig OpenBSD General 2 7th July 2008 05:18 AM
VIA sound device fails on boot, works with kldload robbak FreeBSD General 0 16th June 2008 07:16 AM


All times are GMT. The time now is 11:57 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick