DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Installation and Upgrading

FreeBSD Installation and Upgrading Installing and upgrading FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 24th June 2008
mona mona is offline
New User
 
Join Date: Jun 2008
Posts: 2
Thanked 0 Times in 0 Posts
Default Intel ATOM D945GCLF onboard LAN driver-card problem

I recently purchased Intel ATOM D945GCLF mini ITX board (excelent router in my opininon). I put another PIC 10/100 MB Level one network card. When I try to install Freebsd 6.x or 7.0 only one card-PCI card is detected, onboard not. Onboard card is 10/100 Mbits/sec LAN subsystem using the Realtek* LAN adapter device.

How to fix this problem? Huh

Any help is much apreciated.


here is dmesg:

Copyright (c) 1992-2008 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.3-RELEASE #0: Wed Jan 16 04:45:45 UTC 2008
root@dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/SMP
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Atom(TM) CPU 230 @ 1.60GHz (1599.32-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0x106c2 Stepping = 2
Features=0xbfe9fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE ,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CLFLUSH,DTS,AC PI,MMX,FXSR,SSE,SSE2 ,SS,HTT,TM,PBE>
Features2=0x40e31d<SSE3,RSVD2,MON,DS_CPL,TM2,SSSE3 ,CX16,xTPR,PDCM,<b22>>
AMD Features=0x20100000<NX,LM>
AMD Features2=0x1<LAHF>
Logical CPUs per core: 2
real memory = 1063649280 (1014 MB)
avail memory = 1027358720 (979 MB)
ACPI APIC Table: <INTEL D945GLF >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
cpu0 (BSP): APIC ID: 0
cpu1 (AP): APIC ID: 1
ioapic0: Changing APIC ID to 2
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
hptrr: HPT RocketRAID controller driver v1.1 (Jan 16 2008 04:43:12)
acpi0: <INTEL D945GLF> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
acpi_button0: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <Intel 82945G (945G GMCH) SVGA controller> port 0x30e0-0x30e7 mem 0x50300000-0x5037ffff,0x40000000-0x4fffffff,0x50380000-0x503bffff irq 16 at device 2.0 on pci0
agp0: detected 7932k stolen memory
agp0: aperture size is 256M
pcib1: <ACPI PCI-PCI bridge> at device 28.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <network, ethernet> at device 0.0 (no driver attached)
pcib2: <ACPI PCI-PCI bridge> at device 28.2 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 28.3 on pci0
pci3: <ACPI PCI bus> on pcib3
uhci0: <UHCI (generic) USB controller> port 0x3080-0x309f irq 23 at device 29.0 on pci0
uhci0: [GIANT-LOCKED]
usb0: <UHCI (generic) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <UHCI (generic) USB controller> port 0x3060-0x307f irq 19 at device 29.1 on pci0
uhci1: [GIANT-LOCKED]
usb1: <UHCI (generic) USB controller> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <UHCI (generic) USB controller> port 0x3040-0x305f irq 18 at device 29.2 on pci0
uhci2: [GIANT-LOCKED]
usb2: <UHCI (generic) USB controller> on uhci2
usb2: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3: <UHCI (generic) USB controller> port 0x3020-0x303f irq 16 at device 29.3 on pci0
uhci3: [GIANT-LOCKED]
usb3: <UHCI (generic) USB controller> on uhci3
usb3: USB revision 1.0
uhub3: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0: <Intel 82801GB/R (ICH7) USB 2.0 controller> mem 0x503c0000-0x503c03ff irq 23 at device 29.7 on pci0
ehci0: [GIANT-LOCKED]
usb4: EHCI version 1.0
usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
usb4: <Intel 82801GB/R (ICH7) USB 2.0 controller> on ehci0
usb4: USB revision 2.0
uhub4: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
pcib4: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci4: <ACPI PCI bus> on pcib4
rl0: <RealTek 8139 10/100BaseTX> port 0x1000-0x10ff mem 0x50100000-0x501000ff irq 21 at device 0.0 on pci4
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> on miibus0
rlphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl0: Ethernet address: 00:11:6b:95:f9:d7
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH7 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x30b0-0x30bf irq 18 at device 31.1 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
atapci1: <Intel ICH7 SATA300 controller> port 0x30c8-0x30cf,0x30ec-0x30ef,0x30c0-0x30c7,0x30e8-0x30eb,0x30a0-0x30af irq 19 at device 31.2 on pci0
ata2: <ATA channel 0> on atapci1
ata3: <ATA channel 1> on atapci1
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model IntelliMouse, device ID 3
pmtimer0 on isa0
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250 or not responding
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
umass0: Generic USB Flash Disk, rev 1.10/1.00, addr 2
Timecounters tick every 1.000 msec
hptrr: no controller detected.
ad0: FAILURE - SET_MULTI status=51<READY,DSC,ERROR> error=4<ABORTED>
ad0: 499MB <InnoDisk Corp. - EDC4000 512MB 06/05/18> at ata0-master UDMA66
da0 at umass-sim0 bus 0 target 0 lun 0
da0: <Generic USB Flash Disk 2.01> Removable Direct Access SCSI-2 device
da0: 1.000MB/s transfers
da0: 127MB (260288 512 byte sectors: 64H 32S/T 127C)
acd0: DVDROM <TSSTcorpDVD-ROM SH-D163B/SB01> at ata3-master SATA150
SMP: AP CPU #1 Launched!
Trying to mount root from ufs:/dev/ad0s1a

and pciconf -lv

hostb0@pci0:0:0: class=0x060000 card=0x464c8086 chip=0x27708086 rev=0x02 hdr=0x00
vendor = 'Intel Corporation'
device = '82945G/GZ/P/PL Host Bridge/DRAM Controller'
class = bridge
subclass = HOST-PCI
agp0@pci0:2:0: class=0x030000 card=0x464c8086 chip=0x27728086 rev=0x02 hdr=0x00
vendor = 'Intel Corporation'
device = '82945G Integrated Graphics Controller'
class = display
subclass = VGA
pcib1@pci0:28:0: class=0x060400 card=0x00000000 chip=0x27d08086 rev=0x01 hdr=0x01
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) PCIe Root Port'
class = bridge
subclass = PCI-PCI
pcib2@pci0:28:2: class=0x060400 card=0x00000000 chip=0x27d48086 rev=0x01 hdr=0x01
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) PCIe Root Port'
class = bridge
subclass = PCI-PCI
pcib3@pci0:28:3: class=0x060400 card=0x00000000 chip=0x27d68086 rev=0x01 hdr=0x01
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) PCIe Root Port'
class = bridge
subclass = PCI-PCI
uhci0@pci0:29:0: class=0x0c0300 card=0x464c8086 chip=0x27c88086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) USB Universal Host Controller'
class = serial bus
subclass = USB
uhci1@pci0:29:1: class=0x0c0300 card=0x464c8086 chip=0x27c98086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) USB Universal Host Controller'
class = serial bus
subclass = USB
uhci2@pci0:29:2: class=0x0c0300 card=0x464c8086 chip=0x27ca8086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) USB Universal Host Controller'
class = serial bus
subclass = USB
uhci3@pci0:29:3: class=0x0c0300 card=0x464c8086 chip=0x27cb8086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) USB Universal Host Controller'
class = serial bus
subclass = USB
ehci0@pci0:29:7: class=0x0c0320 card=0x464c8086 chip=0x27cc8086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) USB 2.0 Enhanced Host Controller'
class = serial bus
subclass = USB
pcib4@pci0:30:0: class=0x060401 card=0x464c8086 chip=0x244e8086 rev=0xe1 hdr=0x01
vendor = 'Intel Corporation'
device = '82801 Family (ICH2/3/4/4/5/5/6/7/8/9,63xxESB) Hub Interface to PCI Bridge'
class = bridge
subclass = PCI-PCI
isab0@pci0:31:0: class=0x060100 card=0x464c8086 chip=0x27b88086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '945GL Intel 82801GB/GR (ICH7 Family) LPC Interface Controller - 27B8'
class = bridge
subclass = PCI-ISA
atapci0@pci0:31:1: class=0x01018a card=0x464c8086 chip=0x27df8086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) Ultra ATA Storage Controller'
class = mass storage
subclass = ATA
atapci1@pci0:31:2: class=0x01018f card=0x464c8086 chip=0x27c08086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller'
class = mass storage
subclass = ATA
none0@pci0:31:3: class=0x0c0500 card=0x464c8086 chip=0x27da8086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) SMBus Controller'
class = serial bus
subclass = SMBus
none1@pci1:0:0: class=0x020000 card=0x00018086 chip=0x813610ec rev=0x02 hdr=0x00
vendor = 'Realtek Semiconductor'
device = 'RTL8139/810x Family Fast Ethernet NIC'
class = network
subclass = ethernet
rl0@pci4:0:0: class=0x020000 card=0x813910ec chip=0x813910ec rev=0x10 hdr=0x00
vendor = 'Realtek Semiconductor'
device = 'RT8139 (A/B/C/810x/813x/C+) Fast Ethernet Adapter'
class = network
subclass = ethernet

any help is really apreciated

onboard card works in Puppy linux ...????

Regards



Regards
Reply With Quote
  #2   (View Single Post)  
Old 25th June 2008
phoenix's Avatar
phoenix phoenix is offline
Risen from the ashes
 
Join Date: May 2008
Posts: 699
Thanked 90 Times in 81 Posts
Default

That chipset (RealTek 81xx) should be supported by the re(4) driver. However, you may need to upgrade to FreeBSD 7.0 to pick up all the changes and updates to that driver that happened between 6.3 and 7.0.
__________________
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
Reply With Quote
  #3   (View Single Post)  
Old 25th June 2008
mona mona is offline
New User
 
Join Date: Jun 2008
Posts: 2
Thanked 0 Times in 0 Posts
Default

phoenix: thank you for replay. I tried installing Freebsd 7.0 but nic does not work... (I suspect intel made revision to the chip and this driver does not work..) I runned dmesg on that system.This is onboard lan and I dont have place for another PCI lan card... so I have big problem... Any thoughts about aonother solution?

Regards
Reply With Quote
  #4   (View Single Post)  
Old 25th June 2008
phoenix's Avatar
phoenix phoenix is offline
Risen from the ashes
 
Join Date: May 2008
Posts: 699
Thanked 90 Times in 81 Posts
Default

Purchase a dual-port or quad-port PCI/PCI-X/PCIe (whichever slot you have) NIC. Intel makes some very nice dual-port and quad-port gigabit NICs, that come in low-profile form-factors, so they'll fit in half-height slots. These all use the em(4) driver.

You could also try installing a FreeBSD 7-STABLE snapshot to see if that will detect that the onboard RealTek chipset.

Check through the BIOS and see what options there are for the onboard NIC and toggle them to see if that makes a difference. With the nVidia chipsets, the onboard NIC comes with options to change how it appears (MII or Pin-Strap) that changes how the FreeBSD kernel detects it. Maybe there's something like that on this board.
__________________
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
Reply With Quote
  #5   (View Single Post)  
Old 16th July 2008
Darwimy Darwimy is offline
Port Guard
 
Join Date: Jun 2008
Location: Germany
Posts: 36
Thanked 2 Times in 2 Posts
Default

Support for Realtek 8102EL NIC has been committed to FreeBSD 7 a few days ago. You can try to upgrade your system to RELENG_7 and try it.
Reply With Quote
  #6   (View Single Post)  
Old 17th July 2008
tuck's Avatar
tuck tuck is offline
Shell Scout
 
Join Date: May 2008
Posts: 99
Thanked 14 Times in 6 Posts
Default

If it doesn't work with RELENG_7 try to use the newest
sys/dev/re/if_re.c and sys/pci/if_rlreg.h from HEAD.
The maintainer of the Realtek driver is pretty active
working on it.
Reply With Quote
  #7   (View Single Post)  
Old 12th December 2008
megahead13 megahead13 is offline
New User
 
Join Date: Jul 2008
Posts: 2
Thanked 0 Times in 0 Posts
Default

Hi to all! Has the driver for RTL8102 been submited to FreeBSD RC1? I don't see anything being mentioned here: ftp://ftp.freebsd.org/pub/FreeBSD/re...1/RELNOTES.HTM
Reply With Quote
  #8   (View Single Post)  
Old 17th December 2008
megahead13 megahead13 is offline
New User
 
Join Date: Jul 2008
Posts: 2
Thanked 0 Times in 0 Posts
Default

Just some feedback: I 've installed FreeBSD 7.1 RC1 amd64 and at the moment everything works as expected. Now I am starting to setup my services (apache, postfix+dovecot, nfs, etc)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HOWTO: Working Intel Graphics Card Setup vermaden FreeBSD Installation and Upgrading 2 3rd July 2009 07:59 PM
How to investigate non-working onboard lan? hansivers FreeBSD Installation and Upgrading 10 28th June 2009 11:28 PM
Problems with 1000baseTX on Intel Pro 1000 desktop PCI card [FreeBSD 7.0 RELEASE] asmo FreeBSD General 0 28th June 2008 07:12 PM
Intel 4965AGN WiFi card (802.11n) nonhuman FreeBSD General 5 25th May 2008 04:18 PM
driver for intel HECI controller? edhunter FreeBSD General 3 2nd May 2008 09:02 AM


All times are GMT. The time now is 05:29 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick