DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 1st July 2008
lumiwa lumiwa is offline
Package Pilot
 
Join Date: May 2008
Posts: 145
Thanked 4 Times in 3 Posts
Default diablo15 - JDK16

Hi!

I installed JDK16 and it installed diablo-1.5.0. Is it safe that uninstalled diablo or should be there anyway, please?
Java version shows:
java -version
java version "1.5.0"
Java(TM) 2 Runtime Environment, Standard Edition (build diablo-1.5.0-b01)
Java HotSpot(TM) Client VM (build diablo-1.5.0_07-b01, mixed mode)

Firefox shows:
Java(TM) Plug-in 1.6.0_03-p4-b00

File name: libjavaplugin_oji.so
Java(TM) Plug-in 1.6.0_03

because I made link to Java 1.6.

Thnaks.
Reply With Quote
  #2   (View Single Post)  
Old 1st July 2008
ninjatux's Avatar
ninjatux ninjatux is offline
Real Name: Baqir Majlisi
Spam Deminer
 
Join Date: May 2008
Location: Antarctica
Posts: 293
Thanked 15 Times in 15 Posts
Default

Leave it there, but set your JAVA_HOME variable to 1.6.
__________________
"UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity."
MacBook Pro (Darwin 9), iMac (Darwin 9), iPod Touch (Darwin 9), Dell Optiplex GX620 (FreeBSD 7.1-STABLE)
Reply With Quote
  #3   (View Single Post)  
Old 2nd July 2008
lumiwa lumiwa is offline
Package Pilot
 
Join Date: May 2008
Posts: 145
Thanked 4 Times in 3 Posts
Default

Quote:
Originally Posted by ninjatux View Post
Leave it there, but set your JAVA_HOME variable to 1.6.
Thank you but why I need to have it?
Reply With Quote
  #4   (View Single Post)  
Old 2nd July 2008
ddekok ddekok is offline
Port Guard
 
Join Date: May 2008
Posts: 38
Thanked 4 Times in 3 Posts
Default

diablo 1.5 is used during the build process of jdk 1.6. It isn't a run time dependency and is safe to remove. However, if you upgrade jdk 1.6 in the future, it may try to rebuild diablo as a dependency.
Reply With Quote
  #5   (View Single Post)  
Old 2nd July 2008
lumiwa lumiwa is offline
Package Pilot
 
Join Date: May 2008
Posts: 145
Thanked 4 Times in 3 Posts
Default

Quote:
Originally Posted by ddekok View Post
diablo 1.5 is used during the build process of jdk 1.6. It isn't a run time dependency and is safe to remove. However, if you upgrade jdk 1.6 in the future, it may try to rebuild diablo as a dependency.
Thank you. I deinstalled and it works as before .
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
difference between jdk16 and diablo 1.6 cuongvt FreeBSD Ports and Packages 8 16th October 2008 12:17 AM
JDK16 installation on FreeBSD 7 fronty FreeBSD Ports and Packages 6 8th July 2008 03:49 AM
jdk16 disappearedng FreeBSD General 7 5th July 2008 04:16 AM
Problem instaling java (jdk16) mrbungle FreeBSD Ports and Packages 3 26th June 2008 05:45 PM
install jdk16 on freeBSD 7.0 ccc FreeBSD Ports and Packages 4 16th June 2008 10:48 PM


All times are GMT. The time now is 03:23 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick