DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 7th July 2008
ronaldmcdonald9 ronaldmcdonald9 is offline
New User
 
Join Date: Jul 2008
Posts: 6
Thanked 0 Times in 0 Posts
Post USB wireless network adapter, ndis problem

Hi. I have the D-Link DWL-G122 Rev. A2 USB wireless network adapter (the one not supported by FreeBSD 7), so I am trying to get it to work with ndis. I run
Code:
ndisgen PRISMA02.inf PRISMA02.sys
where PRISMA02.* are the Windows XP drivers for this USB wireless network adapter. This part works fine, and I get the PRISMA02_sys.ko file. I am able to load it with
Code:
kldload PRISMA02_sys.ko
and I have also copied it to /boot/modules and edited /boot/loader.conf to load it on boot. Everything up to this point works fine. But after PRISMA02_sys.ko, if_ndis.ko and ndis.ko are loaded, I am not able to use the ndis0 device, that is, when I run
Code:
ifconfig ndis0
it tells me that the device cannot be found. I've looked at the handbook, and also searched for solutions to similar problems, but everything I find on this issue is like 4 years old and says that USB is not yet supported by ndis. I'm not sure if it is, but I looked at the FreeBSD CVS repository and it does look like USB support has been implemented. Obviously I am doing something wrong or missing something, but I am not sure what it is. Please let me know if you have any ideas. Thanks.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless Network Loses Connection JMJ_coder NetBSD General 5 17th February 2009 09:14 PM
Nvidia nForce MCP77 network adapter issue padmanabh FreeBSD Installation and Upgrading 5 17th January 2009 12:18 PM
Wireless Network Problem fuma218 NetBSD General 8 8th January 2009 12:00 AM
Wireless Network Config working -- almost JMJ_coder General software and network 4 20th November 2008 05:10 PM
Wireless + wired = confused network setup davidgurvich FreeBSD General 3 27th May 2008 06:10 PM


All times are GMT. The time now is 01:29 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick