DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 8th July 2008
master-richie master-richie is offline
New User
 
Join Date: Jul 2008
Posts: 7
Thanked 0 Times in 0 Posts
Default Tightvnc startup script not loading fonts - permission denied

am currently using the following script (usr/local/etc/rc.d/vncserver.sh) I found somewhere on the web and modified (reduction) but still can't get vncserver to load on boot. it looks like it would work but it kicks out errors loading the default fonts - the fonts folders exist.

I applied chmod 755 to vncserver.sh and set vnc_enable="YES" in rc.conf

#!/bin/sh
#
# This script starts vncserver
#

. /etc/rc.subr

name="vnc"

vncserver_display=":1"
vncserver_options="-geometry 800x600 -compatiblekbd -fp '/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/'"

rcvar=`set_rcvar`
start_cmd="${name}_start"
stop_cmd=":"

load_rc_config $name
eval "${rcvar}=\${${rcvar}:-'NO'}"
vnc_msg=${vnc_msg:-"Starting vncserver..."}

vnc_start()
{
echo "$vnc_msg"
PATH=/usr/X11R6/bin:/usr/local/bin:$PATH
su [my user name in wheel group] -c "/usr/X11R6/bin/vncserver ${vncserver_display} ${vncserver_options}\
"
}

run_rc_command "$1"


have tried googling the error, changing single quotes to double quotes in my options string and manually typing the options on my su line - no luck.

am reaching out again for help .. once I can get vncserver loading during boot, I can install the server and will have all the time in the world to figure out the rest for myself. thanks in advance, ~Rich
Reply With Quote
  #2   (View Single Post)  
Old 8th July 2008
master-richie master-richie is offline
New User
 
Join Date: Jul 2008
Posts: 7
Thanked 0 Times in 0 Posts
Default reinstalled the xorg fonts

someone had mentioned that if the fonts are out of date, it will give you that same message.

I did a "make deinstall" & "make reinstall" in the xorg-fonts/xxx folders to update the fonts packages and still the same problem.

Other forums people have surmised a bug in the tightvnc port - any ideas? ~Rich
Reply With Quote
  #3   (View Single Post)  
Old 3rd August 2008
master-richie master-richie is offline
New User
 
Join Date: Jul 2008
Posts: 7
Thanked 0 Times in 0 Posts
Default

SOLVED!!! didn't have sudo installed. doh!

installed sudo, then made sure my window manager was called in the /home/~/.vnc/xstartup file and I was rockin and rollin!

good luck to everyone else trying this ... ~Rich
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rc.d startup script problem Xtender FreeBSD General 9 17th October 2008 06:00 PM
Permission denied (publickey). Help pls rex FreeBSD General 13 14th October 2008 08:54 PM
link_elf error while loading gspca.ko kasse FreeBSD General 3 11th September 2008 08:22 AM
FreeBSD 7.0, tightvnc and jdk16 - newbie master-richie FreeBSD Ports and Packages 5 9th July 2008 04:45 PM
Permission denied delboy FreeBSD Ports and Packages 11 24th May 2008 09:26 PM


All times are GMT. The time now is 10:46 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick