DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD General

NetBSD General Other questions regarding NetBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 27th August 2014
spermwhale_warrior spermwhale_warrior is offline
Port Guard
 
Join Date: May 2013
Posts: 45
Thanked 0 Times in 0 Posts
Exclamation xorg failed to run

Here is the report. I use the latest modular-xorg from the binaries. How could I know the package an executable like ' X ' does belong to ? And ask the details of an already installed package ?
Here is /var/Xorg.0.log : https://drive.google.com/file/d/0B-_...it?usp=sharing

1 X.Org X Server 1.10.3
2 Release Date: 2011-07-08
3 X Protocol Version 11, Revision 0
4 Build Operating System: NetBSD/amd64 -
5 Current Operating System: NetBSD saada.mehdi 6.1.4 NetBSD 6.1.4 (GENERIC) amd64
6 Build Date: 01 August 2011 01:01:00AM

7 Current version of pixman: 0.23.2
8 Before reporting problems, check http://wiki.X.Org
9 to make sure that you have the latest version.
10 Markers: (--) probed, (**) from config file, (==) default setting,
11 (++) from command line, (!!) notice, (II) informational,
12 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
13 ==) Log file: "/var/log/Xorg.0.log", Time: Wed Aug 27 23:57:42 2014
14 (==) Using default built-in configuration (12 lines)
15 Using rom_base = 0xc0000 0x10000 (pci_rom=0)
16 (EE) AIGLX error: i915 does not export required DRI extension
17 (EE) AIGLX: reverting to software rendering
18 [mi] EQ overflowing. The server is probably stuck in an infinite loop.

Last edited by spermwhale_warrior; 28th August 2014 at 10:39 AM. Reason: add numerotation for better reference
Reply With Quote
  #2   (View Single Post)  
Old 28th August 2014
spermwhale_warrior spermwhale_warrior is offline
Port Guard
 
Join Date: May 2013
Posts: 45
Thanked 0 Times in 0 Posts
Default

Tested once again, it said between line 15 and 16 : xf86TokenToOptinfo: Table is NULL
voilà le log d'erreurs de startx :
WARNING: can't open config file: /etc/openssl/openssl.cnf
xauth: file /root/.serverauth.733 does not exist
xauth: file /root/.Xauthority does not exist
xauth: (argv):1: bad display name "saada.mehdi:0" in "list" command
xauth: (stdin):1: bad display name "saada.mehdi:0" in "add" command
/usr/pkg/bin/xinit: unable to run server "/usr/pkg/bin/X": No such file or directory [...]
/usr/pkg/bin/xinit: giving up
/usr/pkg/bin/xinit: unable to connect to X server: Connection refused
/usr/pkg/bin/xinit: server error
xauth: (argv):1: bad display name "saada.mehdi:0" in "remove" command.

Last edited by spermwhale_warrior; 28th August 2014 at 02:14 PM.
Reply With Quote
  #3   (View Single Post)  
Old 28th August 2014
DaBSD DaBSD is offline
Fdisk Soldier
 
Join Date: Jan 2013
Posts: 46
Thanked 0 Times in 0 Posts
Default

Before running X server, ensure you have the line "dbus=YES" in /etc/rc.conf and try the following commands as a root:

mkdir /var/run/dbus
/usr/pkg/bin/dbus-daemon --system
Reply With Quote
  #4   (View Single Post)  
Old 29th August 2014
spermwhale_warrior spermwhale_warrior is offline
Port Guard
 
Join Date: May 2013
Posts: 45
Thanked 0 Times in 0 Posts
Default

it's done. to be sure, I compile modular-xorg. It did well, but it can't yet works.
xdm runs, but it refuses to let me log in with a regular user. Need I at that new user to some "x11" group ? this new user come by "useradd mehdi" so I don't know what kind of programs, like xdm, it can run. Please say me what to do run finaly, X with a decent desktop. I post too something about light-desktop not being fetched.
X can't run through '/usr/pkg/bin/X'.
/var/Xorg.conf.log :
(WW) The directory "/usr/pkg/share/fonts/X11/OTF" does not exist.
Entry deleted from font path. (WW) `fonts.dir' not found (or not valid) in "/usr/pkg/share/fonts/X11/cyrillic". Entry deleted from font path.
(Run 'mkfontdir' on "/usr/pkg/share/fonts/X11/cyrillic").

Lots of such directory are said to lack.
(**) FontPath set to: /usr/pkg/share/fonts/X11/{name_of_the_font}
(EE) LoadModule: Module fbdevhw does not have a fbdevhwModuleData data object.
(EE) Failed to load module "fbdevhw" (invalid module, 0)
Number of created screens does not match number of detected devices. Configuration failed.
Server terminated with error (2). Closing log file.
Reply With Quote
  #5   (View Single Post)  
Old 30th August 2014
spermwhale_warrior spermwhale_warrior is offline
Port Guard
 
Join Date: May 2013
Posts: 45
Thanked 0 Times in 0 Posts
Default

I identified the problem, though I don't know how to solve it.
I found that is interesting :
drmOpenByBusid: Interface 1.4 failed, trying 1.1
[drm] removed 1 reserved context for kernel
drmDropMaster failed: Unknown error: 4294977295
Intel(0): [drm] Closed DRM master

I think, that the driver used for my graphical card is i915drm0, and it interrupts several times at ioapic0 pin 16.
What
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg.conf doesn't exist & I want to keep record of my working Xorg setting daemonfowl OpenBSD General 14 28th August 2012 01:13 AM
Uncompress failed. delboy FreeBSD Ports and Packages 2 9th February 2010 12:58 PM
Ok, i've tried but failed. Damn birdmansdomain OpenBSD Security 28 23rd July 2009 07:50 AM
Communication with su failed amandus OpenBSD Packages and Ports 7 17th July 2008 07:17 AM
Failed Installs dctr OpenBSD Installation and Upgrading 23 4th June 2008 04:25 AM


All times are GMT. The time now is 05:59 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick