DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 23rd February 2018
jmar83 jmar83 is offline
jmar83
 
Join Date: Feb 2018
Posts: 17
Default Install GNOME on OpenBSD 6.2 on a Sun Ultra 45 (Sparc) Workstation?

Hi there!

The base package from http://mirror.switch.ch/ftp/pub/Open.../install62.iso was installed successful with a DVD, then i tried to install the gnome packge:

Code:
export PKG_PATH=http://mirror.switch.ch/ftp/pub/OpenBSD/6.2/packages/sparc64/

pkg_add -v gnome
pkg_add -v gnome-extras

In /etc/rc.conf make sure You have this:
pkg_scripts=dbus_daemon

Edit /root/.xinitrc
And add the line:
exec gnome-session
reboot

startx
(https://www.administrator.de/forum/g...en-254574.html )

-> there was serveral warnings on both packages "gnome" and "gnome-extras", e.g. "can't resolve yelp-3.22.0p3" was the first one... But so it seems there was just some warnings, but no errors - there are no dependency problems because of that..?? Maybe the source is errorful? -> http://mirror.switch.ch/ftp/pub/OpenBSD/6.2/sparc64/ ???

The only one "yelp" thing i see is that, in another (smaller) version that 3.22.0p3: http://mirror.switch.ch/ftp/pub/Open...ols-3.18.0.tgz

And Google shows exactly 1 result for that message: https://www.google.ch/search?q=%22ca...hrome&ie=UTF-8 - really strange!!

After reboot, when i enter "startx", i get the following messages:


"xauth: (stdin):1: bad display name “ultra45.my.domain:0” in “add” command. "

and

"xauth: (argv):1: bad display name “ultra45.my.domain:0” in “remove” command. "


/etc/rc.conf contains:

Code:
Last login: Fri Feb 23 03:32:28 2018
OpenBSD 6.2 (GENERIC.MP) #303: Tue Oct  3 22:46:49 MDT 2017

Welcome to OpenBSD: The proactively secure Unix-like operating system.

Please use the sendbug(1) utility to report bugs in the system.
Before reporting a bug, please try to reproduce it with the latest
version of the code.  With bug reports, please try to ensure that
enough information to reproduce the problem is enclosed, and if a
known fix for it exists, include that as well.

# more /etc/rc.conf
#       $OpenBSD: rc.conf,v 1.216 2017/05/30 12:04:26 tb Exp $

# DO NOT EDIT THIS FILE!!
#
# This file defines the default service selection as shipped in a
# release.  Upgrades of your system will modify this file.
#
# To select the service options you desire, please override these
# options in the file /etc/rc.conf.local
#
# DO NOT EDIT THIS FILE!!

# Set these variables to "NO" to turn the respective service off.
# Set them to "" to run them with the default flags.
# Otherwise, these variables override the default flags.
apmd_flags=NO
bgpd_flags=NO
bootparamd_flags=NO
cron_flags=
dhcpd_flags=NO
dhcrelay_flags=NO       # for normal use: "-i interface [server]"
dvmrpd_flags=NO
eigrpd_flags=NO
ftpd_flags=NO           # set to NO if ftpd is running out of inetd
ftpproxy_flags=NO
ftpproxy6_flags=NO
hostapd_flags=NO
hotplugd_flags=NO
httpd_flags=NO
identd_flags=NO
ifstated_flags=NO
iked_flags=NO
inetd_flags=NO
isakmpd_flags=NO
iscsid_flags=NO
ldapd_flags=NO
ldattach_flags=NO       # for normal use: "[options] linedisc cua-device"
ldomd_flags=NO
ldpd_flags=NO
lpd_flags=NO            # for normal use: "" (or "-l" for debugging)
mopd_flags=NO
mrouted_flags=NO        # be sure to enable multicast below
npppd_flags=NO
nsd_flags=NO
ntpd_flags=
ospfd_flags=NO
ospf6d_flags=NO
pflogd_flags=           # add more flags, e.g. "-s 256"
radiusd_flags=NO
rarpd_flags=NO
rbootd_flags=NO
relayd_flags=NO
rebound_flags=NO
ripd_flags=NO
route6d_flags=NO        # be sure to set net.inet6.ip6.forwarding=1
rtadvd_flags=NO         # for normal use: list of interfaces
                        # be sure to set net.inet6.ip6.forwarding=1
sasyncd_flags=NO
sensorsd_flags=NO
slaacd_flags=
slowcgi_flags=NO
smtpd_flags=
sndiod_flags=
snmpd_flags=NO
spamd_flags=NO          # also see spamd_black below
spamlogd_flags=         # use eg. "-i interface" and see spamlogd(8)
sshd_flags=
switchd_flags=NO
syslogd_flags=          # add more flags, e.g. "-u -a /chroot/dev/log"
tftpd_flags=NO
tftpproxy_flags=NO
unbound_flags=NO
vmd_flags=NO
watchdogd_flags=NO
wsmoused_flags=NO       # for enabling console mouse support (i386 alpha amd64)
                        # for ps/2 or usb mice: "", serial: "-p /dev/cua00"
xenodm_flags=NO         # on some architectures, you must also
                        # disable console getty in /etc/ttys

# services related to RPC, NFS, and YP
amd_flags=NO            # also see amd_master below
lockd_flags=NO
mountd_flags=NO
nfsd_flags=NO
portmap_flags=NO        # note: inetd(8) rpc services need portmap too
statd_flags=NO
ypbind_flags=NO
ypldap_flags=NO
ypserv_flags=NO

# set the following to "YES" to turn them on
pf=YES                  # Packet filter / NAT
ipsec=NO                # IPsec
check_quotas=YES        # NO may be desirable in some YP environments
accounting=NO           # process accounting (using /var/account/acct)

# Multicast routing configuration
# Please look at netstart(8) for a detailed description if you change these
multicast=NO            # Reject IPv4 multicast packets by default

# miscellaneous other flags
amd_master=/etc/amd/master      # AMD 'master' map
library_aslr=YES                # set to NO to disable library randomization
savecore_flags=                 # "-z" to compress
spamd_black=NO                  # set to YES to run spamd without greylisting
shlib_dirs=                     # extra directories for ldconfig, separated
                                # by space

# rc.d(8) packages scripts
# started in the specified order and stopped in reverse order
# pkg_scripts=
pkg_scripts=dbus_daemon
gdm_enable=YES
hostname="ultra45"
(red ones are added by myself!)


/etc/hosts contains:

Code:
127.0.0.1       localhost ultra45
::1             localhost ultra45
-> i added both "ultra45"


file /root/.xinitrc contains:

Code:
exec gnome-session
-> added by myself, mayb the file didn't exist before, or was empty. (?)


AND: i try to execute "startx" as root user, mybe there is a problem.

The graphic card i use is a sun "XVR-300", the "XVR-100" create some graphical errors while booting, screen isn't readable anymore..

The "Sun Ultra45 Workstation" is officially supported by OpenBSD 6.2 ("sparc64"), but that seems to be just a theoretically thing.

Thank you very much for your feedbacks!
__________________
Regards, Jan

Last edited by jmar83; 23rd February 2018 at 02:46 AM.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sparc 20 won't boot after Net BSD 4.1 install rogue0912 NetBSD Installation and Upgrading 1 12th September 2011 09:01 AM
How - To install GNOME vile I install OpenBSD ? looop OpenBSD Installation and Upgrading 6 24th April 2010 08:58 PM
sparc ultra 5 ok== files and args ??? philo_neo71 FreeBSD Installation and Upgrading 2 21st September 2009 03:43 AM
errror install nebsd sparc ultra5 philo_neo71 NetBSD General 3 21st July 2009 06:35 AM
Full install of Gnome on OpenBSD 4.4 mfaridi OpenBSD Installation and Upgrading 17 9th November 2008 01:54 PM


All times are GMT. The time now is 11:50 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick