DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD Package System (pkgsrc)

NetBSD Package System (pkgsrc) Installation and upgrading of packages on NetBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 3rd June 2018
billy_bazooka billy_bazooka is offline
Port Guard
 
Join Date: Sep 2016
Posts: 13
Default [solved] netbsd 6.1.5 i386.. cant compile ratpoison - freetype2 issue

I am trying to compile ratpoison from pkgsrc, it breaks with following message, while trying to install libXft (ratpoison dependency)

Code:
Package dependency requirement 'freetype2 >= 21.0.15' could not be satisfied.
Package 'freetype2' has version '13.0.7', required version is '>= 21.0.15'
The weird thing is.. i googled it.. on the freetype website newest version is 2.9.1..
Am I missing something obvious?

Last edited by billy_bazooka; 5th June 2018 at 01:45 AM.
Reply With Quote
  #2   (View Single Post)  
Old 3rd June 2018
shep shep is offline
Rc.conf Instructor
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 1,122
Default

I think that has to be an error in pkgsrc.

I browsed the ftp.fr.netbsd.org package repository and only found ratpoisen building in
http://ftp.fr.netbsd.org/pub/pkgsrc/....0_2018Q1/All/

The main website (ftp.netbsd.org/pub/pkgsrc/) is down right now.

Where to go depends on your goals. Do you want to learn how to fix the problem and commit back to the project or just get NetBSD working on your i386 system?

Also be aware that NetBSD policy is only to support the 2 most recent major versions and that 8.0 is RC1. When 8.0 is released, the project historically will no longer support 6.1.5.
Reply With Quote
  #3   (View Single Post)  
Old 3rd June 2018
billy_bazooka billy_bazooka is offline
Port Guard
 
Join Date: Sep 2016
Posts: 13
Default

frankly, i would just like to get it working..
its a 512mb i386 somewhat weak (but very usable) machine.. i feel it is counterproductive to put a newer OS on it.. and I love the lack of framebuffer console in 6.1.5...
Reply With Quote
  #4   (View Single Post)  
Old 4th June 2018
shep shep is offline
Rc.conf Instructor
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 1,122
Default

I'm running i386 7.1.2 with openchrome video and LXDE but I have 2mb RAM. I also have an older ECS A900 w/ Sis video,512mb RAM running OpenBox/Tint2/Wbar. LXDE was a rainy day experiment and required alot of effort to get it working. On both, I used packages rather than source. On the low end machines, it takes foreever to build applications and my attempt at cross-compiling failed.

If you are willing to use another WM, you should be able to do it. It is also possible to compile a custom 7.1.2 kernel w/ inteldrm/radeondrm removed.
Reply With Quote
  #5   (View Single Post)  
Old 4th June 2018
IdOp's Avatar
IdOp IdOp is offline
Too dumb for a smartphone
 
Join Date: May 2008
Location: twisting on the daemon's fork(2)
Posts: 797
Default

One could also try the supplied netbsd-LEGACY kernel (example) which supports ISA (vga and PC display) display devices.

Added: Oh, and I forgot, another idea, maybe you can disable the drmkms stuff in boot.cfg.

Last edited by IdOp; 4th June 2018 at 02:44 AM.
Reply With Quote
  #6   (View Single Post)  
Old 4th June 2018
Sensucht94's Avatar
Sensucht94 Sensucht94 is offline
Real Name: Paolo Vincenzo Olivo
Port Guard
 
Join Date: Oct 2017
Location: Rome
Posts: 23
Default

Quote:
Originally Posted by billy_bazooka View Post
The weird thing is.. i googled it.. on the freetype website newest version is 2.9.1..
Am I missing something obvious?
Versions of libfreetype.so are named after the corresponding libtool version which freetype2 is generated with; see freetype/docs/VERSIONS.TXT.
Quote:
I am trying to compile ratpoison from pkgsrc, it breaks with following message, while trying to install libXft (ratpoison dependency)

Code:
Package dependency requirement 'freetype2 >= 21.0.15' could not be satisfied.
Package 'freetype2' has version '13.0.7', required version is '>= 21.0.15'
GCC is trying to link to the freetype2 version included in xbase.tgz, which, on such an outdated system version, predictably lags several versions behind (you should have /usr/X11R7/lib/libfreetype.so.13.0.7 ,
whereas /usr/pkg/lib/libfreetype.so.x.y.z, provided by graphics/freetype2@2.9.1 is what you're looking for. Just echo:

Code:
PREFER.freetype2=pkgsrc
PREFER.fontconfig=pkgsrc
to your /etc/mk.conf; should get the job done
Reply With Quote
  #7   (View Single Post)  
Old 5th June 2018
billy_bazooka billy_bazooka is offline
Port Guard
 
Join Date: Sep 2016
Posts: 13
Default

thank you very much.. problem solved
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
nVidia on NetBSD issue. mbzadegan NetBSD General 6 12th May 2016 05:47 PM
n00b question: how to cross-compile NetBSD Plast0000 NetBSD General 8 1st April 2015 11:50 AM
howto compile kicad on netbsd faysal76 General software and network 4 4th March 2010 12:35 PM
Directadmin on FreeBSD 7 Stable i386 issue Celestemmcknight FreeBSD Ports and Packages 1 7th June 2009 11:35 PM
WindowMaker 0.92.0p7 (OpenBSD 4.4/i386 Packages) configuration issue. xixobrax OpenBSD General 1 3rd May 2009 04:04 PM


All times are GMT. The time now is 03:27 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick