DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 22nd June 2018
jmccue jmccue is offline
Real Name: John McCue
Port Guard
 
Join Date: Aug 2012
Location: here
Posts: 17
Default startx/.Xauthority and patch 010

Hi

I noticed something odd after Patch 010, there is an easy work around though. Curious, did anyone notice this issue ?

After a reboot, startx hangs on ~/.Xauthority and 2 other Xauthority files are created, .Xauthority.l and .Xauthority.f (IIRC).

If I remove all ~/.Xauthority* files and then 'startx', all is fine until the next reboot.

Suspend and everything else is fine between reboots. Seems the reboot resets something now (guessing).

Anyway, just a curiosity to me BTW this is on a T420 and64 v6.3

John
Reply With Quote
  #2   (View Single Post)  
Old 22nd June 2018
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,293
Default

It is unlikely that the patch is related to your reported X11 administration issue. Patch #10 is a revision to the kernel for amd64. See all the code it touches here:

https://ftp.openbsd.org/pub/OpenBSD/...lfpu.patch.sig
Reply With Quote
  #3   (View Single Post)  
Old 22nd June 2018
frcc frcc is offline
Don't Worry Be Happy!
 
Join Date: Jul 2011
Location: hot,dry,dusty,rainy,windy,straight winds, tornado,puts the fear of God in you-Texas
Posts: 144
Default

I have experienced similar behavior on my T430 when I am not paying attention issuing shell commands.

attempt to "startx" from WITHIN x as standard user
.or.
attempt to "startx" from WITHIN x as root.

within a xterm shell.

OpenBSD 6.3 AMD64
Fresh Install - no patches

Last edited by frcc; 22nd June 2018 at 12:13 PM. Reason: clarify post
Reply With Quote
  #4   (View Single Post)  
Old 24th June 2018
jmccue jmccue is offline
Real Name: John McCue
Port Guard
 
Join Date: Aug 2012
Location: here
Posts: 17
Default

Based upon what jggimi stated, I decided to look further. I rebooted, did a startx and when X crashed was going to check out Xorg.0.log, but this time no issues.

Odd, but if it happens again I will look into in in detail
Reply With Quote
  #5   (View Single Post)  
Old 14th July 2018
jmccue jmccue is offline
Real Name: John McCue
Port Guard
 
Join Date: Aug 2012
Location: here
Posts: 17
Default

The issue happened again, but I am quite sure I found the issue.

I had cloned /etc/X11/xinit/xinitrc to create my own ~/.xinitrc but I forgot to include these line at the end of ~/.xinitrc

Code:
if [ "$SSH_AGENT_PID" ]; then
    ssh-add -D < /dev/null
    eval `ssh-agent -s -k`
fi
Since I did this, the intermittent has not happened
Reply With Quote
Reply

Tags
startx xauthority 010

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
startx/.Xauthority and patch 010 jmccue FreeBSD General 0 22nd June 2018 01:44 AM
5.9 amd64 kernel panic after 004_mbuf.patch.sig patch shep OpenBSD General 0 2nd May 2016 04:34 PM
.Xauthority .Xlock ?????? frcc OpenBSD General 1 30th June 2013 11:32 PM
log in to console and startx in os x questionguy Other BSD and UNIX/UNIX-like 11 25th August 2009 05:27 AM
Startx executes as root, "startx:not found" as user Mr-Biscuit NetBSD Installation and Upgrading 4 27th May 2009 08:44 AM


All times are GMT. The time now is 02:58 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick