DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 2 Weeks Ago
bloodnok bloodnok is offline
New User
 
Join Date: Feb 2020
Posts: 4
Default Noob trying to get synaptics to work

New openbsd user here, as a refugee from Linux.

I'm trying to get the synaptics driver loaded in xorg as I want access to buttons 2 and 3 from the trackpad using multi-finger clicks.

I've tried forcing a load of synaptics from xorg.conf, and it appears to load (according to the logs) but synclient claims it's not there. Also tried disabling wsmouse and ws but still no joy.

Can anyone point me in the right direction?

Thanks.

This is openbsd 6.6 (amd64) on a Dell laptop.

__
Marc
Reply With Quote
  #2   (View Single Post)  
Old 2 Weeks Ago
Head_on_a_Stick's Avatar
Head_on_a_Stick Head_on_a_Stick is offline
Real Name: Matthew
Bloaty McBloatFace
 
Join Date: Dec 2015
Location: London
Posts: 153
Default

Quote:
Originally Posted by bloodnok View Post
I've tried forcing a load of synaptics from xorg.conf, and it appears to load (according to the logs) but synclient claims it's not there. Also tried disabling wsmouse and ws but still no joy.
Please post exactly what you have tried (including the actual configuration file(s) and location(s)) rather than a vague description.

Does this thread help?
__________________
Linux is for people who hate Windows. BSD is for people who love UNIX.
Reply With Quote
  #3   (View Single Post)  
Old 2 Weeks Ago
bloodnok bloodnok is offline
New User
 
Join Date: Feb 2020
Posts: 4
Default

Sadly, that post doesn't help. I'd read it previously and although it seemed to contain clues, I don't think it applies.

Here is the wsconsctl stuff:

Code:
minnie# cat /etc/wsconsctl.conf
#	$OpenBSD: wsconsctl.conf,v 1.1 2014/07/16 13:21:33 deraadt Exp $
#
# wscons configurable parameters
#
mouse.type=synaptics
display.brightness=70.00%
#	$OpenBSD: wsconsctl.conf,v 1.1 2014/07/16 13:21:33 deraadt Exp $
#
# wscons configurable parameters
#
mouse.type=synaptics
display.brightness=70.00%

minnie# wsconsctl
keyboard.type=pc-xt
[ . . . ]
keyboard.encoding=us
mouse.type=touchpad
mouse.rawmode=0
mouse.scale=0,1229,0,929,0,12,12
mouse.reverse_scrolling=0
mouse.tp.tapping=0
mouse.tp.scaling=0.597
mouse.tp.swapsides=0
mouse.tp.disable=0
mouse.tp.edges=0.0,5.0,10.0,5.0
display.type=inteldrm
[ . . . ]
display.brightness=70.00%
[ . . . ]

minnie# wsconsctl mouse.type=synaptics
wsconsctl: mouse.type: read only
I set the display brightness in the conf file to ensure that the conf file was being read. I have been unable to set the mouse type to synaptics using wsconsctl.

Here is /etc/X11/xorg.conf.d/70-synaptics.conf:
Code:
# MM

Section "Module"
    Disable "wsmouse"
    Disable "ws"
    Load "synaptics"
EndSection

Section "InputClass"
        Identifier "touchpad for minnie"
        MatchIsTouchpad "on"
        MatchDriver "synaptics"
        MatchDevicePath "/dev/wsmouse0"
            Option "ClickFinger1" "1"
            Option "ClickFinger2" "2"
            Option "ClickFinger3" "3"
EndSection
And an extract from the Xorg.0.log file:
Code:
. . . 
[    34.593] (WW) "wsmouse" will not be loaded unless you've specified it to be
l
oaded elsewhere.
[    34.593] (WW) "ws" will not be loaded unless you've specified it to be loade
d
 elsewhere.
[    34.593] (II) "glx" will be loaded by default.
[    34.593] (II) LoadModule: "synaptics"
[    34.672] (II) Loading /usr/X11R6/lib/modules/input/synaptics_drv.so
[    34.734] (II) Module synaptics: vendor="X.Org Foundation"

. . .

[    37.933] (II) XINPUT: Adding extended input device "/dev/wskbd" (type: KEYBO
A
RD, id 6)
[    38.130] (II) config/wscons: checking input device /dev/wsmouse0
[    38.130] (II) LoadModule: "ws"
[    38.132] (II) Loading /usr/X11R6/lib/modules/input/ws_drv.so
[    38.148] (II) Module ws: vendor="X.Org Foundation"
[    38.148]    compiled for 1.20.5, module version = 1.3.0
[    38.148]    Module class: X.Org XInput Driver
[    38.148]    ABI class: X.Org XInput driver, version 24.1
[    38.148] (II) Using input driver 'ws' for '/dev/wsmouse0'
[    38.148] (**) /dev/wsmouse0: always reports core events
[    38.148] (II) ws: /dev/wsmouse0: debuglevel 0
[    38.148] (**) Option "Device" "/dev/wsmouse0"
[    38.148] (**) ws: /dev/wsmouse0: ZAxisMapping: buttons 4 and 5
[    38.148] (**) ws: /dev/wsmouse0: WAxisMapping: buttons 6 and 7
[    38.148] (**) ws: /dev/wsmouse0: associated screen: 0
[    38.341] (II) ws: /dev/wsmouse0: minimum x position: 0
[    38.341] (II) ws: /dev/wsmouse0: maximum x position: 1365
[    38.341] (II) ws: /dev/wsmouse0: minimum y position: 0
[    38.341] (II) ws: /dev/wsmouse0: maximum y position: 767
[    38.341] (==) ws: /dev/wsmouse0: Buttons: 7
[    38.341] (**) ws: /dev/wsmouse0: YAxisMapping: buttons 4 and 5
[    38.341] (II) XINPUT: Adding extended input device "/dev/wsmouse0" (type: MO
U
SE, id 7)
[    38.541] (**) /dev/wsmouse0: (accel) keeping acceleration scheme 1
[    38.541] (**) /dev/wsmouse0: (accel) acceleration profile 0
[    38.541] (**) /dev/wsmouse0: (accel) acceleration factor: 2.000
[    38.541] (**) /dev/wsmouse0: (accel) acceleration threshold: 4
[    38.541] (II) config/wscons: checking input device /dev/wsmouse
[    38.541] (II) Using input driver 'ws' for '/dev/wsmouse'
[    38.541] (**) /dev/wsmouse: always reports core events
[    38.541] (II) ws: /dev/wsmouse: debuglevel 0
[    38.541] (**) Option "Device" "/dev/wsmouse"
[    38.541] (**) ws: /dev/wsmouse: ZAxisMapping: buttons 4 and 5
[    38.541] (**) ws: /dev/wsmouse: WAxisMapping: buttons 6 and 7
[    38.541] (**) ws: /dev/wsmouse: associated screen: 0
[    38.541] (EE) PreInit returned 2 for "/dev/wsmouse"
[    38.541] (II) UnloadModule: "ws"
On the xorg.conf: I've tried various alternatives of disabling ws and wsmouse with no effect. From the logs it looks like the synaptics module is loaded but ignored. I'm guessing it must be failing to recognise that it has to map to the mouse device. I've tried /dev/wsmouse and /dev/wsmouse0 to no effect.

Thanks.

__
Marc
Reply With Quote
  #4   (View Single Post)  
Old 2 Weeks Ago
Head_on_a_Stick's Avatar
Head_on_a_Stick Head_on_a_Stick is offline
Real Name: Matthew
Bloaty McBloatFace
 
Join Date: Dec 2015
Location: London
Posts: 153
Default

Quote:
Originally Posted by bloodnok
I don't think it applies
What makes you think that?

Have you actually tried just copying /usr/X11R6/share/X11/xorg.conf.d/70-synaptics.conf to /etc/X11/xorg.conf.d/70-synaptics.conf and then adding your options?

The comments in the file say that's what you're supposed to do.
__________________
Linux is for people who hate Windows. BSD is for people who love UNIX.
Reply With Quote
  #5   (View Single Post)  
Old 2 Weeks Ago
bloodnok bloodnok is offline
New User
 
Join Date: Feb 2020
Posts: 4
Default

Quote:
Originally Posted by Head_on_a_Stick View Post
What makes you think that?

Have you actually tried just copying /usr/X11R6/share/X11/xorg.conf.d/70-synaptics.conf to /etc/X11/xorg.conf.d/70-synaptics.conf and then adding your options?

The comments in the file say that's what you're supposed to do.
Yep, that's where I started. And just in case I messed it up originally I just tried again, with no more success than before.

Here is my 70-synaptics.conf file now:
Code:
 Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#
#Section "InputClass"
#        Identifier "touchpad catchall"
#        Driver "synaptics"
#        MatchIsTouchpad "on"
## This option is recommend on all Linux systems using evdev, but cannot be
## enabled by default. See the following link for details:
## http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
##       MatchDevicePath "/dev/input/event*"
#EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/wsmouse*"
        #Option "Ignore" "on"
            Option "ClickFinger1" "1"
            Option "ClickFinger2" "2"
            Option "ClickFinger3" "3"

EndSection
I removed the MatchOS assuming that "Linux" was not relevant, and changed the matchdevicepath to devices that actually exist. Also commented out the ignore option.

Still no joy. synclient tells me that it couldn't find synaptics properties and the Xorg log file shows no loading of synclient.

It looks to me like wscons is in control here, but I don't know what to do about it.

Thanks for the responses btw. It helps to know I'm not on my own.

__
Marc
Reply With Quote
  #6   (View Single Post)  
Old 2 Weeks Ago
Head_on_a_Stick's Avatar
Head_on_a_Stick Head_on_a_Stick is offline
Real Name: Matthew
Bloaty McBloatFace
 
Join Date: Dec 2015
Location: London
Posts: 153
Default

Quote:
Originally Posted by bloodnok View Post
Here is my 70-synaptics.conf file now
You've commented out the "touchpad catchall" section and added your configuration to the "ignore duplicates" section, don't do that.

And I don't think you should change the MatchDevicePath at all.

Try copying my configuration from the other thread, here it is again:

http://daemonforums.org/showpost.php...54&postcount=4
__________________
Linux is for people who hate Windows. BSD is for people who love UNIX.
Reply With Quote
  #7   (View Single Post)  
Old 2 Weeks Ago
bloodnok bloodnok is offline
New User
 
Join Date: Feb 2020
Posts: 4
Smile

Quote:
Originally Posted by Head_on_a_Stick View Post
You've commented out the "touchpad catchall" section and added your configuration to the "ignore duplicates" section, don't do that.
Hmmm. I didn't touch the catchall - it was commented out in in the original from /usr/X11R6/share/X11/xorg.d/

And, yes I was adding options to the wrong section, though only in this iteration and not originally.

Quote:
And I don't think you should change the MatchDevicePath at all.

Try copying my configuration from the other thread, here it is again:

http://daemonforums.org/showpost.php...54&postcount=4
Done. That worked. Thanks.

...A few experiments later:

Looks like the MatchOs and MatchDevicePath stuff was all failing. The MatchOs failing makes sense to me, the MatchDevicePath not so much. I tried various versions: the version from your config file; /dev/wsmouse*; /dev/wsmouse; and /dev/wsmouse0. All caused the driver to fail to load.

Since I will only ever have one trackpad there was no need to use multiple InputClass definitions.

Here is the final working version of my conf file, sans comments and with minimal options defined. This should be enough for future noobs to get started with the synaptics driver:
Code:
Section "InputClass"
        Identifier "touchpad"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "VertEdgeScroll" "off"
        Option "VertTwoFingerScroll" "on"
EndSection
Looking back at my original config, I think it should have worked, but MatchDevicePath seems to have its own ideas. <shrug/>

Many thanks for your help and patience.

__
Marc
Reply With Quote
Reply

Tags
synaptics, trackpad, xorg.conf

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Touchpad scrolling and tap to click - no Synaptics? JWJones OpenBSD General 6 19th January 2019 02:27 PM
NetBSD and a Synaptics Touchpad gmjs NetBSD General 16 17th July 2014 03:19 PM
Synaptics touchpad is slower on OpenBSD 5.2 -current daemonfowl OpenBSD General 4 26th June 2012 05:20 PM
5.0-Current and Synaptics Touch Pad shep OpenBSD General 4 16th October 2011 01:15 AM
Noob Gargamelle Off-Topic 4 16th December 2010 11:39 PM


All times are GMT. The time now is 05:28 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick