DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
Old 15th August 2015
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,180
Default

Just noticed another typo. The options set the timeout to 600 seconds -- that's 10 minutes. I'd missed changing the 6 to a 3.

Good luck!
Reply With Quote
Old 16th August 2015
GarryR's Avatar
GarryR GarryR is online now
Real Name: Garry Ricketson
Spam Deminer
 
Join Date: Jul 2015
Location: Durango, Mx.
Posts: 227
Default

Ok, thanks,
Sadly, so far this still is not working, but I noticed some things in the manual,and on sample for the options file in the ppp directory, that I had not noticed before, ...I need to go over everything carefully again, I bet I have missed something,..
One thing:
Quote:
For example, the Huawei E220 has two serial ports, but only the first port can be used to make connections;
I am using the first one,
actually yesterday, I saw somewhere where it mentions that it may show, 4 but still , the same it said the first one
is the one I need to use.
Just now, I noticed this in the example, : http://www.openbsd.org/cgi-bin/man.c...th=OpenBSD-5.7
/etc/ppp/peers/ac875 ( I am using a different "filename"), but that is not important,
Code:
cuaU0 ****NOTE***, I think I have "tty" or something like that, on this first line!
115200 
debug 
noauth 
nocrtscts 
:10.254.254.1 
ipcp-accept-remote 
defaultroute 
user isp@cingulargprs.com 
demand 
active-filter 'not udp port 123' 
persist 
idle 600 
connect "/usr/sbin/chat -v -f /etc/ppp/cingular-chat"
So anyway, I need to go over everything again, but I am pretty sure, where it says cuaU0, I have something else so that may be what went wrong.
Thanks

Last edited by GarryR; 16th August 2015 at 05:05 PM.
Reply With Quote
Old 16th August 2015
GarryR's Avatar
GarryR GarryR is online now
Real Name: Garry Ricketson
Spam Deminer
 
Join Date: Jul 2015
Location: Durango, Mx.
Posts: 227
Default

Well, I was right, I had made a mistake on that one line, and fixed it, but still didn't work,..
I don't know if the "ifconfig" needs to be changed in some way, or if the info is relevant or not,
but any way I decided to copy it:
"output for ifconfig"
Code:
 lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 32768
	priority: 0
	groups: lo
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
	inet6 ::1 prefixlen 128
	inet 127.0.0.1 netmask 0xff000000
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	lladdr 60:eb:69:0f:9b:26
	priority: 0
	media: Ethernet autoselect (none)
	status: no carrier
enc0: flags=0<>
	priority: 0
	groups: enc
	status: active
vlan0: flags=208843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST,AUTOCONF6> mtu 1500
	lladdr 60:eb:69:0f:9b:26
	priority: 0
	vlan: 1 parent interface: re0
	groups: vlan
	status: no carrier
	inet6 fe80::62eb:69ff:fe0f:9b26%vlan0 prefixlen 64 scopeid 0x4
pflog0: flags=141<UP,RUNNING,PROMISC> mtu 33192
And if changes need to be made, I did look at "man ifconfig" , but am not sure yet what to think of all
that it says,..
OK well I also did this:
Using the command cu -l /dev/cuaU0 -s 11520

Code:
  cu -l /dev/cuaU0 -s 11520
Connected to /dev/cuaU0 (speed 11520)
ATZ
OK
AT&F
OK
AT+CGDCONT=1,"IP","internet.itelcel.com"
OK
ATD*99#
CONNECT
So it seems to be communicating with the device, when it gets to the last, and says
"CONNECT" though, it seems to no longer respond, other then to
the (~.) which ends the connection, [EOF]
It does make me wonder if there is a way, I can just enter the "webgprs" (username) and password, "webgprs2002", manually or directly, once I start "talking" to the modem ?
Any way, I am going to keep trying,..at least it appears there is some communication happening,
ahh, and then I removed the broad band device, and when I tried the same command, cu -l /dev/cuaU0 -s 11520 I got "device not detected or available", so I know, it is communicating, when the device is plugged in. thanks again,..
Reply With Quote
Old 16th August 2015
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,180
Default

The network interface for a ppp(4) device is missing -- and that may be the last piece of the puzzle. There's no ppp0 device listed by ifconfig(8).

So, try this:

# ifconfig ppp0 create

Then, retry the # pppd call <filename> once again.
Reply With Quote
Old 16th August 2015
GarryR's Avatar
GarryR GarryR is online now
Real Name: Garry Ricketson
Spam Deminer
 
Join Date: Jul 2015
Location: Durango, Mx.
Posts: 227
Default

Thanks, I hope so, it had me wondering, because the ifconfig showed nothing on this device.
Reply With Quote
Old 17th August 2015
GarryR's Avatar
GarryR GarryR is online now
Real Name: Garry Ricketson
Spam Deminer
 
Join Date: Jul 2015
Location: Durango, Mx.
Posts: 227
Default

Quote:
Originally Posted by jggimi View Post
The network interface for a ppp(4) device is missing -- and that may be the last piece of the puzzle. There's no ppp0 device listed by ifconfig(8).

So, try this:

# ifconfig ppp0 create

Then, retry the # pppd call <filename> once again.
The # ifconfig ppp0 create
Seemed to go well, I didn't think to run
Code:
ifconfig
and see what it looks like now,
When I ran # pppd call telcel
I got "remote IP is needed " ( I thought I had copied the exact message, to a usb stick, but
it didn't copy right, I will try that again, and get a exact copy)
"telcel"
Code:
# the calling unit in /dev:
cuaU0
# baud rate
115200
# send debug information to /var/log/daemon
debug
# do not require the ISP to authenticate itself
noauth
#  use this connection for the default route
defaultroute
# make this PPP connection when packets are outgoing, disconnect 
# when idle 5 minutes.  If ntpd(8) is running, ignore its clock synchronization
# packets for idle calculations. 
demand
idle 600 
active-filter 'not udp port 123' 
# don't shutdown if the connection goes idle
persist
# userid for PAP authentication
user webgprs# modem commands to be sent when connecting
connect "/usr/sbin/chat -v -f /etc/ppp/telcel-chat"
On my "Telcel Default" info, looking at networkmanager, on the Debian, it says

default route: 10.64.64.64
my guess is that is what goes here:
Code:
#  use this connection for the default route
defaultroute
where it says default route,... but I am not sure if it would be the same IP on openbsd, nor actually what they mean "remote" IP, but I am going to do a "search" (startpage.com) also just now, to see on that. It is getting closer though, now, I think.
Reply With Quote
Old 17th August 2015
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,180
Default

The pppd(8) man page says of defaultroute:
Quote:
defaultroute

Add a default route to the system routing tables, using the peer as the gateway, when IPCP negotiation is successfully completed. This entry is removed when the PPP connection is broken. This option is privileged if the nodefaultroute option has been specified.
There is no operand for the option. It will add a default route using the address of the peer once IPCP negotiation (IP address assignment) has completed.

Since you now have the expected IP address of Telcel's peer, you can adapt this address as was shown in the umsm(4) man page example. Add a line which sets this address for the remote peer, then an option to allow the remote peer to revise the address.
Code:
:10.64.64.64
ipcp-accept-remote
The IP address line has a leading colon, so that it is used as a remote address. And the option which follows permits this address to be changed. This is described in the pppd(8) man page here:
Quote:
[local_IP_address]:[remote_IP_address]

Set the local and/or remote interface IP addresses. Either one may be omitted. The IP addresses can be specified with a host name or in decimal dot notation (e.g., 150.234.56.78). The default local address is the (first) IP address of the system (unless the noipdefault option is given). The remote address will be obtained from the peer if not specified in any option. Thus, in simple cases, this option is not required. If a local and/or remote IP address is specified with this option, pppd will not accept a different value from the peer in the IPCP negotiation, unless the ipcp-accept-local and/or ipcp-accept-remote options are given, respectively.
Sorry about having you do all the testing, but I haven't used PPP for anything in 20 years, predating my OpenBSD experience, and I've never been a Telcel customer.
Reply With Quote
Old 17th August 2015
GarryR's Avatar
GarryR GarryR is online now
Real Name: Garry Ricketson
Spam Deminer
 
Join Date: Jul 2015
Location: Durango, Mx.
Posts: 227
Default

Thanks again ,..
Quote:
The IP address line has a leading colon, so that it is used as a remote address. And the option which follows permits this address to be changed. This is described in the pppd(8) man page here:
Ok, I missed that, on the "leading colon", that might be why it didn't work,
Then I ran out of "air time", so I need to re-charge the account, I just put 50 pesos, on it last night, so I could take care of some things (moderator on another forum), later to today, I will get the "monthly" amount paid, but anyway,.....

Quote:
Sorry about having you do all the testing,
, in reverse, I am sorry , to need so much
"guiding", no problem, ...it would have been a long time (if ever) for me to get this far, and at least there is something happening now, if it tells me I need this IP, or a the "remote" address, etc, at least that also shows it is trying to read those files/scripts. I appreciate this help very much,...
Reply With Quote
Old 18th August 2015
GarryR's Avatar
GarryR GarryR is online now
Real Name: Garry Ricketson
Spam Deminer
 
Join Date: Jul 2015
Location: Durango, Mx.
Posts: 227
Default Still no connect, sort of a "review"

Quote:
Then I ran out of "air time", so I need to re-charge the account, I just put 50 pesos,
Well now, I have a "month" or full 3gb, which ever gets used first,...any way, I made the changes to my /etc/ppp/peers/telcel and, at least I don't get any "error" messages, when I run :
Code:
 pppd call telcel
but still no connect.
-----------------------------
I copied all the files, in the ppp directory, and made another
"ifconfig2.txt" :
Code:
$ifconfig 
	inet 127.0.0.1 netmask 0xff000000
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	lladdr 60:eb:69:0f:9b:26
	priority: 0
	media: Ethernet autoselect (none)
	status: no carrier
enc0: flags=0<>
	priority: 0
	groups: enc
	status: active
vlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	lladdr 60:eb:69:0f:9b:26
	priority: 0
	vlan: 1 parent interface: re0
	groups: vlan
	status: no carrier
pflog0: flags=141<UP,RUNNING,PROMISC> mtu 33192
	priority: 0
	groups: pflog
ppp0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1500
	priority: 0
	groups: ppp egress
	inet 0.0.0.0 --> 10.64.64.64 netmask 0xffffff00
-------------------------------------------------------------------------------------------
This is the current /etc/ppp/peers/telcel:
Code:
 # the calling unit in /dev:
cuaU0
# baud rate
115200
# send debug information to /var/log/daemon
debug
# do not require the ISP to authenticate itself
noauth
#  use this connection for the default route
:10.64.64.64
ipcp-accept-remote
defaultroute
# make this PPP connection when packets are outgoing, disconnect 
# when idle 5 minutes.  If ntpd(8) is running, ignore its clock synchronization
# packets for idle calculations. 
demand
idle 600 
active-filter 'not udp port 123' 
# don't shutdown if the connection goes idle
persist
# userid for PAP authentication
user webgprs# modem commands to be sent when connecting
connect "/usr/sbin/chat -v -f /etc/ppp/telcel-chat"
--------------------------------------------
Next, the:
/etc/ppp/telcel-chat
Code:
# time out if no responses after 10 seconds
TIMEOUT 10
# report if connected
REPORT CONNECT
# terminate the script if the modem is busy, has no data link, or has an error
ABORT BUSY
ABORT 'NO CARRIER'
ABORT ERROR
# reset the modem, load factory defaults
'' ATZ OK AT&F OK
# define GPRS core network as the context, 
# see https://en.wikipedia.org/wiki/Hayes_command_set
AT+CGDCONT=1,"10.64.64.64""internet.itelcel.com" OK
# dial 
ATD*99# CONNECT
---------------------------------------------------
/etc/ppp/options
Code:
#       $OpenBSD: options.sample,v 1.2 2014/07/10 11:18:23 jasper Exp $
/dev/cuaU0
19200
modem
crtscts
defaultroute
netmask 255.255.255.0
ipcp-accept-local
ipcp-accept-remote
noipdefault
lock
connect "/usr/sbin/chat -v -f /etc/ppp/telcel-chat"
-----------------------------------------------------------------------------
last ( I think )
/etc/ppp/chap-secrets
Code:
 # Secrets for authentication using PAP
#client       server     secret      IPaddresses
webgprs      *       webgprs2002
??? Perhaps I need the "remote IP here ? or which IP address ???
------------------------------------------------------
Ahh , Ok, well I think I maybe have just found the problem there is another file in the
ppp directory, that I did nothing with, named "pap-secrets"
pap-secrets
Code:
 #	$OpenBSD: pap-secrets,v 1.3 2002/06/09 06:15:15 todd Exp $

# Secrets for authentication using PAP
# client	server	secret			IP addresses
-----------------------------------------------------------------------------------------

I wonder, if it is looking for "pap-secrets" instead of "chap-secrets" or it needs both,..that is easy enough to try,.
I do know for sure if the ISP or modem does not get the password, it will not connect, sometimes something occurs on Debian Jessie, and the password is not saved by network manager,correctly, So I get prompted, by the "keyring" thing, asking for it, and if I don't enter it, or make a typo, it will not connect.
I did not think of this , but maybe ,
Quote:
# send debug information to /var/log/daemon
maybe there is some info in the daemon now,...
Thank you very much, again, ...
Reply With Quote
Old 18th August 2015
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,180
Default

OK. I'll try again. Bear with me.

First problem: Your AT+CGDCONT command is wrong. You replaced the two letters "IP" with the destination peer's IP address. Don't. Leave that the two ASCII capitilized characters. See the URL in the comment in the line above, or, see the example in the umsm(4) man page again.

Second problem: Your notes stated that PAP was used for authentication, and I gave you a sample pap-secrets file, which you put in chap-secets insead. These files will be read by pppd, based on what is requested by your ISP. And, based on your notes, only PAP is used for authentication.

Third, you have a debug option. This is supposed to log debug messages in /var/log/messages. Perhaps it has done so.

Last edited by jggimi; 18th August 2015 at 01:25 AM. Reason: clarity, typo
Reply With Quote
Old 18th August 2015
GarryR's Avatar
GarryR GarryR is online now
Real Name: Garry Ricketson
Spam Deminer
 
Join Date: Jul 2015
Location: Durango, Mx.
Posts: 227
Default

Quote:
First problem: Your AT+CGDCONT command is wrong. You replaced the two letters "IP" with the destination peer's IP address. Don't.
OOPs! Sorry, I took that wrong, and thought since it said IP, it needed the real IP,..
I added the info to the pap-secrets file, now, so I have that,
correct now,
"pap-secrets"
Code:
# Secrets for authentication using PAP
#client       server     secret      IPaddresses
webgprs      *       webgprs2002
I am going to re-boot, into OpenBsd now, and put it in the files, just thought I would check and see if you had made any comments, glad I did,.. thank you for your patience with me ,..
Reply With Quote
Old 18th August 2015
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,180
Default

You're welcome. I hope. And I was wrong again. Debug messages are sent to /var/log/daemon.
Reply With Quote
Old 18th August 2015
IdOp's Avatar
IdOp IdOp is offline
Too dumb for a smartphone
 
Join Date: May 2008
Location: twisting on the daemon's fork(2)
Posts: 777
Default

Quote:
Originally Posted by GarryR View Post
/etc/ppp/chap-secrets
Code:
 # Secrets for authentication using PAP
#client       server     secret      IPaddresses
webgprs      *       webgprs2002
??? Perhaps I need the "remote IP here ? or which IP address ???
It should not be necessary to put an IP address here.

As an aside, I keep my pap-secrets and chap-secrets identical by having one be a link to the other.

Also, it's hard to be sure but in your chat script, the TIMEOUT of 10 might be a little dicey. I would increase it to 20 (or more). You wouldn't want this to be the point of failure waiting for a CONNECT if everything else was right. You can always reduce it later when things are working.
Reply With Quote
Old 18th August 2015
GarryR's Avatar
GarryR GarryR is online now
Real Name: Garry Ricketson
Spam Deminer
 
Join Date: Jul 2015
Location: Durango, Mx.
Posts: 227
Default

Sadly, still does not connect,

Quote:
Debug messages are sent to /var/log/daemon.
There also are messages in /var/log/messages, like you said, and I looked at the ones in /var/log/daemon also, but nothing that gives any clues, maybe I should have copied the most recent ones, just now, but I am kind of tired too, maybe tomorrow,
Quote:
See the URL in the comment in the line above, or, see the example in the umsm(4) man page again.
umsm(4) man page Been going over and over this, trying to see what I am am missing, also the pppd(8) man page.
And this: http://www.openbsd.org/cgi-bin/man.c...=OpenBSD-3%2e6
One thing, when I run the "call pppd telcel" it is doing something, because the modem has a LED,, (light) that blinks, just a little, more like a flicker when it is plugged in, and not connected, but when I run the call command, the light comes on full, but still just a "blink", then for a while it continues blinking strongly, I even thought it was going to connect, but no,..anyway, the LED light, is telling me there is something a going on, that is encouraging.
Thanks.
Reply With Quote
Old 18th August 2015
GarryR's Avatar
GarryR GarryR is online now
Real Name: Garry Ricketson
Spam Deminer
 
Join Date: Jul 2015
Location: Durango, Mx.
Posts: 227
Default

Quote:
Debug messages are sent to /var/log/daemon.
Tried some more this morning, no connection, but here is what the logs say,
I don't know what it means, but it maybe you all do ?
"daemon"
Code:
 Aug 18 10:39:42 usbbsd dhclient[3855]: No acceptable DHCPOFFERS received.
Aug 18 10:39:42 usbbsd dhclient[3855]: No working leases in persistent database - sleeping.
Aug 18 10:41:59 usbbsd pppd[32459]: pppd 2.3.5 started by root, uid 0
Aug 18 10:41:59 usbbsd pppd[32459]: ioctl(TIOCSETD): Device not configured
Aug 18 10:43:26 usbbsd pppd[27081]: pppd 2.3.5 started by root, uid 0
Aug 18 10:43:26 usbbsd pppd[27081]: ioctl(TIOCSETD): Device not configured
Aug 18 10:44:20 usbbsd pppd[12835]: pppd 2.3.5 started by root, uid 0
Aug 18 10:44:20 usbbsd pppd[12835]: ioctl(TIOCSETD): Device not configured
This is just the most recent, from when I tried this morning.
-----------------------
"/var/log/messages" basicly the same.
Code:
 Aug 18 10:30:22 usbbsd pppd[12000]: pppd 2.3.5 started by root, uid 0
Aug 18 10:30:22 usbbsd pppd[12000]: local  IP address 0.0.0.0
Aug 18 10:30:22 usbbsd pppd[12000]: remote IP address 10.64.64.64
Aug 18 10:35:16 usbbsd pppd[7760]: pppd 2.3.5 started by root, uid 0
Aug 18 10:35:16 usbbsd pppd[7760]: ioctl(TIOCSETD): Device not configured
Aug 18 10:35:16 usbbsd pppd: Exit.
Aug 18 10:39:18 usbbsd pppd[31711]: pppd 2.3.5 started by root, uid 0
Aug 18 10:39:18 usbbsd pppd[31711]: ioctl(TIOCSETD): Device not configured
Aug 18 10:39:18 usbbsd pppd: Exit.
Aug 18 10:41:59 usbbsd pppd[32459]: pppd 2.3.5 started by root, uid 0
Aug 18 10:41:59 usbbsd pppd[32459]: ioctl(TIOCSETD): Device not configured
Aug 18 10:41:59 usbbsd pppd: Exit.
Aug 18 10:43:26 usbbsd pppd[27081]: pppd 2.3.5 started by root, uid 0
Aug 18 10:43:26 usbbsd pppd[27081]: ioctl(TIOCSETD): Device not configured
Aug 18 10:43:26 usbbsd pppd: Exit.
Aug 18 10:44:20 usbbsd pppd[12835]: pppd 2.3.5 started by root, uid 0
Aug 18 10:44:20 usbbsd pppd[12835]: ioctl(TIOCSETD): Device not configured
Aug 18 10:44:20 usbbsd pppd: Exit.
I do not know what this is:
Code:
ioctl(TIOCSETD): Device not configured
I am going to try doing a search now, to see what I can find. Thanks
Reply With Quote
Old 18th August 2015
IdOp's Avatar
IdOp IdOp is offline
Too dumb for a smartphone
 
Join Date: May 2008
Location: twisting on the daemon's fork(2)
Posts: 777
Default

The error messages indicate that pppd is giving up immediately after you invoke it. I suspect this is again the issue of interface ppp0 not existing when you start pppd. The solution to this pointed out by jggimi was

# ifconfig ppp0 create

This has to be done certainly after every re-boot.
Reply With Quote
Old 18th August 2015
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,180
Default

There is a failing DHCP request from dhclient(8) in the log, too, which requires an Ethernet connection that isn't present.

I assume this is due to either a /etc/hostname.re0 or a /etc/hostname.vlan0. The re0 NIC is not connected to an Ethernet.

In addition, the vlan0 virtual interface won't function unless the re0 interface is connected to a managed switch capable of IEEE 802.1Q Ethernet tagging, provisioned to send tagged Ethernet frames to the OpenBSD port. Which, if you're using GPRS for Internet ... tends to be unlikely. That's for infrastructures with multiple LANs that share the same switching backplane.

Last edited by jggimi; 18th August 2015 at 06:18 PM. Reason: clarity, typos, and stupidity
Reply With Quote
Old 19th August 2015
GarryR's Avatar
GarryR GarryR is online now
Real Name: Garry Ricketson
Spam Deminer
 
Join Date: Jul 2015
Location: Durango, Mx.
Posts: 227
Default

Quote:
Which, if you're using GPRS for Internet ... tends to be unlikely. That's for infrastructures with multiple LANs that share the same switching backplane.
Sounds like I am not going to be able to use the USB broadband, or is there a way, around this ?

I noticed that to on DHCP, ... also, that explains why it works on the VM, actually it worked
automaticly, I didn't have to do anything, on the VM.
One last note actually it usually does not use GPRS (Edge), that is like a "last resort", and very slow, almost useless. Usually it (the broadband device), is using GSM UMTS
A few years back, I had basically the same problem, with trying to use the same device, on
a Dos (Free Dos), system, it was suggested I try to find a type of modem, that can has a USB port, and the DHCP, and connect it to the "phone" port on the computer, with the usb broad band plugged in to the modem, something like that , but maybe they were "kidding" with me, I never was able to find such a device,. I am sure there is a way to do this,
it just may be even more complicated then I expected.
Looking at this, dhclient(8) just now, and tomorrow I am
going to go over it more carefully, I'm tired,..
Thanks, a lot though, you have done a lot,
unfortunately in the area I am, there are no phone lines yet, maybe in a year or 2 there will be,then it will be easy with a normal modem.
Thanks again though.
Quote:
The error messages indicate that pppd is giving up immediately after you invoke it. I suspect this is again the issue of interface ppp0 not existing when you start pppd. The solution to this pointed out by jggimi was

# ifconfig ppp0 create

This has to be done certainly after every re-boot.
Yes, I realized that, and run
Code:
 # ifconfig ppp0 create
first, every time I boot. I even made a .sh file, I use so I don't have to type out the full command each time.
Thanks though

Last edited by GarryR; 19th August 2015 at 06:24 AM.
Reply With Quote
Old 19th August 2015
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,180
Default

There must be something we're missing. The "device not configured" message is a failure to connect to the /dev/cuaU0 device.

It's probably worth it to test the other three control lines to see if they also appear to respond to modem AT commands.
Reply With Quote
Old 19th August 2015
IdOp's Avatar
IdOp IdOp is offline
Too dumb for a smartphone
 
Join Date: May 2008
Location: twisting on the daemon's fork(2)
Posts: 777
Default

About the DHCP problem, that must be an unrelated issue? With PPP, once you have CONNECTed, then pppd should negotiate with the peer (your ISP), and this includes a phase called IPCP ( ... IP control protocol ... ). During this phase the two sides will try to agree on their IP addresses. In practice this usually implies the ISP will tell you what your IP address is. This address will be assigned to device ppp0. So long story short, no need for DHCP with PPP.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Plan 9 network configuration gpatrick Other OS 1 27th January 2015 02:06 AM
KVM Virtual Machine network configuration J65nko Other BSD and UNIX/UNIX-like 3 2nd December 2014 06:00 AM
Fedora 15 Changing The Network Device Naming Scheme J65nko News 4 27th January 2011 12:30 PM
Network Card Configuration Freeco FreeBSD Installation and Upgrading 6 8th May 2010 11:11 AM
Device-agnostic network interface sean OpenBSD General 2 28th January 2010 06:24 PM


All times are GMT. The time now is 09:49 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick