DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 16th August 2019
joancatala joancatala is offline
Port Guard
 
Join Date: Jun 2011
Posts: 30
Default [SOLVED] I can't install php-gd on OpenBSD 6.5 arm64

Hello,
I have:
Code:
rpi3$ uname -msr
OpenBSD 6.5 arm64
rpi3$
And I would like to install GD library for PHP, because it is a depdendency of Drupal CMS.

Code:
rpi3$ doas pkg_add -vi php-gd-7.2.21
Update candidates: quirks-3.169 -> quirks-3.169
quirks-3.169 signed on 2019-08-15T11:11:44Z
Can't install php-gd-7.2.21 because of libraries
|library X11.17.0 not found
| /usr/X11R6/lib/libX11.so.16.1 (system): bad major
Direct dependencies for php-gd-7.2.21 resolve to png-1.6.37 jpeg-2.0.2v0 php-7.2.21
Full dependency tree is oniguruma-6.9.3 libxml-2.9.9 jpeg-2.0.2v0 php-7.2.21 argon2-20171227 libsodium-1.0.18 libiconv-1.16p0 png-1.6.37 femail-1.0p1 femail-chroot-1.0p3 xz-5.2.4 gettext-runtime-0.20.1p0
Couldn't install php-gd-7.2.21
Can somebody help me?

Last edited by joancatala; 4 Weeks Ago at 07:55 AM.
Reply With Quote
  #2   (View Single Post)  
Old 16th August 2019
bsd-keith bsd-keith is offline
Real Name: Keith
Open Source Software user
 
Join Date: Jun 2014
Location: Surrey/Hants Border, England
Posts: 189
Default

Looks like you need libX11.so.17.0 or later, if it hasn't been compiled, I'd try linking libX11.so.16.1 to libX11.so.17.1 & see if you can get away with it.
Else, you would need to compile it yourself.
__________________
Linux since 1999, & also a BSD user.
Reply With Quote
  #3   (View Single Post)  
Old 16th August 2019
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,712
Default

Code:
Can't install php-gd-7.2.21 because of libraries
|library X11.17.0 not found
| /usr/X11R6/lib/libX11.so.16.1 (system): bad major
Your OS is 6.5-release, but your package path is set is -current.

You cannot use -current packages with a -release system.
Reply With Quote
  #4   (View Single Post)  
Old 16th August 2019
joancatala joancatala is offline
Port Guard
 
Join Date: Jun 2011
Posts: 30
Default

jggimi, I don't understand. I installed nginx, php-7.2, mysql, php-pdo_mysql but... I can't install php-gd?

How could I can install it then?

For your information:
- My machine is a Raspberry Pi 3.
- I burned the image https://ftp.openbsd.org/pub/OpenBSD/.../miniroot65.fs
- I installed several packages succesfully.
- And the package php-gd I want to install is here https://ftp.openbsd.org/pub/OpenBSD/6.5/packages/arm/

Last edited by joancatala; 16th August 2019 at 11:19 AM.
Reply With Quote
  #5   (View Single Post)  
Old 16th August 2019
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,712
Default

The libX11 library moved from 16.1 to 17.0 on August 4, 2019. The package you are trying to install requires the 17.0 version of the library.
  • If you are running -current, update your OS with a more recent snapshot, one built after August 4.
  • If you are running -release, correct your $PKG_PATH.
Reply With Quote
  #6   (View Single Post)  
Old 4 Weeks Ago
joancatala joancatala is offline
Port Guard
 
Join Date: Jun 2011
Posts: 30
Default

Hi @jggimi,
I downloaded a new release image miniroot65.fs from https://ftp.openbsd.org/pub/OpenBSD/6.5/arm64/ and I could install php-gd successfully. Thanks very much for your help!

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Openbsd 5.7 Can't install php-5.6.5 Valus OpenBSD Packages and Ports 4 23rd February 2015 10:36 AM
How to install kde in openbsd v5.6? Crypto333 OpenBSD Packages and Ports 6 30th December 2014 04:53 PM
Install OpenBSD 3.6 zabidin2 OpenBSD Installation and Upgrading 4 22nd September 2010 10:09 AM
How - To install GNOME vile I install OpenBSD ? looop OpenBSD Installation and Upgrading 6 24th April 2010 08:58 PM
install ssh openbsd darken OpenBSD Packages and Ports 22 26th September 2008 02:58 AM


All times are GMT. The time now is 09:40 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick