DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 19th March 2017
dragan dragan is offline
New User
 
Join Date: Feb 2017
Posts: 4
Default Touchpad mouse scrolling

I'm having trouble setting up touchpad double tap and scrolling. It's Toshiba model without synaptics mouse.

Code:
puffy> synclient
Couldn't find synaptics properties. No synaptics driver loaded?
It seems my google-fu is not good enough since I can't find solution.
This is .xinitrc I'm using:

Code:
xinput set-prop "/dev/wsmouse" "WS Pointer Wheel Emulation" 1
xinput set-prop "/dev/wsmouse" "WS Pointer Wheel Emulation Axes" 6 7 4 5
xinput set-prop "/dev/wsmouse" "WS Pointer Wheel Emulation Button" 2
xinput set-prop "/dev/wsmouse" "WS Pointer Wheel Emulation Timeout" 50
xinput set-prop "/dev/wsmouse" "WS Pointer Wheel Emulation Inertia" 3
xinput set-prop "/dev/wsmouse" "Device Accel Constant Deceleration" 0.7
Note that scrolling works on my external mouse, but I'd like to use two-finger scroll on touchpad.

Any help is more than appreciated.

Thanks.
Reply With Quote
  #2   (View Single Post)  
Old 19th March 2017
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 5,884
Default

A quick look through the dmesg(8) database at NYCBUG tells me that Toshiba laptops come with multiple brands of touchpads: Synaptics and ALPS being the two I found in a short search.

To my understanding, the ALPS touchpad is connected to the kernel through the pms(4) driver, and the X.Org synaptics(4) driver can be configured with them.

Here's a comment on the ALPS touchpad configuration via Synaptics settings:

http://openbsd-archive.7691.n7.nabbl...-td163308.html

If this link doesn't help you, please post your dmesg() and the contents of /var/log/Xorg.0.log, so that we can see what hardware the kernel attaches, and how X configures it.
Reply With Quote
  #3   (View Single Post)  
Old 20th March 2017
dragan dragan is offline
New User
 
Join Date: Feb 2017
Posts: 4
Default

Thank for helping out.
I saw that post from archive before and; those commands didn't help unfortunately.
This is Xorg log, it's an auto-generated configuration, seemed OpenBSD always picks up right options:

Code:
puffy> cat /var/log/Xorg.0.log                                                                                                       
[    66.761] (WW) checkDevMem: failed to open /dev/xf86 and /dev/mem
	(Operation not permitted)
	Check that you have set 'machdep.allowaperture=1'
	in /etc/sysctl.conf and reboot your machine
	refer to xf86(4) for details
[    66.761] 	linear framebuffer access unavailable
[    66.767] (--) Using wscons driver on /dev/ttyC4
[    66.772] 
X.Org X Server 1.18.3
Release Date: 2016-04-04
[    66.772] X Protocol Version 11, Revision 0
[    66.772] Build Operating System: OpenBSD 6.0 amd64 
[    66.772] Current Operating System: OpenBSD puffy.domain.home 6.0 GENERIC.MP#2319 amd64
[    66.773] Build Date: 26 July 2016  01:23:40PM
[    66.773]  
[    66.773] Current version of pixman: 0.32.8
[    66.773] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    66.773] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    66.773] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Mar 19 22:28:51 2017
[    66.774] (==) Using system config directory "/usr/X11R6/share/X11/xorg.conf.d"
[    66.774] (==) No Layout section.  Using the first Screen section.
[    66.774] (==) No screen section available. Using defaults.
[    66.774] (**) |-->Screen "Default Screen Section" (0)
[    66.774] (**) |   |-->Monitor "<default monitor>"
[    66.775] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    66.775] (==) Disabling SIGIO handlers for input devices
[    66.775] (==) Automatically adding devices
[    66.775] (==) Automatically enabling devices
[    66.775] (==) Not automatically adding GPU devices
[    66.775] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    66.781] (==) FontPath set to:
	/usr/X11R6/lib/X11/fonts/misc/,
	/usr/X11R6/lib/X11/fonts/TTF/,
	/usr/X11R6/lib/X11/fonts/OTF/,
	/usr/X11R6/lib/X11/fonts/Type1/,
	/usr/X11R6/lib/X11/fonts/100dpi/,
	/usr/X11R6/lib/X11/fonts/75dpi/
[    66.781] (==) ModulePath set to "/usr/X11R6/lib/modules"
[    66.781] (II) The server relies on wscons to provide the list of input devices.
	If no devices become available, reconfigure wscons or disable AutoAddDevices.
[    66.781] (II) Loader magic: 0x4ce25335a0
[    66.781] (II) Module ABI versions:
[    66.781] 	X.Org ANSI C Emulation: 0.4
[    66.781] 	X.Org Video Driver: 20.0
[    66.781] 	X.Org XInput driver : 22.1
[    66.781] 	X.Org Server Extension : 9.0
[    66.781] (--) PCI:*(0:0:2:0) 8086:0a16:1179:0005 rev 11, Mem @ 0xf0000000/4194304, 0xe0000000/268435456, I/O @ 0x00003000/64
[    66.781] (II) LoadModule: "glx"
[    66.783] (II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
[    66.790] (II) Module glx: vendor="X.Org Foundation"
[    66.790] 	compiled for 1.18.3, module version = 1.0.0
[    66.790] 	ABI class: X.Org Server Extension, version 9.0
[    66.790] (==) AIGLX enabled
[    66.791] (==) Matched intel as autoconfigured driver 0
[    66.791] (==) Matched vesa as autoconfigured driver 1
[    66.791] (==) Assigned the driver to the xf86ConfigLayout
[    66.791] (II) LoadModule: "intel"
[    66.791] (II) Loading /usr/X11R6/lib/modules/drivers/intel_drv.so
[    66.793] (II) Module intel: vendor="X.Org Foundation"
[    66.793] 	compiled for 1.18.3, module version = 2.99.916
[    66.793] 	Module class: X.Org Video Driver
[    66.793] 	ABI class: X.Org Video Driver, version 20.0
[    66.793] (II) LoadModule: "vesa"
[    66.794] (II) Loading /usr/X11R6/lib/modules/drivers/vesa_drv.so
[    66.794] (II) Module vesa: vendor="X.Org Foundation"
[    66.794] 	compiled for 1.18.3, module version = 2.3.3
[    66.794] 	Module class: X.Org Video Driver
[    66.794] 	ABI class: X.Org Video Driver, version 20.0
[    66.794] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    66.795] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[    66.795] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[    66.795] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[    66.795] (II) VESA: driver for VESA chipsets: vesa
[    66.795] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20080730
[    66.796] (WW) Falling back to old probe method for vesa
[    66.796] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4400
[    66.796] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2
[    66.797] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[    66.797] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    66.797] (==) intel(0): RGB weight 888
[    66.797] (==) intel(0): Default visual is TrueColor
[    66.798] (II) intel(0): Output eDP1 has no monitor section
[    66.798] (--) intel(0): Found backlight control interface wscons (type 'platform') for output eDP1
[    66.798] (II) intel(0): Enabled output eDP1
[    66.798] (II) intel(0): Output DP1 has no monitor section
[    66.798] (II) intel(0): Enabled output DP1
[    66.798] (II) intel(0): Output HDMI1 has no monitor section
[    66.798] (II) intel(0): Enabled output HDMI1
[    66.798] (II) intel(0): Output DP2 has no monitor section
[    66.798] (II) intel(0): Enabled output DP2
[    66.798] (II) intel(0): Output HDMI2 has no monitor section
[    66.798] (II) intel(0): Enabled output HDMI2
[    66.798] (--) intel(0): Using a maximum size of 64x64 for hardware cursors
[    66.798] (II) intel(0): Output VIRTUAL1 has no monitor section
[    66.798] (II) intel(0): Enabled output VIRTUAL1
[    66.798] (--) intel(0): Output eDP1 using initial mode 1920x1080 on pipe 0
[    66.798] (--) intel(0): Output DP1 using initial mode 1920x1080 on pipe 1
[    66.799] (==) intel(0): TearFree disabled
[    66.799] (==) intel(0): DPI set to (96, 96)
[    66.799] (II) Loading sub module "dri2"
[    66.799] (II) LoadModule: "dri2"
[    66.799] (II) Module "dri2" already built-in
[    66.799] (II) Loading sub module "present"
[    66.799] (II) LoadModule: "present"
[    66.799] (II) Module "present" already built-in
[    66.799] (II) UnloadModule: "vesa"
[    66.799] (II) Unloading vesa
[    66.799] (==) Depth 24 pixmap format is 32 bpp
[    66.801] (II) intel(0): SNA initialized with Haswell (gen7.5, gt2) backend
[    66.801] (==) intel(0): Backing store enabled
[    66.801] (==) intel(0): Silken mouse disabled
[    66.801] (II) intel(0): HW Cursor enabled
[    66.801] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    66.802] (==) intel(0): DPMS enabled
[    66.803] (II) intel(0): [DRI2] Setup complete
[    66.803] (II) intel(0): [DRI2]   DRI driver: i965
[    66.803] (II) intel(0): [DRI2]   VDPAU driver: i965
[    66.803] (II) intel(0): direct rendering: DRI2 enabled
[    66.803] (II) intel(0): hardware support for Present enabled
[    66.803] (--) RandR disabled
[    66.845] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    66.845] (II) AIGLX: enabled GLX_ARB_create_context
[    66.845] (II) AIGLX: enabled GLX_ARB_create_context_profile
[    66.845] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
[    66.845] (II) AIGLX: enabled GLX_INTEL_swap_event
[    66.845] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[    66.845] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[    66.845] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[    66.845] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
[    66.845] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    66.845] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[    66.845] (II) AIGLX: Loaded and initialized i965
[    66.845] (II) GLX: Initialized DRI2 GL provider for screen 0
[    66.848] (II) intel(0): switch to mode 1920x1080@59.9 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[    66.868] (II) intel(0): switch to mode 1920x1080@59.9 on DP1 using pipe 1, position (0, 0), rotation normal, reflection none
[    66.885] (II) intel(0): Setting screen physical size to 508 x 285
[    66.970] (II) config/wscons: checking input device /dev/wskbd
[    66.970] (II) wskbd: using layout us
[    66.970] (II) LoadModule: "kbd"
[    66.971] (II) Loading /usr/X11R6/lib/modules/input/kbd_drv.so
[    66.972] (II) Module kbd: vendor="X.Org Foundation"
[    66.972] 	compiled for 1.18.3, module version = 1.8.1
[    66.972] 	Module class: X.Org XInput Driver
[    66.972] 	ABI class: X.Org XInput driver, version 22.1
[    66.972] (II) Using input driver 'kbd' for '/dev/wskbd'
[    66.972] (**) /dev/wskbd: always reports core events
[    66.972] (**) /dev/wskbd: always reports core events
[    66.972] (**) Option "Protocol" "standard"
[    66.972] (**) Option "XkbRules" "base"
[    66.972] (**) Option "XkbModel" "pc105"
[    66.972] (**) Option "XkbLayout" "us"
[    66.972] (II) XINPUT: Adding extended input device "/dev/wskbd" (type: KEYBOARD, id 6)
[    67.500] (II) config/wscons: checking input device /dev/wsmouse
[    67.500] (II) LoadModule: "ws"
[    67.503] (II) Loading /usr/X11R6/lib/modules/input/ws_drv.so
[    67.505] (II) Module ws: vendor="X.Org Foundation"
[    67.505] 	compiled for 1.18.3, module version = 1.3.0
[    67.505] 	Module class: X.Org XInput Driver
[    67.505] 	ABI class: X.Org XInput driver, version 22.1
[    67.505] (II) Using input driver 'ws' for '/dev/wsmouse'
[    67.505] (**) /dev/wsmouse: always reports core events
[    67.505] (II) ws: /dev/wsmouse: debuglevel 0
[    67.505] (**) Option "Device" "/dev/wsmouse"
[    67.505] (**) ws: /dev/wsmouse: ZAxisMapping: buttons 4 and 5
[    67.505] (**) ws: /dev/wsmouse: WAxisMapping: buttons 6 and 7
[    67.506] (**) ws: /dev/wsmouse: associated screen: 0
[    68.022] (II) ws: /dev/wsmouse: minimum x position: 0
[    68.022] (II) ws: /dev/wsmouse: maximum x position: 1919
[    68.022] (II) ws: /dev/wsmouse: minimum y position: 0
[    68.022] (II) ws: /dev/wsmouse: maximum y position: 1079
[    68.022] (==) ws: /dev/wsmouse: Buttons: 7
[    68.028] (**) ws: /dev/wsmouse: YAxisMapping: buttons 4 and 5
[    68.028] (II) XINPUT: Adding extended input device "/dev/wsmouse" (type: MOUSE, id 7)
[    68.543] (**) /dev/wsmouse: (accel) keeping acceleration scheme 1
[    68.543] (**) /dev/wsmouse: (accel) acceleration profile 0
[    68.543] (**) /dev/wsmouse: (accel) acceleration factor: 2.000
[    68.543] (**) /dev/wsmouse: (accel) acceleration threshold: 4

And dmesg:

Code:
 OpenBSD 6.0 (GENERIC.MP) #2319: Tue Jul 26 13:00:43 MDT 2016
    deraadt@amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 17068429312 (16277MB)
avail mem = 16546668544 (15780MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.6 @ 0xdcbff000 (42 entries)
bios0: vendor TOSHIBA version "Version 4.20" date 09/02/2015
bios0: TOSHIBA PORTEGE Z30-A
acpi0 at bios0: rev 0
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP HPET APIC MCFG TCPA BOOT MSDM SLIC DBGP SSDT SSDT SSDT ASF! SSDT SSDT SSDT SSDT FPDT
acpi0: wakeup devices GLAN(S4) EHC1(S3) XHC_(S3) HDEF(S3) PXSX(S3) PWRB(S4) LID_(S4)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 14318179 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i7-4600U CPU @ 2.10GHz, 1995.70 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM) i7-4600U CPU @ 2.10GHz, 1995.39 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 1, core 0, package 0
cpu2 at mainbus0: apid 2 (application processor)
cpu2: Intel(R) Core(TM) i7-4600U CPU @ 2.10GHz, 1995.39 MHz
cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
cpu2: 256KB 64b/line 8-way L2 cache
cpu2: smt 0, core 1, package 0
cpu3 at mainbus0: apid 3 (application processor)
cpu3: Intel(R) Core(TM) i7-4600U CPU @ 2.10GHz, 1995.39 MHz
cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
cpu3: 256KB 64b/line 8-way L2 cache
cpu3: smt 1, core 1, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 40 pins
acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PEGP)
acpiprt2 at acpi0: bus 2 (RP03)
acpiprt3 at acpi0: bus 1 (RP06)
acpicpu0 at acpi0: C3(200@506 mwait.1@0x60), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu1 at acpi0: C3(200@506 mwait.1@0x60), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu2 at acpi0: C3(200@506 mwait.1@0x60), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu3 at acpi0: C3(200@506 mwait.1@0x60), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpipwrres0 at acpi0: PDOC, resource for DOCK
acpitz0 at acpi0: critical temperature is 102 degC
"IFX0102" at acpi0 not configured
"TOS7407" at acpi0 not configured
"TTP1000" at acpi0 not configured
"PNP0C14" at acpi0 not configured
acpitoshiba0 at acpi0
"TOS6205" at acpi0 not configured
acpiac0 at acpi0: AC unit offline
acpibtn0 at acpi0: PWRB
acpibtn1 at acpi0: LID_
acpibat0 at acpi0: BAT1 model "G71C000G7210" serial 0 type Li-ION   oem "0"
"INT340E" at acpi0 not configured
"INT33A0" at acpi0 not configured
acpidock0 at acpi0: DOCK not docked (0)
acpivideo0 at acpi0: VGA_
acpivideo1 at acpi0: GFX0
acpivout at acpivideo1 not configured
cpu0: Enhanced SpeedStep 1995 MHz: speeds: 2701, 2700, 2600, 2400, 2300, 2100, 2000, 1800, 1700, 1600, 1400, 1300, 1100, 1000, 800, 756 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 4G Host" rev 0x0b
inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics" rev 0x0b
drm0 at inteldrm0
inteldrm0: msi
inteldrm0: 1024x768
error: [drm:pid0:intel_dp_set_idle_link_train] *ERROR* Timed out waiting for DP idle patterns
wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
azalia0 at pci0 dev 3 function 0 "Intel Core 4G HD Audio" rev 0x0b: msi
azalia0: No codecs found
xhci0 at pci0 dev 20 function 0 "Intel 8 Series xHCI" rev 0x04: msi
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
"Intel 8 Series MEI" rev 0x04 at pci0 dev 22 function 0 not configured
puc0 at pci0 dev 22 function 3 "Intel 8 Series KT" rev 0x04: ports: 1 com
com4 at puc0 port 0 apic 2 int 19: ns16550a, 16 byte fifo
com4: probed fifo depth: 0 bytes
em0 at pci0 dev 25 function 0 "Intel I218-LM" rev 0x04: msi, address b8:6b:23:b4:9f:8d
azalia1 at pci0 dev 27 function 0 "Intel 8 Series HD Audio" rev 0x04: msi
azalia1: codecs: Realtek/0x0283
audio0 at azalia1
ppb0 at pci0 dev 28 function 0 "Intel 8 Series PCIE" rev 0xe4: msi
pci1 at ppb0 bus 1
rtsx0 at pci1 dev 0 function 0 "Realtek RTS5227 Card Reader" rev 0x01: msi
sdmmc0 at rtsx0: 4-bit
ppb1 at pci0 dev 28 function 2 "Intel 8 Series PCIE" rev 0xe4: msi
pci2 at ppb1 bus 2
iwm0 at pci2 dev 0 function 0 "Intel Dual Band Wireless AC 7260" rev 0x6b, msi
ehci0 at pci0 dev 29 function 0 "Intel 8 Series USB" rev 0x04: apic 2 int 23
usb1 at ehci0: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
pcib0 at pci0 dev 31 function 0 "Intel 8 Series LPC" rev 0x04
ahci0 at pci0 dev 31 function 2 "Intel 8 Series AHCI" rev 0x04: msi, AHCI 1.3
ahci0: port 0: 6.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, SAMSUNG MZMTE256, EXT4> SCSI3 0/direct fixed naa.50025388a08f8f1e
sd0: 244198MB, 512 bytes/sector, 500118192 sectors, thin
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
uhidev0 at uhub0 port 1 configuration 1 interface 0 "SIGMACHIP USB Keyboard" rev 1.10/1.10 addr 2
uhidev0: iclass 3/1
ukbd0 at uhidev0: 8 variable keys, 6 key codes
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
uhidev1 at uhub0 port 1 configuration 1 interface 1 "SIGMACHIP USB Keyboard" rev 1.10/1.10 addr 2
uhidev1: iclass 3/0, 2 report ids
uhid0 at uhidev1 reportid 1: input=2, output=0, feature=0
uhid1 at uhidev1 reportid 2: input=1, output=0, feature=0
run0 at uhub0 port 2 configuration 1 interface 0 "Ralink 802.11 n WLAN" rev 2.00/1.01 addr 3
run0: MAC/BBP RT3070 (rev 0x0201), RF RT3020 (MIMO 1T1R), address 64:70:02:29:6e:27
umsm0 at uhub0 port 4 configuration 1 interface 0 "HUAWEI Technology HUAWEI Mobile" rev 2.00/2.28 addr 4
ucom0 at umsm0
umsm1 at uhub0 port 4 configuration 1 interface 1 "HUAWEI Technology HUAWEI Mobile" rev 2.00/2.28 addr 4
ucom1 at umsm1
umsm2 at uhub0 port 4 configuration 1 interface 2 "HUAWEI Technology HUAWEI Mobile" rev 2.00/2.28 addr 4
ucom2 at umsm2
umsm3 at uhub0 port 4 configuration 1 interface 3 "HUAWEI Technology HUAWEI Mobile" rev 2.00/2.28 addr 4
ucom3 at umsm3
umsm4 at uhub0 port 4 configuration 1 interface 4 "HUAWEI Technology HUAWEI Mobile" rev 2.00/2.28 addr 4
ucom4 at umsm4
umsm5 at uhub0 port 4 configuration 1 interface 5 "HUAWEI Technology HUAWEI Mobile" rev 2.00/2.28 addr 4
ucom5 at umsm5
uhidev2 at uhub0 port 5 configuration 1 interface 0 "Logitech USB-PS/2 Optical Mouse" rev 2.00/27.20 addr 5
uhidev2: iclass 3/1
ums0 at uhidev2: 8 buttons, Z and W dir
wsmouse1 at ums0 mux 0
uhub2 at uhub0 port 6 "Genesys Logic USB2.0 Hub" rev 2.10/88.30 addr 6
ugen0 at uhub2 port 2 "Validity Sensors product 0x0010" rev 1.10/0.78 addr 7
uvideo0 at uhub0 port 7 configuration 1 interface 0 "Chicony Electronics Co.,Ltd. TOSHIBA Web Camera - FHD" rev 2.00/83.73 addr 8
video0 at uvideo0
uhub3 at uhub1 port 1 "Intel Rate Matching Hub" rev 2.00/0.04 addr 2
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on sd0a (79b29a08f8f5bd7f.a) swap on sd0b dump on sd0b
iwm0: hw rev 0x140, fw ver 16.242414.0, address 5c:c5:d4:45:cb:49
error: [drm:pid93027:intel_dp_set_idle_link_train] *ERROR* Timed out waiting for DP idle patterns
acpivideo1: unknown event 0x00
iwm0: could not initiate scan
iwm0: fatal firmware error
iwm0: fatal firmware error
acpivideo1: unknown event 0x00
acpivideo1: unknown event 0x00
error: [drm:pid52059:intel_dp_set_idle_link_train] *ERROR* Timed out waiting for DP idle patterns
acpivideo1: unknown event 0x00
Reply With Quote
  #4   (View Single Post)  
Old 20th March 2017
shep shep is offline
Rc.conf Instructor
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 1,035
Default

Toshiba also uses an Elantech touchpad:
Toshiba Forum

This may be of some help
Undeadly - Preparing multitouch support
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard lockup when scrolling terminal caravel FreeBSD General 0 7th January 2014 11:22 AM
HP kills TouchPad ocicat News 10 21st March 2012 05:31 PM
How to disable touchpad gpatrick OpenBSD General 3 4th March 2012 03:36 PM
Scrolling touchpad on T500 There0 OpenBSD General 0 28th December 2009 08:01 PM
Cannot get touchpad to scroll! cgc2 FreeBSD General 5 16th August 2008 05:53 PM


All times are GMT. The time now is 01:27 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick